View Issue Details

IDProjectCategoryView StatusLast Update
0002698Ham Radio DeluxeBugpublic2019-02-25 10:15
ReporterKB3NPHAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.5.0.196 
Summary0002698: IC-7300 Vd Inconsistency between radio and HRD Display
DescriptionThe calibration of the Vd: indication

The Icom bar graph on the radio has an indicated range of 10 to 16. The measured supply voltage into my radio is 13.80 but the Vd: indication on HRD is 16.1. The 2 indications are correct at 13.0.

These are the measurements I've taken:

Supply HRD
10.5 3.3
11.0 5.2
11.5 7.2
12.0 9.1
12.5 11.1
13.0 13.0
13.5 14.9
14.0 16.8
14.5 18.8
15.0 20.7

Thank You for hopefully correcting this problem,

Steve Dunkle - KE3PL
Additional InformationTicket #796007
TagsIC-7300, ICOM
ModuleRig Control
Sub-ModuleFunctional
Testing Beta Successful

Relationships

related to 0003082 closedK7ZCZ IC-7610 Volt & Ampere values are wrongly displayed in Rig Control 

Activities

K7ZCZ

2018-05-01 23:18

administrator   ~0004921

This is actually kind of hard to fix because Icom doesn't document the feature very well. The manual says that the response for the Vdd query has a range of 0 to 255. It says that 0 means 0 volts (uh ...), 13 means 10 volts, and 241 is 16 volts. This isn't linear, obviously; but there's no mention of a function which properly converts the range is given.

I think the best we can do is trying the assumption that there's two linear ranges; one from 0(0) thru 13(10), and the other from 13(10) thru 241(16).

Most Icom radios have parameters like this; those that do have several (power, Idd, Compression; maybe S-meter, ...)

K7ZCZ

2019-02-09 10:11

administrator   ~0007339

Maybe we can conclude that the Icom values given aren't meant to imply some range between 0 and 10 volts exists; let's assume that under 10 volts, the radio won't even operate.

That leaves us to translate the range of responses from 151 (10 volts) to 211 (16 volts). We can do so with this function:

voltage = 10 + (radioValue - 13) / 38


where radioValue is the value reported from the radio by the 0x15-15 command, and the voltage is the operating Vd voltage of the radio.

The customer here gives an "HRD reports" value along with an actual, measured voltage.

Turns out HRD is getting the value from the radio and dividing it by 10 -- I guess at some point, someone assumed that was correct or close enough. Given that, though, we know that the value reported by the radio is 10 times the "HRD Reports" number.

If we translate the values accordingly and use the equation developed above, we end up with values that are right on -- within about 5-hundredths of a volt. These calculations are all in the attached spreadsheet.

K7ZCZ

2019-02-09 10:13

administrator  

Mantis 2698 Icom Voltage.xlsx (12,463 bytes)

K7ZCZ

2019-02-10 13:26

administrator   ~0007346

The only adjustable power supply I have is an HP E3630A, which is only good for half an amp towards the 20-volt adjustable output. That's not enough to power on my IC-7610, so I can't test this change directly.

And it turns out the IC-7300, IC-7600, and IC-7610 have slightly different mappings for the value returned from the radio to the actual current read. Rig Control doesn't have very good support for per-radio, scalable parameters.

And so, I've added it! I've used the new code for the IC-7100, IC-7300, IC-7600, IC-7610, and IC-7700. The IC-7410, IC-9100, and IC-R9000 don't document the Vd and Id query commands, so I've left them as-is. Maybe they could be fixed with information from Icom, maybe they should be removed.

K7ZCZ

2019-02-10 13:26

administrator   ~0007347

Last edited: 2019-02-10 13:28

View 2 revisions

Resolved with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4819

note that this fix addresses issues with Vd and Id, and fixes several radios:

IC-7100
IC-7300
IC-7600
IC-7610
IC-7700

K7ZCZ

2019-02-11 17:08

administrator   ~0007354

Could've done a better job with cleaning up the old implementation, so I've done this checkin to fix it:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4820

WA9PIE

2019-02-25 10:15

administrator   ~0007500

Validated by customer

Issue History

Date Modified Username Field Change
2018-05-01 11:18 KB3NPH New Issue
2018-05-01 23:18 K7ZCZ Note Added: 0004921
2018-11-27 23:29 WA9PIE Tag Attached: Icom IC-7300
2018-11-30 16:39 WA9PIE Tag Attached: ICOM
2018-11-30 16:40 WA9PIE Tag Attached: IC-7300
2018-11-30 16:40 WA9PIE Tag Detached: Icom IC-7300
2019-01-22 16:57 K7ZCZ Relationship added related to 0003082
2019-02-09 10:11 K7ZCZ Note Added: 0007339
2019-02-09 10:13 K7ZCZ File Added: Mantis 2698 Icom Voltage.xlsx
2019-02-10 13:26 K7ZCZ Note Added: 0007346
2019-02-10 13:26 K7ZCZ Assigned To => K7ZCZ
2019-02-10 13:26 K7ZCZ Status new => resolved
2019-02-10 13:26 K7ZCZ Resolution open => fixed
2019-02-10 13:26 K7ZCZ Note Added: 0007347
2019-02-10 13:28 K7ZCZ Note Edited: 0007347 View Revisions
2019-02-11 17:08 K7ZCZ Note Added: 0007354
2019-02-11 20:46 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2019-02-13 07:59 K7ZCZ Fixed in Version => 6.5.0.192
2019-02-20 00:44 WA9PIE Summary Ticket #796007 - IC-7300 Vd Inconsistency between radio and HRD Display => IC-7300 Vd Inconsistency between radio and HRD Display
2019-02-20 00:44 WA9PIE Additional Information Updated View Revisions
2019-02-24 14:35 WA9PIE Fixed in Version 6.5.0.192 => 6.5.0.196
2019-02-24 15:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2019-02-25 10:15 WA9PIE Status resolved => closed
2019-02-25 10:15 WA9PIE Testing Not Started => Beta Successful
2019-02-25 10:15 WA9PIE Note Added: 0007500