View Issue Details

IDProjectCategoryView StatusLast Update
0002700Ham Radio DeluxeMaintenancepublic2018-05-13 15:26
ReporterWA9PIE 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.840 
Summary0002700: Update Ham Radio Deluxe domain in URLs or links in the application
DescriptionFind and replace any "ham-radio-deluxe.com" domain names in links in the software to "hamradiodeluxe.com".
Also, if any still exist, find and replace any "hrdsoftwarell.com" domain names in links in the software to "hamradiodeluxe.com" (exception is when hrdsoftwarellc.com is used in an email address; keep that).

With one exception, all URLs (links) are SSL and should begin with "https://" (rather than "http://"). The exception is that the Release Notes URL (link) begins with "http://" (http://ReleaseNotes.HamRadioDeluxe.com).

The download URL for the country files should begin with "https://cdn2.hamradiodeluxe.com".

There's no urgency about this, as the former sites are being redirected with 301 or DNS.

That is all.

TagsNo tags attached.
ModuleAll
Sub-ModuleGeneral
Testing Beta Successful

Relationships

related to 0002656 closedWA9PIE CDN prevents access to Logbook country 

Activities

K7ZCZ

2018-05-04 12:45

manager   ~0004947

The URL provided for country file downloads doesn't work; looks like the SLL cert doesn't match the domain (but maybe something else is wrong).

K7ZCZ

2018-05-04 16:22

manager   ~0004954

This shelved change set addresses this issue. It can be checked-in when the CDN problems are resolved and the change is viable.

https://hrdsoftware.visualstudio.com/HRD/_versionControl/shelveset?ss=update%20URLs%3Bmikeblas%40msn.com

WA9PIE

2018-05-08 20:51

administrator   ~0004977

Fixed this by adding a DNS entry for cdn2.hamradiodeluxe.com, adding this DNS entry in the CDN, and added an SSL certificate to the URL in the CDN (image attached). This should be done.

CDN Domains.png (64,767 bytes)
CDN Domains.png (64,767 bytes)

K7ZCZ

2018-05-09 18:01

manager   ~0004982

Fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4114

g3ucq

2018-05-10 15:45

viewer   ~0004989

FIxed

WA9PIE

2018-05-12 01:21

administrator   ~0005018

Excellent fix!

Issue History

Date Modified Username Field Change
2018-05-02 14:44 WA9PIE New Issue
2018-05-02 14:44 WA9PIE Status new => assigned
2018-05-02 14:44 WA9PIE Assigned To => K7ZCZ
2018-05-04 12:45 K7ZCZ Assigned To K7ZCZ => WA9PIE
2018-05-04 12:45 K7ZCZ Note Added: 0004947
2018-05-04 16:22 K7ZCZ Note Added: 0004954
2018-05-04 16:23 K7ZCZ Relationship added related to 0002656
2018-05-08 20:51 WA9PIE File Added: CDN Domains.png
2018-05-08 20:51 WA9PIE Note Added: 0004977
2018-05-08 20:52 WA9PIE Assigned To WA9PIE => K7ZCZ
2018-05-09 18:01 K7ZCZ Status assigned => resolved
2018-05-09 18:01 K7ZCZ Resolution open => fixed
2018-05-09 18:01 K7ZCZ Note Added: 0004982
2018-05-09 23:28 K7ZCZ Fixed in Version => 6.4.0.839
2018-05-10 15:45 g3ucq Note Added: 0004989
2018-05-12 01:21 WA9PIE Status resolved => closed
2018-05-12 01:21 WA9PIE Testing Not Started => Beta Successful
2018-05-12 01:21 WA9PIE Note Added: 0005018
2018-05-13 15:25 WA9PIE Fixed in Version 6.4.0.839 => 6.4.0.840
2018-05-13 15:26 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe