View Issue Details

IDProjectCategoryView StatusLast Update
0002707Ham Radio DeluxeEnhancementpublic2019-07-01 14:20
Reporterg3ucqAssigned ToDOUG 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.6.0.236 
Summary0002707: 30 day trial not available on installation
DescriptionI had created a new Windows 10 64 bit OS and installed HRD .837.
I tried to run the Trial version from the installation but clicking the trial button did not allow it.
Steps To ReproduceStart a completely fresh installation of HRD and when the Activation/or Trial screen is reached, pressing the Trial button did not proceed the installation. As I did not have my Activation key available I had to can the install.
Later, when I had my key, I was able to finish the installation.
TagsNo tags attached.
ModuleSW License Mgmt
Sub-ModuleSW License Client
Testing Beta Successful

Activities

PD9FER

2018-05-15 04:02

viewer   ~0005046

If you have a key assigned, it is not possible to use the trial.
This is per design.
Not a Bug

g3ucq

2018-05-15 04:58

viewer   ~0005047

Ferry. My key was not immediately available so why could I not run the trial and add the key later?
This is the first software I have installed that had to be installed this way.

PD9FER

2018-05-15 09:17

viewer   ~0005050

This is just how it is implemented and want it to work.
If a customer has no access to their key, they should contact Support and will be given the requested key.

KB3NPH

2018-05-15 09:52

administrator   ~0005051

John,
The policy at HRD has always been that if you own a license key for HRD, you will not be able to run the trial version. This has been in effect since V6.0 was released in 2012. The reason for this is to prevent a person who has not purchased HRD from running trial after trial after trial after trial and never purchasing it. For those who, for some reason whether issues in the HRD software or other valid reason, requires a new free trial, we do have the capabilities to provide that, but if they are listed in our License Manager as either running the trial in the past or if they are listed as having a valid license key, then the HRD software will not run unless you enter a valid license key.

If you lost your key, we can certainly provide it for you. Just open a support ticket for support or sales requesting a copy of your license key and we'll be than happy to send it to you.

g3ucq

2018-05-15 11:00

viewer   ~0005053

I suppose software can be hacked so that it is possible to run trial after trial but for me, when a trial period is up that is it. The software no longer runs.

WA9PIE

2018-06-05 17:43

administrator   ~0005208

This is actually a use-case that needs to be considered when we implement Soraco. That is...

If an existing customer wants to do a trial of the latest features before buying a renewal, they should be able to try the new features without purchasing the renewal. After 30 days, the features should be grey'd out (or otherwise locked out) unless/until they purchase the renewal.

Point being... they SHOULD install the latest because that's how we deliver bug fixes. But we SHOULD NOT enable features for more than 30 days.

g3ucq

2018-07-22 04:06

viewer   ~0005753

"Point being... they SHOULD install the latest because that's how we deliver bug fixes. But we SHOULD NOT enable features for more than 30 days. "
That is how it should be.

WA9PIE

2018-07-23 12:46

administrator   ~0005757

This is a use-case that is under consideration for the new license server code (Soraco). That said, this won't be addressed until after Soraco is implemented in v6.5.

Customers should always download and install the latest version to get the benefits of bug fixes, to the extent that it is "commercially and technically feasible for us to do so." [All agree. We've always done that.]

Significant new features should only be enabled when the expiration date of Software Maintenance and Support is greater than the date of the feature release. In this case, existing customers can renew and enjoy the benefit of all new enhancements released up to the date of their SM&S expiration.

The problem is... there is presently no way to enable an existing customer to do a trial of new features before committing to a renewal (even though a non-customer would be able to try these features because their call does not exist in the license server).

So... we do want to enable existing customers to try new features before they commit to the renewal. But this won't be fixed in the current license code. So I'm moving this item back into the backlog as a child enhancement request under the Soraco enhancement.

WA9PIE

2019-06-10 18:35

administrator   ~0008027

Ok, we're changing the approach for doing a trial. From the 6.6 release forward, users need to register for the trial on a website. It won't be possible to do it directly from within Ham Radio Deluxe. The website collects callsign, name, and email address... then sends the key to the user via email.

Further... the new license server (QLM) will provide current customers with the ability to do a trial of future versions ahead of their purchase.

Here's what needs to happen here.

Doug - put a link in the License Manager dialog box (somewhere down below) that has the trial URL (I'm not putting the URL in this Mantis issue; email me and I'll give you the URL). An argument could be made that the trial URL should be there only when there is no activated key in the client. (if that's possible) Existing users who want to do a trial can get that information elsewhere.

DOUG

2019-06-10 21:38

developer   ~0008028

Email sent

DOUG

2019-06-10 22:45

developer   ~0008030

Url link has been added will be in next build for testing

WA9PIE

2019-06-22 16:15

administrator   ~0008172

I just tested this. It's both code and process. Customer downloads software and tries to launch it, the hyperlink is there that takes them to a page where they can obtain a trial key. When they come back and put the trial key in, it works as expected.

Issue History

Date Modified Username Field Change
2018-05-08 09:22 g3ucq New Issue
2018-05-15 04:02 PD9FER Note Added: 0005046
2018-05-15 04:58 g3ucq Note Added: 0005047
2018-05-15 09:17 PD9FER Note Added: 0005050
2018-05-15 09:39 PD9FER Status new => resolved
2018-05-15 09:39 PD9FER Resolution open => fixed
2018-05-15 09:39 PD9FER Testing => Not Started
2018-05-15 09:52 KB3NPH Note Added: 0005051
2018-05-15 11:00 g3ucq Note Added: 0005053
2018-05-23 09:49 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2018-06-05 17:43 WA9PIE Note Added: 0005208
2018-07-19 19:40 K7ZCZ Fixed in Version => 6.4.0.872
2018-07-22 04:06 g3ucq Note Added: 0005753
2018-07-23 12:46 WA9PIE Status resolved => confirmed
2018-07-23 12:46 WA9PIE Resolution fixed => reopened
2018-07-23 12:46 WA9PIE Category Bug => Enhancement
2018-07-23 12:46 WA9PIE Fixed in Version 6.4.0.872 =>
2018-07-23 12:46 WA9PIE Note Added: 0005757
2018-07-23 12:46 WA9PIE Assigned To => DOUG
2018-07-23 12:46 WA9PIE Status confirmed => assigned
2019-06-10 18:35 WA9PIE Note Added: 0008027
2019-06-10 21:38 DOUG Note Added: 0008028
2019-06-10 22:45 DOUG Note Added: 0008030
2019-06-11 00:57 WA9PIE Status assigned => resolved
2019-06-11 00:57 WA9PIE Resolution reopened => fixed
2019-06-11 00:57 WA9PIE Fixed in Version => 6.6.0.228
2019-06-11 00:57 WA9PIE Module All => QLM
2019-06-11 00:57 WA9PIE Sub-Module Install => QLM Client
2019-06-13 14:47 WA9PIE Module QLM => SW License Mgmt
2019-06-15 10:36 WA9PIE Sub-Module QLM Client => SW License Client
2019-06-22 16:15 WA9PIE Status resolved => closed
2019-06-22 16:15 WA9PIE Fixed in Version 6.6.0.228 => 6.6.0.234
2019-06-22 16:15 WA9PIE Testing Not Started => Beta Successful
2019-06-22 16:15 WA9PIE Note Added: 0008172
2019-07-01 14:18 WA9PIE Fixed in Version 6.6.0.234 => 6.6.0.236
2019-07-01 14:20 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe