View Issue Details

IDProjectCategoryView StatusLast Update
0002710Ham Radio DeluxeBugpublic2018-11-11 00:34
ReporterPD9FER 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityunable to reproduce
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.902 
Summary0002710: No Buttons are showing in Rig Control when connected to an IC-7851
DescriptionCan connect my IC-7851 properly to rig control. But I do not see the graphical "radio operating buttons" to the left and right of the frequency indication/setting area in rig control.
However, when I am connecting my other ICOM TRX (IC-7700, IC-7300), I have all the radio buttons I need to control the TRX via rig control to the left and right of the frequency indication/setting area.
Steps To ReproduceAsked around for other 7851 users but no success,
Additional InformationTicket #475591
Screenshots attached.
TagsNo tags attached.
ModuleRig Control
Sub-ModuleRadio Support
Testing Beta Successful

Relationships

related to 0002314 resolvedPD9FER 3 - Current Dev List IC-7851 Mode does not changes on cluster spot selection 
related to 0002938 new 3 - Current Dev List Rig Control: some IC-7851 buttons not working, missing 

Activities

PD9FER

2018-05-09 05:23

viewer  

ICOM IC-7300 RigControl Main Screen.JPG (287,279 bytes)
ICOM IC-7851 RigControl Main Screen.JPG (269,274 bytes)

K7ZCZ

2018-11-01 23:22

manager   ~0006360

Seems like this issue at least partially overlaps 2314

K7ZCZ

2018-11-01 23:24

manager   ~0006361

This issue is fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4402

PD9FER

2018-11-05 12:29

viewer   ~0006386

Send the Beta to customer and am waiting for his reply

PD9FER

2018-11-06 03:15

viewer   ~0006393

Customer comment:
I just made a smoke test:

1. I see the buttons now – and they work!, as far as I was able to test them in the short time.
2. At a first glance, I am missing some buttons:

a. The MP-W and the MP-R buttons; I like to use them quite often.

b. The V/M button; you replaced it with the two buttons VFO and MEM ?

c. The M = S button should rather read M > S;
 on the 7851 front panel, this button always copies from M to S, independently of which receiver (main or sub) is active.

d. The APF button; on the “real” 7851 it is combined with the TPF button. In your HRD layout it is missing.
 However, I accept that this APF button is not so important to see it in HRD since this function is depending to the adjustment of the allocated knob on the TRX’ front panel.

e. It would be nice to have the “Main” and “Sub” button side by side instead of one above the other. This would be more like the arrangement on the 785’1 front panel.

f. In my 7851, I have inhibited to be able to switch the antenna matrix via remote control – for safety reasons. It would however be nice to be able to toggle between the programmed TX Antenna (1, 2, 3 or 4) to the RX-I/O antenna .
 This is a function I use very often during contesting.


3. There may be more nice “cosmetics” possible. For the moment I am happy to see the working buttons in HRD. Congratulations!

73, Fred HB9EPP

K7ZCZ

2018-11-07 20:54

manager   ~0006398

I have created 2938 to track the reported issues, since they're orthogonal to the originally reported problem -- and that originally reported problem is fixed.

Issue History

Date Modified Username Field Change
2018-05-09 05:23 PD9FER New Issue
2018-05-09 05:23 PD9FER File Added: ICOM IC-7300 RigControl Main Screen.JPG
2018-05-09 05:23 PD9FER File Added: ICOM IC-7851 RigControl Main Screen.JPG
2018-11-01 23:22 K7ZCZ Relationship added related to 0002314
2018-11-01 23:22 K7ZCZ Note Added: 0006360
2018-11-01 23:24 K7ZCZ Assigned To => K7ZCZ
2018-11-01 23:24 K7ZCZ Status new => resolved
2018-11-01 23:24 K7ZCZ Resolution open => fixed
2018-11-01 23:24 K7ZCZ Sub-Module Appearance/UI => Radio Support
2018-11-01 23:24 K7ZCZ Testing => Not Started
2018-11-01 23:24 K7ZCZ Note Added: 0006361
2018-11-04 07:48 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2018-11-04 07:49 K7ZCZ Fixed in Version => 6.4.0.900
2018-11-05 12:29 PD9FER Note Added: 0006386
2018-11-06 03:15 PD9FER Note Added: 0006393
2018-11-07 20:53 K7ZCZ Relationship added related to 0002938
2018-11-07 20:54 K7ZCZ Note Added: 0006398
2018-11-08 22:13 WA9PIE Status resolved => closed
2018-11-08 22:13 WA9PIE Description Updated View Revisions
2018-11-08 22:13 WA9PIE Additional Information Updated View Revisions
2018-11-08 22:13 WA9PIE Testing Not Started => Beta Successful
2018-11-11 00:34 WA9PIE Fixed in Version 6.4.0.900 => 6.4.0.902
2018-11-11 00:34 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe