View Issue Details

IDProjectCategoryView StatusLast Update
00027344 - Closed w/o ActionBugpublic2019-02-21 15:51
ReporterPD9FERAssigned ToPD9FER 
PrioritynormalSeveritycrashReproducibilityunable to reproduce
Status closedResolutionreopened 
Summary0002734: Rig Controll Crashes on changing Bands
DescriptionWhen change bands using application , ham radio deluxe crashes.
running latest windows 10 version 1803 OS build 17134.48
Steps To ReproduceN/A
Additional InformationWin 10 V.1803 Build 17134.48 64 bit
Radio: Yaesu FT-991A

Multiple minidumps added in Dumps folder
TagsFT-991A, Yaesu
ModuleRig Control
Sub-ModuleRig Control
TestingNot Started

Relationships

related to 0002152 assignedK7ZCZ 3 - Current Dev List Bandscope crashes Rig Control 

Activities

PD9FER

2018-05-23 02:07

updater   ~0005091

Ticket #371377
Mantis_ID-0002734.rar

K7ZCZ

2018-12-13 15:59

manager   ~0006621

The description of the bug doesn't provide any information -- just that a crash somehow happened. There are multiple ways that the application might be asked to change bands, but the bug doesn't specify which mechanism was used when the crash was witnessed.

The provided *.RAR file contains 14 files.

Two of them are *.partial files, as if this archive was created before the files finished downloading. I will ignore those.

One is a dump from DM780, and this bug is about Rig Control, so I will ignore that one.

That leaves 11 dump files to investigate for clues. All but one of those dump files shows a crash related to the charting control used to draw the band scope. Some of the dumps have a bad stack that ends at the charting control, others have a useful stack that shows the crash, like this:


0:000> kb
  *** Stack trace for last set context - .thread/.cxr resets it
 # ChildEBP RetAddr  Args to Child              
WARNING: Stack unwind information not available. Following frames may be wrong.
00 01eff148 10020528 041855a0 04186278 00000001 olch2d32+0x21214
*** WARNING: Unable to verify checksum for HamRadioDeluxe.exe
01 01eff218 00e30f25 041855a0 00000001 00000125 olch2d32+0x20528
02 01eff29c 00e30e33 01eff2c0 00e30e20 067f53fc HamRadioDeluxe!CBandscopeDlg::SelectFrequency+0xd5 [c:\ham radio\hamradiodeluxe\bandscopedlg.cpp @ 1092] 
03 01eff2b4 00fb97c0 00000000 00000125 00000001 HamRadioDeluxe!CBandscopeDlg::OnMouseMove+0x13 [c:\ham radio\hamradiodeluxe\bandscopedlg.cpp @ 1042] 
04 01eff370 00fbaaef 01468dc8 00000000 00010125 HamRadioDeluxe!CWnd::OnWndMsg+0x503 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 2473] 
05 01eff390 00fb61db 00000200 00000000 00010125 HamRadioDeluxe!CWnd::WindowProc+0x22 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 2094] 
06 01eff400 00fb6990 067f53fc 00050da6 00000200 HamRadioDeluxe!AfxCallWndProc+0xb0 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 285] 
07 01eff420 73bebe6b 00050da6 00000200 00000000 HamRadioDeluxe!AfxWndProc+0x34 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 434] 
08 01eff44c 73be833a 00fb695c 00050da6 00000200 user32!_InternalCallWinProc+0x2b
09 01eff534 73bcbeca 00fb695c 00000000 00000200 user32!UserCallWinProcCheckWow+0x3aa
0a 01eff5a0 73bcbab1 02cc9610 00000000 00010125 user32!SendMessageWorker+0x20a
0b 01eff5d8 100449a1 00050da6 00000200 00000000 user32!SendMessageA+0x131
0c 01eff62c 73be85fc 00000000 7704f5b0 012aa590 olch2d32+0x449a1
0d 01eff704 00000000 00000000 00000000 00000000 user32!UserCallWinProcCheckWow+0x66c




The issue of the bandscope crashing is tracked by Mantis 2152.

Either this is a duplicate of 2152 (because the crash is actually in the band scope graphing library) or the issue is "not repro" because the description of the problem doesn't match the dump files provided.

PD9FER

2018-12-28 05:23

updater   ~0006819

Asked customer in Ticket 371377 if the issue still exists when trying 6.5.0.163
Awaiting feedback

WA9PIE

2019-01-09 15:12

administrator   ~0006930

I tried this today and can't replicate it.

WA9PIE

2019-02-13 13:28

administrator   ~0007375

I've gone through this with my FT-991A and this is not happening at this point.

This was likely eliminated during the FT-991A fixes done in the 183 build.

Closing without action.

K7ZCZ

2019-02-13 13:43

manager   ~0007378

The FT-991 fixes were unlikely to have an effect on the root cause of this issue based on the call stack in the provided minidump.

There are similar crash patterns throughout the Rig Control application where it interacts with the graphing control. See 2152 for a similar, but different example.

PD9FER

2019-02-13 15:54

updater   ~0007384

Never got a customer reply

Issue History

Date Modified Username Field Change
2018-05-23 02:02 PD9FER New Issue
2018-05-23 02:07 PD9FER Note Added: 0005091
2018-11-27 22:14 WA9PIE Tag Attached: FT991A
2018-11-29 00:21 WA9PIE Tag Attached: Yaesu FT-991(A)
2018-11-29 00:21 WA9PIE Tag Detached: FT991A
2018-11-30 18:12 WA9PIE Tag Attached: Yaesu
2018-11-30 18:13 WA9PIE Tag Attached: FT-991
2018-11-30 18:14 WA9PIE Tag Attached: FT-991A
2018-11-30 18:17 WA9PIE Tag Detached: FT-991
2018-11-30 18:17 WA9PIE Tag Detached: Yaesu FT-991(A)
2018-12-13 00:01 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-12-13 15:59 K7ZCZ Note Added: 0006621
2018-12-13 16:00 K7ZCZ Relationship added related to 0002152
2018-12-13 16:00 K7ZCZ Assigned To => K7ZCZ
2018-12-13 16:00 K7ZCZ Status new => resolved
2018-12-13 16:00 K7ZCZ Resolution open => unable to reproduce
2018-12-13 16:00 K7ZCZ Assigned To K7ZCZ => PD9FER
2018-12-27 16:39 WA9PIE Status resolved => feedback
2018-12-27 16:39 WA9PIE Resolution unable to reproduce => reopened
2018-12-28 05:23 PD9FER Note Added: 0006819
2019-01-09 15:12 WA9PIE Note Added: 0006930
2019-02-10 22:15 WA9PIE Severity minor => crash
2019-02-13 13:28 WA9PIE Status feedback => closed
2019-02-13 13:28 WA9PIE Resolution reopened => unable to reproduce
2019-02-13 13:28 WA9PIE Note Added: 0007375
2019-02-13 13:43 K7ZCZ Status closed => new
2019-02-13 13:43 K7ZCZ Resolution unable to reproduce => reopened
2019-02-13 13:43 K7ZCZ Note Added: 0007378
2019-02-13 15:54 PD9FER Note Added: 0007384
2019-02-21 15:51 WA9PIE Status new => closed
2019-02-21 15:51 WA9PIE Project 3 - Current Dev List => 4 - Closed w/o Action