View Issue Details

IDProjectCategoryView StatusLast Update
0002739Ham Radio DeluxeBugpublic2018-07-25 20:47
ReporterPD9FER 
Assigned ToPD9FER 
PrioritynormalSeverityminorReproducibilityrandom
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.873 
Summary0002739: HRD Rotator spontanious locking up/freezing build 840
Descriptionsince Build 780, the latest release of the HRDRotator.exe, application has failed to function properly by locking up for no reason after an hour or so of running and especially when trying to exit "X" out of the program, it hangs up and must be forced to close. now back to running build 806 with build 780 HRDRotator.exe and all is good. Build 787 was the first time in many versions that the rotator failed to function properly.
Steps To ReproduceJust use the program, it is too random too do replication.
Additional InformationTicket #602390

Minidump added to the Dumps folder
TagsNo tags attached.
ModuleRotator
Sub-ModuleGeneral
Testing Beta Successful

Relationships

has duplicate 0002701 closedPD9FER Rotor application crashes on use 

Activities

PD9FER

2018-05-25 02:56

viewer   ~0005110

Mantis_ID-0002739-HRDRotator.rar

K7ZCZ

2018-05-25 15:52

manager   ~0005112

This bug says there's an issue with Build 860, but the provided dump is from Build 840.

Which version is the customer actually using?

0:000:x86> lmDvmHRDRotator
Browse full module list
start    end        module name
012a0000 01d11000   HRDRotator   (export symbols)       HRDRotator.exe
    Loaded symbol image file: HRDRotator.exe
    Image path: C:\Program Files (x86)\HRD SOFTWARE LLC\HAM RADIO DELUXE\HRDRotator.exe
    Image name: HRDRotator.exe
    Browse all global symbols  functions  data
    Timestamp:        Sun May 13 12:15:15 2018 (5AF88EC3)
    CheckSum:         0086D638
    ImageSize:        00A71000
    File version:     6.4.0.840
    Product version:  6.4.0.840
    File flags:       0 (Mask 3F)
    File OS:          4 Unknown Win32
    File type:        1.0 App
    File date:        00000000.00000000
    Translations:     0409.04b0
    CompanyName:      HRD Software, LLC
    ProductName:      HRD Rotator
    InternalName:     Rotator
    OriginalFilename: Rotator.EXE
    ProductVersion:   6.4.0.840
    FileVersion:      6.4.0.840
    SpecialBuild:     Release 6.4.0.840
    FileDescription:  Ham Radio Deluxe Rotator Application
    LegalCopyright:   Copyright © 2008-2018 by HRD Software, LLC
    Comments:         Ham Radio Deluxe Rotator controller

K7ZCZ

2018-05-25 16:14

manager   ~0005113

Without any information describing the scenario that causes this problem, diagnosing and fixing this issue will be an arduous task.

Please take the time to provide whatever information you can about the state of the application and which settings might affect the appearance of the problem.

The Rotator can draw a polar map or a Mercator map. Does the problem reproduce with one map type, or both?

The Rotator might be set to draw sunlight lines or not. Does this setting affect the possibility of hanging?

What's the color depth of the user's display?

The Rotator application might draw long or short paths. Which setting makes the issue more likely to appear?

The Rotator application may be set to draw "gauges" or not. What setting makes the problem more or less likely to occur?

The Rotator application might draw maidenhead squares (in a Mercator view) or not. Does that setting predict the appearance of the issue?

The Rotator application can zoom the map in or out. Does the Zoom setting seem to have an effect on the problem?



K7ZCZ

2018-05-28 10:55

manager   ~0005119

Nothing heard for my queries, so I'm afraid I have to guess.

The best I have at the moment is a bit of code which looks as though it is intended to clip the border of the drawn heading text in degrees. Rather than doing math, that code is a loop which decrements on of the coordinates by one and tests again. The dump looks like it is stopped in this loop. It's not easy to find the values involved in the code, since they're stored in XMM registers due to the use of floats and GDI+, but it looks like they're very far off and end up causing the loop to run a long time. Because the loop is in response to a paint request, the long-running code hangs the app until it completes.

Without being able to reproduce this issue, the best I can provide is a speculative fix. I'd be far more comfortable being able to test the fix. I'd also prefer to understand what's actually causing the out-of-range coordinates to be passed; perhaps there is bad math someplace that is causing a parameter to go out of bounds. With no available information, I don't believe I have any alternative.

K7ZCZ

2018-05-28 14:59

manager   ~0005123

Fixed with this changeset:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4136

PD9FER

2018-06-01 03:10

viewer   ~0005159

Contacted the customer and asked to test build 842
Getting additional info is rather daunting

PD9FER

2018-06-03 04:02

viewer   ~0005183

Still have same issues with 842
New dump file: Mantis_ID-0002739HRDRotator.zip

K7ZCZ

2018-06-03 17:03

manager   ~0005184

The fix I made is not in build 842; 842 was built before this fix was checked in. A build with this fix has yet to be produced.

K7ZCZ

2018-06-03 17:18

manager   ~0005187

The call stack from the new dump points at the same bit of code that I fixed with the above checkin.

PD9FER

2018-06-06 08:54

viewer   ~0005212

I will let customer try when the Build is available.

PD9FER

2018-07-01 03:02

viewer   ~0005579

Fixed in 858

g3ucq

2018-07-22 04:07

viewer   ~0005754

Cannot test.

PD9FER

2018-07-23 09:55

viewer   ~0005756

Waiting for confirmation on build 872
Tim has a remote planned with the customer.

WA9PIE

2018-07-23 22:46

administrator   ~0005765

Need an update folks Ferry/Tim.

PD9FER

2018-07-24 12:51

viewer   ~0005777

Got confirmation from Tim.
Fixed in 872

Issue History

Date Modified Username Field Change
2018-05-25 02:53 PD9FER New Issue
2018-05-25 02:56 PD9FER Note Added: 0005110
2018-05-25 15:52 K7ZCZ Note Added: 0005112
2018-05-25 16:14 K7ZCZ Assigned To => PD9FER
2018-05-25 16:14 K7ZCZ Status new => feedback
2018-05-25 16:14 K7ZCZ Note Added: 0005113
2018-05-26 02:18 PD9FER Summary HRD Rotator spontanious locking up/freezing build 860 => HRD Rotator spontanious locking up/freezing build 840
2018-05-26 23:36 K7ZCZ Relationship added related to 0002701
2018-05-28 10:55 K7ZCZ Note Added: 0005119
2018-05-28 14:59 K7ZCZ Status feedback => resolved
2018-05-28 14:59 K7ZCZ Resolution open => fixed
2018-05-28 14:59 K7ZCZ Note Added: 0005123
2018-06-01 03:10 PD9FER Note Added: 0005159
2018-06-01 13:24 WA9PIE Project 1 - Backlog => Ham Radio Deluxe
2018-06-01 13:25 WA9PIE Project Ham Radio Deluxe => 3 - Current Dev List
2018-06-03 04:02 PD9FER Note Added: 0005183
2018-06-03 17:03 K7ZCZ Note Added: 0005184
2018-06-03 17:18 K7ZCZ Note Added: 0005187
2018-06-03 17:34 K7ZCZ Relationship deleted related to 0002701
2018-06-03 17:36 K7ZCZ Relationship added has duplicate 0002701
2018-06-06 08:54 PD9FER Note Added: 0005212
2018-07-01 03:02 PD9FER Note Added: 0005579
2018-07-19 19:40 K7ZCZ Fixed in Version => 6.4.0.872
2018-07-22 04:07 g3ucq Note Added: 0005754
2018-07-23 09:55 PD9FER Note Added: 0005756
2018-07-23 22:46 WA9PIE Note Added: 0005765
2018-07-24 12:51 PD9FER Note Added: 0005777
2018-07-24 15:28 WA9PIE Status resolved => closed
2018-07-24 15:45 WA9PIE Testing Not Started => Beta Successful
2018-07-25 08:00 WA9PIE Fixed in Version 6.4.0.872 => 6.4.0.873
2018-07-25 20:47 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe