View Issue Details

IDProjectCategoryView StatusLast Update
0002769Ham Radio DeluxeBugpublic2018-07-25 20:47
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version6.4.0.843 
Target VersionFixed in Version6.4.0.873 
Summary0002769: Setup: doesn't install cleanly over older version
DescriptionSetup behaves poorly when installed over an older version of the product without that older version first being uninstalled
Steps To Reproduce1) Uinstall HRD
2) Run Setup for version 842. No need to run the product
3) Run Setup for Version 843 without uninstalling 842.

BUG#1) An "overwrite" message is issued for each executable file that setup installs. This is pretty obnoxious; worse, if a customer every says that they don't want to overwrite the older version, they'll end up with different versions of the executable set, which is likely to cause stability problems.

Setup should implicitly uninstall the old version if run with an older version present.
TagsNo tags attached.
ModuleAll
Sub-ModuleInstall
Testing Beta Successful

Relationships

Activities

K7ZCZ

2018-06-14 22:15

manager   ~0005334

fixed with this checkin

K7ZCZ

2018-06-14 22:15

manager   ~0005335

https://hrdsoftware.visualstudio.com/web/cs.aspx?pcguid=024933d8-393e-4d7b-806f-280bdbd42f73&cs=4145

g3ucq

2018-06-16 06:18

viewer   ~0005349

I got the attached message running the uninstall.
I have never seen an 'overwrite' message during an install.
No message about uninstalling before the install.

uninstall1.JPG (20,892 bytes)
uninstall1.JPG (20,892 bytes)

WA9PIE

2018-06-17 11:10

administrator   ~0005351

These items were validated by beta testers and users who had reported these problems.

WA9PIE

2018-06-27 09:54

administrator   ~0005498

It appears that we're seeing additional cases of this. I'm reopening this so we can continue to track down new use cases.

K7ZCZ

2018-06-27 10:10

manager   ~0005500

Additional fixes with this checkin:

https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4195

I think this change will help with the uninstall phase of setup failing. The issue is that InstallAware works in two modes: "Windows" and "native". In a previous checkin (to fix Uninstall being an Uninstall in the first place; and to get the services correctly uninstalling) I switched from "Windows" to "native".

A Native uninstall can't uninstall a previous Windows uninstall, and visa-versa. The documentation is pretty poor, but I think I've got the right code in place to get the cross-mode uninstall working right.

g3ucq

2018-06-28 12:00

viewer   ~0005521

I Uninstalled HRD and expected to see a progress tape. Very quick though.
Re-installation no problem. Fixed

WA9PIE

2018-07-02 17:29

administrator   ~0005597

I ran through an upgrade on a couple VMs and they did not exhibit any abnormal behavior.

g3ucq

2018-07-13 15:50

viewer   ~0005684

Fixed

Issue History

Date Modified Username Field Change
2018-06-14 19:10 K7ZCZ New Issue
2018-06-14 19:11 K7ZCZ Summary Setup: doesn't install over older version => Setup: doesn't install cleanly over older version
2018-06-14 19:11 K7ZCZ Description Updated View Revisions
2018-06-14 22:15 K7ZCZ Assigned To => K7ZCZ
2018-06-14 22:15 K7ZCZ Status new => resolved
2018-06-14 22:15 K7ZCZ Resolution open => fixed
2018-06-14 22:15 K7ZCZ Note Added: 0005334
2018-06-14 22:15 K7ZCZ Note Added: 0005335
2018-06-15 18:31 WA9PIE Fixed in Version => 6.4.0.845
2018-06-16 06:18 g3ucq File Added: uninstall1.JPG
2018-06-16 06:18 g3ucq Note Added: 0005349
2018-06-17 11:09 WA9PIE Fixed in Version 6.4.0.845 => 6.4.0.846
2018-06-17 11:10 WA9PIE Note Added: 0005351
2018-06-17 11:10 WA9PIE Status resolved => closed
2018-06-17 11:11 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-06-27 09:54 WA9PIE Status closed => feedback
2018-06-27 09:54 WA9PIE Resolution fixed => reopened
2018-06-27 09:54 WA9PIE Note Added: 0005498
2018-06-27 09:54 WA9PIE Project Ham Radio Deluxe => 3 - Current Dev List
2018-06-27 10:10 K7ZCZ Status feedback => resolved
2018-06-27 10:10 K7ZCZ Resolution reopened => fixed
2018-06-27 10:10 K7ZCZ Note Added: 0005500
2018-06-27 12:49 WA9PIE Fixed in Version 6.4.0.846 =>
2018-06-28 10:06 K7ZCZ Fixed in Version => 6.4.0.858
2018-06-28 12:00 g3ucq Note Added: 0005521
2018-07-02 17:29 WA9PIE Note Added: 0005597
2018-07-13 15:50 g3ucq Note Added: 0005684
2018-07-17 16:56 WA9PIE Status resolved => closed
2018-07-17 16:56 WA9PIE Testing Not Started => Beta Successful
2018-07-23 22:52 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-07-24 15:35 WA9PIE Project Ham Radio Deluxe => 3 - Current Dev List
2018-07-25 08:00 WA9PIE Fixed in Version 6.4.0.858 => 6.4.0.873
2018-07-25 20:47 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe