View Issue Details

IDProjectCategoryView StatusLast Update
00027875 - Closed w/o ActionBugpublic2018-07-09 14:28
ReporteranonymousAssigned ToK7ZCZ 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformPCOSWindows 10 64 bit HomeOS Version64 bit
Summary0002787: Does not record QTH data
DescriptionQTH data can be entered but it is not saved.
Steps To ReproduceEnter QTH. Save. Relaunch QSO file - QTH is missing.
TagsICOM
ModuleLogbook
Sub-ModuleData
TestingNot Started

Relationships

duplicate of 0002716 closedK7ZCZ Ham Radio Deluxe Build 840 Logbook: QTH entry vanishes when manually editing an existing QSO 

Activities

WA9PIE

2018-06-26 19:54

administrator   ~0005494

Who opened this? We already have a bug open for this I believe.

K7ZCZ

2018-06-29 13:16

administrator   ~0005545

Which bug is that?

g3ucq

2018-07-01 16:21

updater   ~0005584

0002716 me thinks

K7ZCZ

2018-07-04 06:23

administrator   ~0005605

2716 is about the QTH data not displaying and does not describe the loss of entered data. This issue claims QTH data is not actually recorded after being entered, and is lost.

If a bug exists for this, let's find it.

If one doesn't, let's find some way to make the issue actionable -- probably best to start with clear repro steps. It's pretty easy to demonstrate that the data is actually stored by adding a "location" column to the logbook's view, which will show the entered data even if it doesn't appear in the ELE window.

g3ucq

2018-07-04 08:35

updater   ~0005606

I believe there is confusion over this. Someone entering data into the ALE and not seeing it on later views assumes that the data was not saved, when in fact, it had. I think the bug is that the data is there but not being displayed.

g3ucq

2018-07-04 08:53

updater   ~0005607

Steps to reproduce.
Open Logbook and add the QTH field to the Layout. Ensure it is easily visible in the Logbook window.
Open the ALE and add a call sign whose QTH you can see in the Logbook.
Click Lookup and Update.
The Entry displays in the Log with the QTH.
Close the ALE.
Double click that QSO to open it again in the ALE and the QTH field will be empty.

K7ZCZ

2018-07-06 14:54

administrator   ~0005619

Isn't this, then, a duplicate of 2716?

g3ucq

2018-07-06 15:21

updater   ~0005622

Seems to be which is what I said above. How can there be an 'anonymous' reporter?

K7ZCZ

2018-07-06 22:46

administrator   ~0005624

Indeed, that's what you said -- and I said that this bug is different because it discusses not saving, while the other bug discusses not displaying.

I have no idea why we have anonymous reporters. I'll close the bug with the assumption that it really is a duplicate; if a reporter wants to provide details and show themselves, then we can go from there.

K7ZCZ

2018-07-06 22:46

administrator   ~0005625

Presumed a duplicate of 2716.

WA9PIE

2018-07-09 14:28

administrator   ~0005644

I'm closing this. We'll track this under 0002716 because this is a duplicate of that one.

Not sure why user "anonymous" was able to create a bug report anyway. I've tightened security about that.

Issue History

Date Modified Username Field Change
2018-06-26 16:21 anonymous New Issue
2018-06-26 16:21 anonymous Tag Attached: ICOM
2018-06-26 19:54 WA9PIE Note Added: 0005494
2018-06-29 13:16 K7ZCZ Note Added: 0005545
2018-07-01 16:21 g3ucq Note Added: 0005584
2018-07-04 06:23 K7ZCZ Note Added: 0005605
2018-07-04 08:35 g3ucq Note Added: 0005606
2018-07-04 08:53 g3ucq Note Added: 0005607
2018-07-06 14:54 K7ZCZ Note Added: 0005619
2018-07-06 15:21 g3ucq Note Added: 0005622
2018-07-06 22:46 K7ZCZ Note Added: 0005624
2018-07-06 22:46 K7ZCZ Assigned To => K7ZCZ
2018-07-06 22:46 K7ZCZ Status new => resolved
2018-07-06 22:46 K7ZCZ Resolution open => fixed
2018-07-06 22:46 K7ZCZ Note Added: 0005625
2018-07-06 22:46 K7ZCZ Relationship added duplicate of 0002716
2018-07-09 14:28 WA9PIE Status resolved => closed
2018-07-09 14:28 WA9PIE Resolution fixed => duplicate
2018-07-09 14:28 WA9PIE Note Added: 0005644
2018-07-09 14:28 WA9PIE Project Issues Needing Retest => 5 - Closed w/o Action