View Issue Details

IDProjectCategoryView StatusLast Update
0002824Ham Radio DeluxeBugpublic2018-08-09 21:05
ReporterKB3NPH 
Assigned ToK7ZCZ 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.876 
Summary0002824: Contact's "STATE" not logging in V6.4.0.873
DescriptionSupport is receiving many reports of the contact't state not appearing in the logbook once saved into their logbook. I have confirmed this situation on many occasions when remoting into contacts system.
Steps To Reproduce1. Open Logbook
2. Create a Layout which will show the "STATE" field
3. Click "ADD" to open ALE
4. Enter "K7ZCZ" in ALE callsign field
5. Click "Lookup" button (in my case QRZ.com XML is lookup option using)
6. Notice after lookup the "State" field is populated in the ALE
7. Click [Update (F7)] button to save contact to logbook
8. Check "State" field for contact in logbook and note that STATE is not populated.

As a further check, export "K7ZCZ" contact to an ADI file. Once the ADI file is created, open the utility "ADIF Master" and look for the contact's "STATE" field in the ADIF Master screen. The "FIELD" for the contact's "STATE" does not appear anywhere in the ADIF fields.

Further verification.

Open the K7ZCZ.adi in Notepad
1. Search for "State" and the only thing that will be found is where the words "United States" appears in the record.
2. Search for "WA" (exact). No "WA" phrase found in the file.

See screenshots and including exported ADI file of entire process

TagsNo tags attached.
ModuleLogbook
Sub-ModuleFunctional
TestingNot Started

Relationships

has duplicate 0002822 closedK7ZCZ Logbook not saving USA State data 

Activities

KB3NPH

2018-07-31 09:16

administrator  

K7ZCZ ALE Entry.jpg (418,651 bytes)
K7ZCZ.ADI (1,404 bytes)
K7ZCZ Modify Window.jpg (158,636 bytes)
K7ZCZ Modify Window.jpg (158,636 bytes)
k7zcz Log Entry.jpg (143,892 bytes)
k7zcz Log Entry.jpg (143,892 bytes)

g3ucq

2018-07-31 10:59

viewer   ~0005896

I added this bug in 0002822

K7ZCZ

2018-08-02 20:36

manager   ~0005907

Something here doesn't add up. When I use the "Add" button to open an ALE and add a record, there's no "Update" button -- the button to close the ALE and save the record says "Add", not "Update".

The button will say "Update" when editing an existing record, but that's not done with the "Add" button in the main Logbook UI.

WA9PIE

2018-08-03 19:14

administrator   ~0005912

For the life of me, I cannot replicate this. We have no reliable steps for causing this to happen.

Meanwhile, many customers have reported it.

"Update" is what the F7 button says when you're modifying an existing record.
"Add" is what the buttons says when creating a new record.

K7ZCZ

2018-08-03 23:48

manager   ~0005913

Right; so Step #7 in the repro steps doesn't match Step #3.

The related bug explains that there's a problem with saving the state on an updated entry. I can repro that, and I can work on fixing it. But it makes me think that this issue actually is not the same as 2822.

WA9PIE

2018-08-04 00:16

administrator   ~0005914

The repro steps in 2822 are better than in this record. I could not reproduce it using the steps in this record. But with Tim in TeamViewer tonight, we found the exact steps to replicate this and they're described in 2822.

I would use that case. At the very least, I would ignore the repro steps in this case and use 2822. Regardless, these are duplicates.

K7ZCZ

2018-08-04 13:04

manager   ~0005926

I think this is fixed with this checkin:
https://hrdsoftware.visualstudio.com/web/cs.aspx?pcguid=024933d8-393e-4d7b-806f-280bdbd42f73&cs=4266

vk2byi

2018-08-09 03:20

viewer  

Test Case Results v6.4.0.875 beta.pdf (42,340 bytes)

vk2byi

2018-08-09 03:20

viewer   ~0005950

I can reproduce the issue with 873 (as per the repro steps in 2822). Defect appears to be fixed in this release. Ran my usual set of Logbook API tests as well and all test pass. Results attached.

g3ucq

2018-08-09 03:36

viewer   ~0005951

The issue is fixed as detailed above.
However, if I add the field 'State' to the Logbook layout there are a number of QSOs showing 'State' data populated from stations outside of the States.
To show only US States I have to add the 'State Name' field instead.
No big deal for me as I do not normally have the State field showing anyway.

vk2byi

2018-08-09 04:14

viewer   ~0005955

I regularly store values other than US State abbreviations in State, and always have it visible in the grid. E.g: Australian State abbreviations - we use 'em too <grin> - as well as Italian/Spanish provinces, Japanese prefectures etc. I wouldn't like State to be restricted to US States only. <grin>

WA9PIE

2018-08-09 21:05

administrator   ~0005958

Closed as part of the 875 beta... 876 release.

Issue History

Date Modified Username Field Change
2018-07-31 09:16 KB3NPH New Issue
2018-07-31 09:16 KB3NPH File Added: K7ZCZ ALE Entry.jpg
2018-07-31 09:16 KB3NPH File Added: k7zcz Log Entry.jpg
2018-07-31 09:16 KB3NPH File Added: K7ZCZ Modify Window.jpg
2018-07-31 09:16 KB3NPH File Added: K7ZCZ.ADI
2018-07-31 10:59 g3ucq Note Added: 0005896
2018-08-01 10:15 K7ZCZ Relationship added has duplicate 0002822
2018-08-02 20:36 K7ZCZ Note Added: 0005907
2018-08-03 19:14 WA9PIE Note Added: 0005912
2018-08-03 23:48 K7ZCZ Note Added: 0005913
2018-08-04 00:16 WA9PIE Note Added: 0005914
2018-08-04 00:16 WA9PIE Assigned To => K7ZCZ
2018-08-04 00:16 WA9PIE Status new => assigned
2018-08-04 13:04 K7ZCZ Status assigned => resolved
2018-08-04 13:04 K7ZCZ Resolution open => fixed
2018-08-04 13:04 K7ZCZ Note Added: 0005926
2018-08-08 18:20 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2018-08-08 18:21 K7ZCZ Fixed in Version => 6.4.0.875
2018-08-09 03:20 vk2byi File Added: Test Case Results v6.4.0.875 beta.pdf
2018-08-09 03:20 vk2byi Note Added: 0005950
2018-08-09 03:36 g3ucq Note Added: 0005951
2018-08-09 04:14 vk2byi Note Added: 0005955
2018-08-09 21:00 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-08-09 21:03 WA9PIE Fixed in Version 6.4.0.875 => 6.4.0.876
2018-08-09 21:05 WA9PIE Note Added: 0005958
2018-08-09 21:05 WA9PIE Status resolved => closed