View Issue Details

IDProjectCategoryView StatusLast Update
00028352 - Next Dev List (Holding Area)Bugpublic2019-06-15 11:36
Reporterg3ucqAssigned Tog3ucq 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10 64 bit Home
Summary0002835: DM780 created a minidump file
DescriptionDM780 created a minidump file as I was changing Identities
Steps To ReproduceThis has never happened to me before with DM780 so was not expecting it.
I had earlier created a second identity and was changing identities when the mindump was created.
DM780 carried on running normally with the new Identity.
Additional InformationThe minidump is attached.
Not long after the minidump was created the Logbook closed down.
That is the first time for me that that has happened since the Logbook closing issue was reported.
Could the Logbook closing issue be related to having more than one DM780 Identity?
TagsNo tags attached.
ModuleDM780
Sub-ModuleFunctional
TestingNot Started

Activities

g3ucq

2018-08-10 06:44

updater  

DigitalMaster_20180810_110742.zip (7,256,333 bytes)

K7ZCZ

2018-08-14 09:50

administrator   ~0005972

Looks like something is getting sick while writing to the Logfile pane. The Logfile code is in bad shape across the apps; bad memory management, bad synchronization across threads. Plus, it's copy-and-paste reuse, so it has to be analyzed and fixed in each application.

This dump is from the 876 version of the product.

0:010> .ecxr
eax=0172cc54 ebx=754e6490 ecx=01d418b0 edx=00000002 esi=01d418a0 edi=01d418b0
eip=46746547 esp=0f0ffc48 ebp=0f0ffd68 iopl=0         nv up ei pl nz ac pe nc
cs=0023  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00010216
46746547 ??              ???
0:010> kb
  *** Stack trace for last set context - .thread/.cxr resets it
 # ChildEBP RetAddr  Args to Child              
WARNING: Frame IP not in any known module. Following frames may be wrong.
00 0f0ffc44 01234302 0dab6448 e255b19b 01aaff78 0x46746547
01 0f0ffd68 011ed538 01d418a0 017dbb28 01ab0160 Digital_Master!CLogfile::Add+0x152 [c:\ham radio\digital master\digital master\logfile.cpp @ 108] 
02 0f0ffdac 011e5467 0af3b780 01aaff78 008fd5ac Digital_Master!CBackgroundProcessingThread::CloseSoundIn+0x118 [c:\ham radio\digital master\digital master\backgroundprocessingthreadsound.cpp @ 383] 
03 0f0ffdc4 01384b62 e255b11f 00000784 00060a00 Digital_Master!CBackgroundProcessingThread::EndWork+0x37 [c:\ham radio\digital master\digital master\backgroundprocessingthread.cpp @ 423] 
04 0f0ffdec 01384be6 e255b2db 0af3b780 00000784 Digital_Master!CThinThread::Run+0x92 [c:\ham radio\digital master\digital master\thinthread.cpp @ 200] 
05 0f0ffe28 013c41f8 01aaff78 e255b223 014ed9fb Digital_Master!CThinThread::Start+0x46 [c:\ham radio\digital master\digital master\thinthread.cpp @ 234] 
06 0f0ffed0 014ed94f 008fd5ac e255b3fb 014ed9fb Digital_Master!_AfxThreadEntry+0xff [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\thrdcore.cpp @ 109] 
07 0f0fff08 014eda77 014ed9fb 0f0fff28 754e8484 Digital_Master!_callthreadstartex+0x1b [f:\dd\vctools\crt\crtw32\startup\threadex.c @ 376] 
08 0f0fff14 754e8484 0d8cb370 754e8460 ed0d71df Digital_Master!_threadstartex+0x7c [f:\dd\vctools\crt\crtw32\startup\threadex.c @ 354] 
09 0f0fff28 77272fea 0d8cb370 96fdfad8 00000000 kernel32!BaseThreadInitThunk+0x24
0a 0f0fff70 77272fba ffffffff 7728ec3d 00000000 ntdll!__RtlUserThreadStart+0x2f
0b 0f0fff80 00000000 014ed9fb 0d8cb370 00000000 ntdll!_RtlUserThreadStart+0x1b

K7ZCZ

2018-08-14 10:57

administrator   ~0005973

Changing identities causes the application to shut down and restart. The carsh is due to the Log file trying to continue writing while another thread is still working -- the partially destroyed LogFile object can't handle the write call and crashes.

K7ZCZ

2018-08-15 06:48

administrator   ~0005976

This fix gets started with cleanup; still lots more work to do before we can call this fixed
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4279

g3ucq

2019-03-07 05:00

updater   ~0007621

No mini dumps created now.

K7ZCZ

2019-06-06 13:19

administrator   ~0008000

John, is this happening in current builds? If not, I'd like to close it.

g3ucq

2019-06-06 13:44

updater   ~0008008

I recreated a new Identity (I normally only have one) and ran the test without problems.
Fixed for me.

K7ZCZ

2019-06-06 17:24

administrator   ~0008017

Thank you!

Issue History

Date Modified Username Field Change
2018-08-10 06:44 g3ucq New Issue
2018-08-10 06:44 g3ucq File Added: DigitalMaster_20180810_110742.zip
2018-08-14 09:50 K7ZCZ Note Added: 0005972
2018-08-14 10:57 K7ZCZ Note Added: 0005973
2018-08-15 06:48 K7ZCZ Note Added: 0005976
2018-12-21 14:52 WA9PIE Project Issues Needing Retest => 3 - Current Dev List
2019-03-07 05:00 g3ucq Note Added: 0007621
2019-06-06 13:19 K7ZCZ Assigned To => g3ucq
2019-06-06 13:19 K7ZCZ Status new => assigned
2019-06-06 13:19 K7ZCZ Note Added: 0008000
2019-06-06 13:44 g3ucq Note Added: 0008008
2019-06-06 17:24 K7ZCZ Note Added: 0008017
2019-06-06 17:24 K7ZCZ Status assigned => resolved
2019-06-06 17:24 K7ZCZ Resolution open => fixed
2019-06-15 11:36 WA9PIE Project 3 - Current Dev List => 2 - Next Dev List (Holding Area)