View Issue Details

IDProjectCategoryView StatusLast Update
0002841Ham Radio DeluxeBugpublic2018-09-11 13:18
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status closedResolutionfixed 
Product Version6.4.0.873 
Target VersionFixed in Version6.4.0.886 
Summary0002841: Digtal Master: occasional crash when writing LogFile string from HRDInterface implementation
DescriptionThis issue is turning up in the Microsoft Dev Dashboard, so I can't provide a complete report case for it; all I have is a static stack trace and not even a minidump.

But we see several reports of various calls to CHRDInterface001App::SendLogfileMessage() resulting in a crash because an invalid parameter is passed to _tcscpy_s().

My guess from the stack and reviewing the disassembled code is that the GlobalAlloc() or GlobalLock() calls are failing and returning NULL; this triggers the invalid argument handler and shuts down the application.
TagsNo tags attached.
ModuleDM780
Sub-ModuleRadio Support
Testing Not Tested

Relationships

Activities

K7ZCZ

2018-08-16 14:16

manager   ~0005980

Here are the spreadsheets with the stack traces. Multiple traces at different message calls, so we can't connect this to any pattern of usage.

Mantis2841Stack2.xlsx (10,774 bytes)
Mantis2841Stack1.xlsx (10,634 bytes)

K7ZCZ

2018-08-19 12:29

manager   ~0005983

Looks like several calls to Global-heap functions are made without checking return codes. This checkin addresses those calls, though the underlying reason for memory allocation failure isn't known.

https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4284


g3ucq

2018-08-30 05:49

viewer   ~0006019

DM780 will stop responding after a key press or setting change. I have not seen this before.
No dump file is created.

g3ucq

2018-08-30 05:51

viewer   ~0006020

DM780 stops responding when adding a call sign in the ALE.

K7ZCZ

2018-08-30 10:10

manager   ~0006027

Please open new issues for these, and include complete repro steps. The symptoms you're seeing are not related to this issue, and should be tracked separately and individually.

WA9PIE

2018-09-07 16:53

administrator   ~0006117

Unable to test. Accepting this as validated; developer managed topic.

Issue History

Date Modified Username Field Change
2018-08-16 11:26 K7ZCZ New Issue
2018-08-16 14:16 K7ZCZ File Added: Mantis2841Stack1.xlsx
2018-08-16 14:16 K7ZCZ File Added: Mantis2841Stack2.xlsx
2018-08-16 14:16 K7ZCZ Note Added: 0005980
2018-08-19 12:29 K7ZCZ Assigned To => K7ZCZ
2018-08-19 12:29 K7ZCZ Status new => resolved
2018-08-19 12:29 K7ZCZ Resolution open => fixed
2018-08-19 12:29 K7ZCZ Note Added: 0005983
2018-08-29 18:40 K7ZCZ Fixed in Version => 6.4.0.877
2018-08-30 05:49 g3ucq Note Added: 0006019
2018-08-30 05:51 g3ucq Note Added: 0006020
2018-08-30 10:10 K7ZCZ Note Added: 0006027
2018-09-07 16:53 WA9PIE Status resolved => closed
2018-09-07 16:53 WA9PIE Description Updated View Revisions
2018-09-07 16:53 WA9PIE Testing Not Started => Not Tested
2018-09-07 16:53 WA9PIE Note Added: 0006117
2018-09-11 13:15 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-09-11 13:18 WA9PIE Fixed in Version 6.4.0.877 => 6.4.0.886