View Issue Details

IDProjectCategoryView StatusLast Update
0002850Ham Radio DeluxeBugpublic2018-09-11 13:18
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version6.4.0.876 
Target VersionFixed in Version6.4.0.886 
Summary0002850: Logbook: BackgroundProcessingThread leaks two critical sections
DescriptionThe BackgroundProcessingThread (and all its derived classes) is commonly used in the Logbook app. It leaks a couple of critical sectoin objects for each instance. For some reason, raw Win32 CRITICAL_SECTION objects are used for a couple of locks; these, of course, are the ones that leak because they don't have a built-in destructor to manage their lifecycle.

CLibBackgroundProcessingThread has two more critical sections which are leaked, in addition to the two in the base class.
Steps To ReproduceFound with App Verifier.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleFunctional
Testing Not Tested

Relationships

Activities

K7ZCZ

2018-08-23 10:38

manager   ~0006000

Not a user-visible issue

Fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4302

WA9PIE

2018-09-07 17:01

administrator   ~0006124

Unable to test. Accepting this as validated; developer managed topic.

Issue History

Date Modified Username Field Change
2018-08-23 09:17 K7ZCZ New Issue
2018-08-23 10:38 K7ZCZ Assigned To => K7ZCZ
2018-08-23 10:38 K7ZCZ Status new => resolved
2018-08-23 10:38 K7ZCZ Resolution open => fixed
2018-08-23 10:38 K7ZCZ Note Added: 0006000
2018-08-29 18:39 K7ZCZ Fixed in Version => 6.4.0.877
2018-09-07 17:01 WA9PIE Status resolved => closed
2018-09-07 17:01 WA9PIE Testing Not Started => Not Tested
2018-09-07 17:01 WA9PIE Note Added: 0006124
2018-09-11 13:15 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-09-11 13:18 WA9PIE Fixed in Version 6.4.0.877 => 6.4.0.886