View Issue Details

IDProjectCategoryView StatusLast Update
0002851Ham Radio DeluxeBugpublic2018-09-11 13:18
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version6.4.0.876 
Target VersionFixed in Version6.4.0.886 
Summary0002851: Station: GetFileSignature() uses a ton of memory, crashes in low-memory situations
DescriptionThe Station implementation has a routine called GetFileSignature() that (why?) computes a checksum for some of the application files. The function gets the size of the file, allocates that much memory, and reads the whole file into memory at once. Our executables are about 25 megs in size, so the function looks for 25 megs of memory at a time.

If the allocation fails (it's more likely to do so because the memory must be contiguous) it will crash because absolutely no error checking is performed in the function. This crash would happen very early in start-up, the paplication would present no UI beforehand, and might not even have the minidump hook set up.
Steps To ReproduceFound with App Verifier.
TagsNo tags attached.
ModuleAll
Sub-ModuleGeneral
Testing Not Tested

Relationships

Activities

K7ZCZ

2018-08-23 10:21

manager   ~0005997

I don't think there's a real way for end-users to test a fix like this.

Fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4298

WA9PIE

2018-09-07 17:00

administrator   ~0006123

Unable to test. Accepting this as validated; developer managed topic.

Issue History

Date Modified Username Field Change
2018-08-23 09:17 K7ZCZ New Issue
2018-08-23 10:21 K7ZCZ Assigned To => K7ZCZ
2018-08-23 10:21 K7ZCZ Status new => resolved
2018-08-23 10:21 K7ZCZ Resolution open => fixed
2018-08-23 10:21 K7ZCZ Note Added: 0005997
2018-08-29 18:39 K7ZCZ Fixed in Version => 6.4.0.877
2018-09-07 17:00 WA9PIE Status resolved => closed
2018-09-07 17:00 WA9PIE Steps to Reproduce Updated View Revisions
2018-09-07 17:00 WA9PIE Testing Not Started => Not Tested
2018-09-07 17:00 WA9PIE Note Added: 0006123
2018-09-11 13:15 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-09-11 13:18 WA9PIE Fixed in Version 6.4.0.877 => 6.4.0.886