View Issue Details

IDProjectCategoryView StatusLast Update
0002858Ham Radio DeluxeBugpublic2018-09-11 13:18
ReporterK7ZCZ 
Assigned ToWA9PIE 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformIntel i7-5960XOSWindows 10 Professional x64OS Version16299
Product Version6.4.0.876 
Target VersionFixed in Version6.4.0.886 
Summary0002858: Logbook: QSO Forwarding options are not correctly scoped
DescriptionThe QSO Forwarding options let the user set the application to listen for QSO announcements from other applications as UDP broadcasts; or send QSO announcements to other applications as a UDP braodcasts. The send and receive can be turend on or off, and the port numbers used can be configured.

The UI implies that these options are application-wide, and will affect all opened databases. However, the options only work for the currently open database. The options are globally stored, though -- each database doesn't have its own state for the persistence of these options.

Further, closing the database which is actually correctly listening will stop the application from listen at all, and further notifications won't be received.

Sending works a bit differently, but is similarly poorly factored over the use of multiple databases.

This will take some design work to fix. We should decide how the sends are meant to be generated, how the receives are menat to be processed; and how the settings should be represented in the UI in a way that's easy to understand and verify.
Steps To Reproduce1) Open the Logobook
2) Open your favorite database
3) Use the "Configure" tear off in the "Tools" menu to find the "QSO Forwarding" command
4) In the resulting "QSO Forwarding" dialog, mark the "Receive logbook changes"
5) Close the dialog
6) Open a second logbook database
7) send the Logbook a UDP packet announcing a new QSO on the configured port

BUG#1) The application will log the QSO in one logbook database, but not the other

Note that Step 7 is kind of hard due to bugs in the handling of the UDP packet parsing.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleInterfacing
Testing Beta Successful

Relationships

related to 0002795 closedK7ZCZ QSO Forwarding (UDP broadcast) API in Logbook doesn't work (for WSJT-X). 
related to 0002888 closedK7ZCZ Rows inserted via UDP Receive in QSO Forwarding are not inserted in the Target Database. 
related to 0002867 closedK7ZCZ Logbook: Databases Manager could use some enhancement 

Activities

K7ZCZ

2018-09-01 14:40

manager   ~0006041

fixed with this checkin
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4317

WA9PIE

2018-09-10 10:31

administrator   ~0006171

I just tested this and - from what I can see - it is not fixed. Here are the steps I took and the results I found:

1) Open the Logobook
2) Open your favorite database (WA9PIE)
3) Use the "Configure" tear off in the "Tools" menu to find the "QSO Forwarding" command
4) In the resulting "QSO Forwarding" dialog, mark the "Receive logbook changes"; select the "WA9PIE" database (logbook)
5) Close the dialog
6) Switch to a second logbook database (KB3NPH Log)... making it the active database (the only database tab open)
7) Send the Logbook a UDP packet announcing a new QSO on the configured port

Result) The application logged the QSO in the "KB3NPH Log", rather than the "WA9PIE" log as selected in the QSO Forwarding dialog box.

QSO Forwarding Dialog.PNG (167,346 bytes)
QSO Forwarding Dialog.PNG (167,346 bytes)

WA9PIE

2018-09-10 10:32

administrator   ~0006172

MB... take a look at my notes and let me know if I'm testing it wrong... or if it still needs fixing.

WA9PIE

2018-09-10 11:06

administrator   ~0006180

Putting FIV back... I changed it by accident.

K7ZCZ

2018-09-10 14:27

manager   ~0006186

The symptom reported by W8PIE is primarily tracked by Mantis issue 2888 which was addressed with this checkin:

https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4343

WA9PIE

2018-09-10 16:36

administrator   ~0006190

Given W8PIE's topic will be tracked in 2888, I'll be closing this one as done.

Issue History

Date Modified Username Field Change
2018-08-25 16:33 K7ZCZ New Issue
2018-08-25 17:33 K7ZCZ Relationship added related to 0002795
2018-09-01 14:35 K7ZCZ Relationship added related to 0002867
2018-09-01 14:40 K7ZCZ Assigned To => K7ZCZ
2018-09-01 14:40 K7ZCZ Status new => resolved
2018-09-01 14:40 K7ZCZ Resolution open => fixed
2018-09-01 14:40 K7ZCZ Sub-Module (select) => Interfacing
2018-09-01 14:40 K7ZCZ Note Added: 0006041
2018-09-03 00:07 K7ZCZ Fixed in Version => 6.4.0.878
2018-09-10 10:31 WA9PIE File Added: QSO Forwarding Dialog.PNG
2018-09-10 10:31 WA9PIE Note Added: 0006171
2018-09-10 10:32 WA9PIE Status resolved => feedback
2018-09-10 10:32 WA9PIE Resolution fixed => reopened
2018-09-10 10:32 WA9PIE Note Added: 0006172
2018-09-10 11:01 WA9PIE Fixed in Version 6.4.0.878 =>
2018-09-10 11:06 WA9PIE Fixed in Version => 6.4.0.878
2018-09-10 11:06 WA9PIE Note Added: 0006180
2018-09-10 14:26 K7ZCZ Relationship added related to 0002888
2018-09-10 14:27 K7ZCZ Assigned To K7ZCZ => WA9PIE
2018-09-10 14:27 K7ZCZ Status feedback => assigned
2018-09-10 14:27 K7ZCZ Resolution reopened => fixed
2018-09-10 14:27 K7ZCZ Note Added: 0006186
2018-09-10 14:28 K7ZCZ Status assigned => resolved
2018-09-10 16:36 WA9PIE Status resolved => closed
2018-09-10 16:36 WA9PIE Testing Not Started => Beta Successful
2018-09-10 16:36 WA9PIE Note Added: 0006190
2018-09-11 13:15 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-09-11 13:18 WA9PIE Fixed in Version 6.4.0.878 => 6.4.0.886