View Issue Details

IDProjectCategoryView StatusLast Update
0002871Ham Radio DeluxeBugpublic2018-09-11 13:18
Reportervk2byi 
Assigned ToK7ZCZ 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSWindows 10 ProOS Version1803 64-bit
Product Version 
Target VersionFixed in Version6.4.0.886 
Summary0002871: Not All Fields in WSJT-X QSO Broadcast Being Logged
DescriptionWhen an N1MM Section 9 UDP datagram is received on the QSO Forwarding receive port in Logbook, not all the fields sent in a packet from WSJT-X are being correctly inserted into the Logbook record.

I would further suggest that other ADIF field tags in the N1MM Section 9 specification that are not sent in the WSJT-X datagram, and that have a corresponding column in Logbook, should also be logged accurately in case WSJT-X adds further fields in a later release or another application is using the Logbook QSO Forwarding feature.
Steps To Reproduce1. Have WSJT-x running and have N1MM+ Logger Broadcasts enabled on UDP port 2333 in the Reporting tab settings;
2. If JTAlert is installed, make sure that the Last QSO API setting is not using port 2333;
3. Make sure that Logbook has the WSJT-X Receive QSO port enabled and set to port 2333 in the QSO Forwarding settings;
4. Enter W1AW as the DX Call in WSJT-X and press the Log QSO pushbutton;
5. In the QSO confirmation dialog, enter the following values (or other suitable values);
              Call: W1AW
              Start: 2018-08-27 10:20:30
              End: 2018-08-27 10:25:00
              Mode: FT8
              Band: 20m
              Rpt Sent: -7
              Rpt Rcvd: -3
              Grid: FN31pr
              Name: ARRL HQ OPERATORS CLUB
              Tx Pwr: 50.0
              Comments: FT8
              Operator: VK2BYI
6. Click the OK pushbutton so that WSJT-X broadcasts the datagram;
7. Verify the values inserted in the QSO in Logbook;
8. Note the following errors in the grid display:
              Start: current time and date UTC
              End: blank
              Band: 14m (blank in Modify dialog)
              Rpt Sent: -7 (-31 in Modify Log Entry window)
              Rpt Rcvd: -3 (-31 in Modify Log Entry window)
              Tx Pwr: blank

Additional InformationRefer to the attachment for further details, including test results from sending additional ADIF field tag values not currently sent by WSJT-X.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleInterfacing
Testing Beta Successful

Relationships

Activities

vk2byi

2018-09-02 01:35

viewer   ~0006049

Additional N1MM+ ADIF field tag test data results attached

N1MM Test Data.pdf (220,687 bytes)

vk2byi

2018-09-02 01:39

viewer   ~0006050

Typo in Steps to Reproduce step 8 - Rpt Sent and Rpt Rcvd displayed in grid are blank (not -7 and -3 as expected).

k2dls

2018-09-02 13:48

viewer   ~0006054

Attached is a PDF showing screenshots of differences.

HRD QSO Forwarding Differences.pdf (297,146 bytes)

k2dls

2018-09-02 14:07

viewer   ~0006055

An additional PDF showing the differences as seen in the list view.

HRD QSO Forwarding List View.pdf (290,190 bytes)

K7ZCZ

2018-09-02 18:33

manager   ~0006057

Chris' concerns should be fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4322

except that I think there are a couple of problems with the test, as two of the fields given don't match the ADIF spec. "ARRL_SECT" and "ITUZ" are given in the ADIF spec, the test uses "ARRL_SECTION" and "ITU", so I think it's by design that those fields are ignored.

vk2byi

2018-09-02 20:09

viewer   ~0006059

My bad! I have corrected my test script accordingly:

<call:4>W1AW <qso_date:8>20180827 <time_on:6>102030 <contest_id:9>CQ-WW-SSB <mode:3>FT8 <freq:9>14.075000 <freq_rx:9>14.075000 <band:3>20m <comment:3>FT8 <cqz:1>5 <ituz:1>8 <gridsquare:6>FN31pr <name:22>ARRL HQ OPERATORS CLUB <rst_rcvd:2>-3 <rst_sent:2>-7 <tx_pwr:4>50.0 <rx_pwr:4>60.0 <srx:3>001 <stx:3>002 <qth:9>Newington <operator:6>VK2BYI <arrl_sect:2>CT <iota:6>NA-001 <pfx:2>W1 <state:2>CT <precedence:10>precedence <check:5>check <eor>

vk2byi

2018-09-02 20:20

viewer   ~0006060

Dan also makes a good point re the differences between what is captured in Logbook with the Logbook API on TCP:7826 compared to the new WSJT-X interface on UDP:2333.

With reference to what was addressed with Mantis 0002261, maybe the this interface should insert the same 'active' MY STATION information in each QSO logged.

k2dls

2018-09-02 22:14

viewer   ~0006062

Yes, the insertion of My Station info ought to be triggered as with an insertion via JT Alert. Ideally, there should be little to no difference between the 2 paths. That is what I was trying to point out with the screenshots.

vk2byi

2018-09-03 02:09

viewer   ~0006066

878 BETA: Not seeing any change in what has been inserted from the previous 877 beta.

k2dls

2018-09-03 11:06

viewer   ~0006068

Tested under 881 and encountered minidump and Logbook close. See HRDLogbook_20180903_154706.mdmp on Dropbox.

vk2byi

2018-09-03 20:14

viewer   ~0006069

881 BETA: All ADIF field tags documented by N1MM Section 9 specification, that have corresponding columns in Logbook, are being populated correctly with expected values with the exception of SRX and STX. Test results attached.

The NA VHF Contest mode that can be activated for FT8 and MSK144 modes in WSJT-X, uses four-character grid locators (e.g. FN31, QF55) as the required exchange. Therefore, the Rcvd Exch (COL_SRX) and Sent Exch (COL_STX) columns cannot be used to record these exchange values as these columns are numeric types. Instead, the Srx # (COL_SRX_STRING) and Stx # (COL_STX_STRING) columns need to be used instead, as these columns are text/varchar types (despite their names).

The SRX and STX ADIF field tag values are being appropriately inserted in the Srx # and Stx # columns, but it would appear as those the code is expecting a numeric value. Using '001' and '002' as test values results in '1' and '2' being inserted (Pass), however, using 'FN31' and 'QF55' as test values results in blank values being inserted (FAIL). This would be an issue for NA VHF Contest participants.

Mantis 0002871 Test Results.pdf (212,801 bytes)

WA9PIE

2018-09-07 16:12

administrator   ~0006112

With the comments there from Chris, I'll take this one as passed (with the SRX/STX exception that we'll track separately).

Issue History

Date Modified Username Field Change
2018-09-02 01:28 vk2byi New Issue
2018-09-02 01:35 vk2byi File Added: N1MM Test Data.pdf
2018-09-02 01:35 vk2byi Note Added: 0006049
2018-09-02 01:39 vk2byi Note Added: 0006050
2018-09-02 13:48 k2dls File Added: HRD QSO Forwarding Differences.pdf
2018-09-02 13:48 k2dls Note Added: 0006054
2018-09-02 14:07 k2dls File Added: HRD QSO Forwarding List View.pdf
2018-09-02 14:07 k2dls Note Added: 0006055
2018-09-02 18:33 K7ZCZ Assigned To => K7ZCZ
2018-09-02 18:33 K7ZCZ Status new => resolved
2018-09-02 18:33 K7ZCZ Resolution open => fixed
2018-09-02 18:33 K7ZCZ Testing => Not Started
2018-09-02 18:33 K7ZCZ Note Added: 0006057
2018-09-02 20:09 vk2byi Note Added: 0006059
2018-09-02 20:20 vk2byi Note Added: 0006060
2018-09-02 22:14 k2dls Note Added: 0006062
2018-09-02 22:19 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-09-03 00:07 K7ZCZ Fixed in Version => 6.4.0.878
2018-09-03 02:09 vk2byi Note Added: 0006066
2018-09-03 11:06 k2dls Note Added: 0006068
2018-09-03 20:14 vk2byi File Added: Mantis 0002871 Test Results.pdf
2018-09-03 20:14 vk2byi Note Added: 0006069
2018-09-07 16:12 WA9PIE Note Added: 0006112
2018-09-07 16:14 WA9PIE Status resolved => closed
2018-09-07 16:14 WA9PIE Testing Not Started => Beta Successful
2018-09-11 13:15 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-09-11 13:18 WA9PIE Fixed in Version 6.4.0.878 => 6.4.0.886