View Issue Details

IDProjectCategoryView StatusLast Update
0002876Ham Radio DeluxeBugpublic2018-12-05 11:23
Reporterk2dls 
Assigned Tok2dls 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.886 
Summary0002876: Build 881 Introduces Error in QSOs entered via JT Alert
DescriptionWhile testing build 881, I now get an error when using JT Alert to send a QSO to HRD using the v6 API. This was not been in earlier general release or beta versions.
Steps To ReproduceLog a QSO in WSJT-X configured to be used with JT Alert and HRD Logbook.
QSO will be accepted by API however an error message will display that indicates "Error adding...". See attachment.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleVarious
TestingNot Started

Relationships

Activities

k2dls

2018-09-04 12:14

viewer  

HRD 881 Error.png (4,629 bytes)
HRD 881 Error.png (4,629 bytes)

k2dls

2018-09-04 14:49

viewer   ~0006072

Further testing after reboot. QSL Logged via JT Alert, appears in HRD Logbook, notification popup occurs, then minidump and close. Most recent minidump attached.

HRDLogbook_20180904_194532.mdmp (563,612 bytes)

K7ZCZ

2018-09-05 11:19

manager   ~0006080

The dump provided is the same as Mantis 2875 and is orthogonal to the message box displayed.

K7ZCZ

2018-09-05 12:15

manager   ~0006082



There's not quite enough information here to make a diagnosis.

The error message provided can come from the ALE, or from code that adds a record in the UDP listner. The report says that the message appears when JTAlert adds a record, so I think we can rule out the ALE.

But JTAlert uses the TCP/IP API, not the UDP listner. I have to assume, then, that both the UDP listener and the TCP/IP API are active. I figure that the UDP listener is hearing the announcement from WSJT-X directly, then the API is catching the record re-broadcast from JTAlert.

K2LDS, can you confirm this in the build you're currently using?

The actual cause of the error mgiht be the same as Mantis 2875, but I can't prove that completely. The message shown to the user should include a string describnig the error, but doesn't; some of the code paths which would result in those symptoms would result from the same cause as 2875.

I've added some more diagnostics to the involved code path. In the next build, the error message should include text that describes exactly what went wrong, and that can inform further diagnosis.

In the current build, it should be possible to look for error messages in the Logfile window. Please provide a copy of the Logfile window text after reproducing this issue, as it might provide some diagnostic information.

In the next build, we might find that the problem disappears. That means the same root cause as 2875 was involved. Or, we might find the the error persists; in that case, the new message text plus the content of the logfile window would be helpful. I've also adjusted the code so that the file involved won't be deleted in the case of an error being encountered. Retrieivng the file would provide more information, as well.

K7ZCZ

2018-09-05 12:28

manager   ~0006083

Also, I'm unable to reproduce the problem as described. When I log through JT Alert, I don't receive an error message. That means I either have a slightly different configuration, or the issue is dependent on data. A detailed description of the configuration and a copy of the data being logged would be helpful in diagnosing this issue.

K7ZCZ

2018-09-05 12:30

manager   ~0006084

This checkin includes the described diagnostic fixes.
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4330

k2dls

2018-09-05 16:19

viewer   ~0006085

Mike B., your point is quote valid. So I double checked the configuration to ensure that the QSO forwarding receiver on Logbook was turned off. It was unexpectedly on. I turned the 4 receive items off and retested. The loggings succeeded without error. While I am sure I did this during testing yesterday, I was testing both WSJT-X direct and via JT Alert so it is possible that either something was missed or not saved during a crash. So at this point, based upon today's retest, this ticket can be marked as resolved.

k2dls

2018-09-05 16:21

viewer   ~0006086

Cannot confirm on retest after making certain that the QSO forwarding receive parameters in Logbook were unchecked.

K7ZCZ

2018-09-05 19:02

manager   ~0006087

OK. If you can manage to get the error again, feel free to re-activate this issue. The aditional error messages are fine -- they'll help anybody with any problem that comes along in this area.

WA9PIE

2018-09-10 11:03

administrator   ~0006176

Putting FIV back... I changed it by accident.

K7ZCZ

2018-09-28 07:48

manager   ~0006237

Can this issue be closed?

k2dls

2018-09-28 08:08

viewer   ~0006241

OK to close.

Issue History

Date Modified Username Field Change
2018-09-04 12:14 k2dls New Issue
2018-09-04 12:14 k2dls File Added: HRD 881 Error.png
2018-09-04 14:49 k2dls File Added: HRDLogbook_20180904_194532.mdmp
2018-09-04 14:49 k2dls Note Added: 0006072
2018-09-05 11:19 K7ZCZ Note Added: 0006080
2018-09-05 12:15 K7ZCZ Assigned To => K7ZCZ
2018-09-05 12:15 K7ZCZ Status new => feedback
2018-09-05 12:15 K7ZCZ Note Added: 0006082
2018-09-05 12:16 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2018-09-05 12:16 K7ZCZ Assigned To K7ZCZ => k2dls
2018-09-05 12:28 K7ZCZ Note Added: 0006083
2018-09-05 12:30 K7ZCZ Note Added: 0006084
2018-09-05 16:19 k2dls Note Added: 0006085
2018-09-05 16:21 k2dls Status feedback => resolved
2018-09-05 16:21 k2dls Resolution open => unable to reproduce
2018-09-05 16:21 k2dls Testing => Not Started
2018-09-05 16:21 k2dls Note Added: 0006086
2018-09-05 19:02 K7ZCZ Note Added: 0006087
2018-09-06 20:03 K7ZCZ Fixed in Version => 6.4.0.882
2018-09-10 11:01 WA9PIE Fixed in Version 6.4.0.882 =>
2018-09-10 11:03 WA9PIE Fixed in Version => 6.4.0.882
2018-09-10 11:03 WA9PIE Note Added: 0006176
2018-09-11 16:24 WA9PIE Fixed in Version 6.4.0.882 =>
2018-09-28 07:48 K7ZCZ Note Added: 0006237
2018-09-28 08:08 k2dls Note Added: 0006241
2018-10-07 05:23 K7ZCZ Status resolved => closed
2018-10-07 05:23 K7ZCZ Resolution unable to reproduce => fixed
2018-12-05 11:22 WA9PIE Fixed in Version => 6.4.0.886
2018-12-05 11:23 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe