View Issue Details

IDProjectCategoryView StatusLast Update
0002910Ham Radio DeluxeBugpublic2018-11-11 22:33
ReporterPD9FER 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityrandom
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.902 
Summary0002910: Double City entry in ALE QTH field at lookup.
DescriptionWhen opening the ALE in Logbook and doing a call lookup, often the City is showed twice in the QTH field.
Mainly with US stations.
 
Steps To Reproducein Logbook open ALE
Do a Call sign lookup (ie WA9PIE)
Look at the populated QTH field and see 2 times the city Prosper.
See also attached screenshot.
Additional InformationTicket #391382
TagsNo tags attached.
ModuleLogbook
Sub-ModuleALE Window
Testing Beta Successful

Relationships

Activities

PD9FER

2018-10-01 02:12

viewer  

QTH.png (97,633 bytes)
QTH.png (97,633 bytes)

K7ZCZ

2018-10-22 15:49

manager   ~0006326

fix spelling in title for easier searching

K7ZCZ

2018-10-22 15:52

manager   ~0006327

This is fixed with the checkin below.

Turns out a table of values is used when handling lookup results. Some sections of the application use ADDR2 for what is displayed as the QTH. Other parts of the application compute and use their own QTH. I've set it straight, but we could use a bit more work in thsi area to try and make the code consistent and (much!) easier to maintain.

https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4386

PD9FER

2018-11-05 12:00

viewer   ~0006380

Fixed in build 900

Issue History

Date Modified Username Field Change
2018-10-01 02:12 PD9FER New Issue
2018-10-01 02:12 PD9FER File Added: QTH.png
2018-10-22 15:49 K7ZCZ Summary Double Citty entry in ALE QTH field at lookup. => Double City entry in ALE QTH field at lookup.
2018-10-22 15:49 K7ZCZ Description Updated View Revisions
2018-10-22 15:49 K7ZCZ Steps to Reproduce Updated View Revisions
2018-10-22 15:49 K7ZCZ Note Added: 0006326
2018-10-22 15:52 K7ZCZ Assigned To => K7ZCZ
2018-10-22 15:52 K7ZCZ Status new => resolved
2018-10-22 15:52 K7ZCZ Resolution open => fixed
2018-10-22 15:52 K7ZCZ Note Added: 0006327
2018-10-22 15:52 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2018-11-04 07:49 K7ZCZ Fixed in Version => 6.4.0.900
2018-11-05 12:00 PD9FER Note Added: 0006380
2018-11-05 12:01 WA9PIE Status resolved => closed
2018-11-05 12:01 WA9PIE Testing Not Started => Beta Successful
2018-11-11 00:34 WA9PIE Fixed in Version 6.4.0.900 => 6.4.0.902
2018-11-11 00:34 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-11-11 22:33 K7ZCZ Category Maintenance => Bug