View Issue Details

IDProjectCategoryView StatusLast Update
0002911Ham Radio DeluxeBugpublic2018-10-10 19:31
ReporterKB3NPH 
Assigned ToK7ZCZ 
PriorityimmediateSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.893 
Summary0002911: V6.4.0.888 DM and Logbook CRASH
DescriptionOSTicket #548517 - Did a remote into customer's compute to help resolve Logbook crashing with V6.4.0.887. I ran his current installation to check and when DM would be running, the Logbook would become non-responsive and close. This has been reported previously in .887. Downloaded and installed V6.4.0.888. When the program was run, RC loaded fine, Logbook loaded, but when DM started to load it would become non-responsive with the SPLASH screen showing.

Checked Task Manager and it showed both Logbook and DM as "Not Responding". Checked the Logbook and it displayed the Mini-Dump error screen. When the logbook closed, DM would then become responsive and opened as normal.

Tried to manually start by opening RC, Opening DM, then open Logbook, but as soon as the LB screen opened DM would close with no mini-dump. Start DM, and Logbook would crash with the mini-dump. Minidump is in the DUMPS folder in Mantis 2911 Folder.
Steps To ReproduceRun HRD Rig Control
Start Logbook from RC Toolbar
Start DM from Logbook Toolbar
DM will show splash screen and Logbook will CRASH with Mini Dump message. Once Logbook closes, DM will continue to load as normal.
Start Logbook again and DM will exit without any dump. Logbook will continue to run.

TagsNo tags attached.
ModuleLogbook
Sub-ModuleFunctional
Testing Beta Successful

Relationships

Activities

KB3NPH

2018-10-01 11:44

administrator   ~0006257

I also am having the same issue. Load RC, Load Logbook, load DM and as soon as DM splash screen opens, Logbook crashes with Mini domp. Entered the minidump in the Mantis 2911 folder in the Dumps folder. Once Logbook closes a minidump for DM is created. Included that dump in the dumps folder. The dumps that I had created are indicated with my callsign as the prefix in the dump name.

See the images attached to this Mantis record. See the dumps in the Dumps\Mantis 2911 folder.

KB3NPH LB Crash.jpg (134,983 bytes)
KB3NPH LB Crash.jpg (134,983 bytes)
KB3NPH DM Crash.jpg (120,847 bytes)
KB3NPH DM Crash.jpg (120,847 bytes)

KB3NPH

2018-10-01 13:49

administrator   ~0006258

OSTicket #792745 has just reported the EXACT same issue with Logbook and DM. Waiting for him to forward the mini-dumps to add to the collection.

K7ZCZ

2018-10-02 08:30

manager   ~0006260

What database is configured as the target for the Network Server in the Logbook options? Does that database exist? Can it be opened? Is it opened at the time of the crash?

K7ZCZ

2018-10-03 05:32

manager   ~0006262

Incomplete information in this report has made a solid diagnosis challenging. I spent about three hours playing with the apps to try to reason out what's happening. I think I've made some progress, but I do wish the team would consider a more thorough approach as I think clearer and more detailed reports would substantially aid my progress.

The dumps for the DM and Logbook closures don't appear to be available. Of the provided dumps, the most useful seem to be "KB3NPH HRDLogbook_20181001_162344.mdmp" and "OSTicket #548517 HRDLogbook_20181001_153133.mdmp", which contain the same stack pattern:

(2cd4.2170): C++ EH exception - code e06d7363 (first/second chance not available)
eax=00000000 ebx=13ad87b0 ecx=00000003 edx=00000000 esi=13ad8768 edi=13ad8778
eip=77ebb11c esp=1401d54c ebp=1401d558 iopl=0         nv up ei pl nz na po nc
cs=0023  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00000202
ntdll!NtGetContextThread+0xc:
77ebb11c c20800          ret     8
0:026> .ecxr
eax=1401f1a8 ebx=00000000 ecx=00000003 edx=00000000 esi=019a07bc edi=1401f254
eip=74a9ddc2 esp=1401f1a8 ebp=1401f204 iopl=0         nv up ei pl nz ac po nc
cs=0023  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00000212
KERNELBASE!RaiseException+0x62:
74a9ddc2 8b4c2454        mov     ecx,dword ptr [esp+54h] ss:002b:1401f1fc=a8269849
0:026> kp
  *** Stack trace for last set context - .thread/.cxr resets it
 # ChildEBP RetAddr  
00 1401f204 012262e3 KERNELBASE!RaiseException+0x62
01 1401f244 010df5eb HRDLogbook!_CxxThrowException(void * pExceptionObject = 0x1401f254, struct _s__ThrowInfo * pThrowInfo = 0x019a07bc)+0x5b [f:\dd\vctools\crt\crtw32\eh\throw.cpp @ 152] 
02 1401f258 010fabef HRDLogbook!AfxThrowInvalidArgException(void)+0x19 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\except.cpp @ 228] 
03 1401f2c0 010faf22 HRDLogbook!CMDIChildWnd::Create(wchar_t * lpszClassName = <Value unavailable error>, wchar_t * lpszWindowName = <Value unavailable error>, unsigned long dwStyle = <Value unavailable error>, struct tagRECT * rect = <Value unavailable error>, class CMDIFrameWnd * pParentWnd = <Value unavailable error>, struct CCreateContext * pContext = <Value unavailable error>)+0x177 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\winmdi.cpp @ 488] 
04 1401f304 010af307 HRDLogbook!CMDIChildWnd::LoadFrame(unsigned int nIDResource = 0x103, unsigned long dwDefaultStyle = 0x40cf8000, class CWnd * pParentWnd = 0x00000000, struct CCreateContext * pContext = 0x1401f340)+0xbe [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\winmdi.cpp @ 613] 
05 1401f320 01153fa2 HRDLogbook!CXTPFrameWndBase<CMDIChildWnd>::LoadFrame(unsigned int nIDResource = 0x103, unsigned long dwDefaultStyle = 0xcf8000, class CWnd * pParentWnd = 0x00000000, struct CCreateContext * pContext = 0x1401f340)+0x17 [c:\ham radio\codejock software\mfc\xtreme toolkitpro v15.0.2\source\commandbars\xtpframewnd.h @ 231] 
06 1401f354 0112cce6 HRDLogbook!CDocTemplate::CreateNewFrame(class CDocument * pDoc = 0x0816c260, class CFrameWnd * pOther = 0x00000000)+0x5d [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\doctempl.cpp @ 294] 
07 1401f384 0112cc9e HRDLogbook!CMultiDocTemplate::OpenDocumentFile(wchar_t * lpszPathName = 0x00000000 "", int bAddToMRU = 0n1, int bMakeVisible = 0n1)+0x44 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\docmulti.cpp @ 126] 
08 1401f398 016433c7 HRDLogbook!CMultiDocTemplate::OpenDocumentFile(wchar_t * lpszPathName = 0x00000000 "", int bMakeVisible = 0n1)+0x13 [f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\docmulti.cpp @ 110] 
09 1401f3b0 01640e47 HRDLogbook!CHRDLogbookApp::OpenDocument(int iIdx = 0n0)+0x17 [c:\ham radio\logbook\hrdlogbook\hrdlogbook.cpp @ 1267] 
0a 1401f400 01672d8b HRDLogbook!CHRDLogbookApp::FindOrOpenLogbookView(class ATL::CStringT<wchar_t,StrTraitMFC<wchar_t,ATL::ChTraitsCRT<wchar_t> > > strDatabase = "My Logbook")+0x157 [c:\ham radio\logbook\hrdlogbook\hrdlogbook.cpp @ 1114] 
0b 1401f434 01670741 HRDLogbook!CIpThread::FindOrOpenLogbookView(void)+0x9b [c:\ham radio\logbook\hrdlogbook\iplistener.cpp @ 853] 
0c 1401f6dc 0167025d HRDLogbook!CIpThread::DispatchCommand(class ATL::CStringT<wchar_t,StrTraitMFC<wchar_t,ATL::ChTraitsCRT<wchar_t> > > * strMessage = 0x1401f71c 60 '<', class ATL::CStringT<wchar_t,StrTraitMFC<wchar_t,ATL::ChTraitsCRT<wchar_t> > > * strReply = 0x1401f714)+0x291 [c:\ham radio\logbook\hrdlogbook\iplistener.cpp @ 919] 
0d 1401f89c 01673030 HRDLogbook!CIpThread::ProcessConnection(void)+0x23d [c:\ham radio\logbook\hrdlogbook\iplistener.cpp @ 1890] 
0e 1401f8d8 012234c5 HRDLogbook!CIpThread::StartThreadPoint(class CIpThread * pThisObj = 0x08094700)+0xb0 [c:\ham radio\logbook\hrdlogbook\iplistener.cpp @ 725] 
0f 1401f910 0122356c HRDLogbook!_callthreadstart(void)+0x1b [f:\dd\vctools\crt\crtw32\startup\thread.c @ 255] 
10 1401f918 77bf8484 HRDLogbook!_threadstart(void * ptd = <Value unavailable error>)+0x56 [f:\dd\vctools\crt\crtw32\startup\thread.c @ 237] 
11 1401f92c 77eb305a kernel32!BaseThreadInitThunk+0x24
12 1401f974 77eb302a ntdll!__RtlUserThreadStart+0x2f
13 1401f984 00000000 ntdll!_RtlUserThreadStart+0x1b



This stack shows that the "network server" feature is trying to open a database in the logook for subequent use from the network server. The Logbook has a long history of poorly managing the configuration of database choices for its communication and background connection features, and the problem here is a side-effect of that issue.

A thread is used to listen to a sockets which communicates with DM and other apps. The interface may need to connect to a database; if that database isn't already open in the Logbook, it tries to open it. (As far as I can tell, to work around this bug, all a user needs to do is manually open the database they have configured to be the target of the Network Server database operations.) When the logbook code tries to open the database on the background thread, it fails because MFC can't open a doc/view window on a thread other than the application's main thread. MFC ends up throwing an invalid argument exception, and that takes the app down.

Because dumps for the other crashes aren't submitted, I'm not able to fix anything surrounding them. It's probable that the Logbook's crash causes DM780 to fall over; it would be great to make the communication code in the applications more robust, but the provided dumps don't give quite enough infomration to deduce what's going wrong in the applications at the time.

PD9FER

2018-10-03 05:34

viewer   ~0006263

Added Ticket #647992.rar to the related dumps folder.

Customers comment:

scenario1
-start of HRD rig control, this starts the DM780 automatically on my setup. DM780 is ok.
-try to start logbook at DM780 top button bar
-when asked for lotw or eQSL, I press "nothing"
-logbook not started, creates minidump "HRDlogbook_20181002_220727.mdmp"
-after a while DM780 closed itself (not responding, minidump seen "HRDLogbook_20181002_221628.mdmp")

scenario2
-this scenario done immediately after scenario1 when rig control is still open
-try to start logbook at HRD Rig control
-this time HRD logbook starts ok
-try to start DM780 top button bar in logbook
-only startup screen of DM780 shows, program is not starting ok, see minidump "DigitalMaster_20181002_222018.mdmp"

PD9FER

2018-10-03 06:10

viewer   ~0006264

Repro on my computer.

Start RC
Start LB (have 2 databases) PD9FER Logbook and My Logbook (PD9FER Logbook is the one selected in Network server.)
Start DM....No problems
Close DM
Select My Logbook to be the active database
Start DM (Logbook crashes with a Minidump)

Shut down DM
Restart LB and selected PD9FER Logbook)
Start DM (Now getting an error popup telling:
Exception thrown in destructor
(f:\dd\vctools\vc7libs\ship\atlmfc\src\mfc\array_s.ccp:83)
Encountered a improper argument.

After this DM closes

Now restarted LB (Still with PD9FER Logbook active) and started DM and all is good without crash or errors.

K7ZCZ

2018-10-03 08:02

manager   ~0006265

A workaround is available that doesn't require any code changes.

This checkin has been made:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4358

PD9FER

2018-10-03 09:04

viewer   ~0006266

One fix would be, remove Network server
And lets DM auto select the active DB
And in DM build in an option to switch from DB so LB auto changes it to active
just my 2 cents

K7ZCZ

2018-10-03 09:54

manager   ~0006267

Details of the workaround are in this forum post:
https://forums.hamradiodeluxe.com/node/47736?p=47832

g3ucq

2018-10-03 13:32

viewer  

HRDLogbook_20181003_182147.zip (19,114,960 bytes)

g3ucq

2018-10-03 13:32

viewer   ~0006268

Opened the Logbook and selected a non-default database.
It did not appear in the Logbook. I.e a blank screen with the Cluster beneath.
Opened DM780 and a Logbook mini dump was created.
Attached here.

ke0hqz

2018-10-03 14:50

viewer   ~0006269

Ticket#932554 Logbook crash with minidump added to the Mantis 2911 folder.

K7ZCZ

2018-10-04 06:36

manager   ~0006272

I believe this is fixed in 890.

PD9FER

2018-10-04 08:00

viewer   ~0006274

Same problem with build 890

KB3NPH

2018-10-04 08:13

administrator   ~0006275

Same problem in 6.4.890. Load RC loads fine, then from the RC screen start the Logbook. Logbook starts fine. From Logbook screen start DM, splash screen comes up for DM then crashes with Mini dump. Minidump added to 2911 dump folder "KB3NPH - 890 Alpha DigitalMaster_20181004_124255.mdmp"

Shut HRD down and start in this order.

Load RC, loads fine, Load DM from RC gui, DM loads fine. Load Logbook from DM GUI and immediately get LB CRASH with mini=dump.
Entered this dump in the 2911 dump folder "KB3NPH - 890 Alpha HRDLogbook_20181004_125448.mdmp"

PD9FER

2018-10-05 05:51

viewer   ~0006276

Seems to be fixed with build 891
At least no errors or crashes when I do the Repro steps,

KB3NPH

2018-10-05 07:51

administrator   ~0006277

Tested 6.4.0.891 and all appears to be working correctly on my computer. Will try sending it to a couple customers who are having the problem and see if it resolves it for them before final confirmation that it is fixed.

g3ucq

2018-10-07 04:08

viewer   ~0006278

Ran the procedure at #6264 and had no problems.
Fixed for me.

Issue History

Date Modified Username Field Change
2018-10-01 11:16 KB3NPH New Issue
2018-10-01 11:21 KB3NPH Description Updated View Revisions
2018-10-01 11:21 KB3NPH Steps to Reproduce Updated View Revisions
2018-10-01 11:44 KB3NPH File Added: KB3NPH LB Crash.jpg
2018-10-01 11:44 KB3NPH File Added: KB3NPH DM Crash.jpg
2018-10-01 11:44 KB3NPH Note Added: 0006257
2018-10-01 13:49 KB3NPH Note Added: 0006258
2018-10-02 08:30 K7ZCZ Assigned To => K7ZCZ
2018-10-02 08:30 K7ZCZ Status new => feedback
2018-10-02 08:30 K7ZCZ Note Added: 0006260
2018-10-03 05:32 K7ZCZ Note Added: 0006262
2018-10-03 05:34 PD9FER Note Added: 0006263
2018-10-03 06:10 PD9FER Note Added: 0006264
2018-10-03 08:02 K7ZCZ Note Added: 0006265
2018-10-03 09:04 PD9FER Note Added: 0006266
2018-10-03 09:54 K7ZCZ Note Added: 0006267
2018-10-03 13:32 g3ucq File Added: HRDLogbook_20181003_182147.zip
2018-10-03 13:32 g3ucq Note Added: 0006268
2018-10-03 14:50 ke0hqz Note Added: 0006269
2018-10-04 06:25 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2018-10-04 06:36 K7ZCZ Status feedback => resolved
2018-10-04 06:36 K7ZCZ Resolution open => fixed
2018-10-04 06:36 K7ZCZ Note Added: 0006272
2018-10-04 08:00 PD9FER Note Added: 0006274
2018-10-04 08:13 KB3NPH Note Added: 0006275
2018-10-05 05:51 PD9FER Note Added: 0006276
2018-10-05 07:51 KB3NPH Note Added: 0006277
2018-10-07 04:08 g3ucq Note Added: 0006278
2018-10-07 05:24 K7ZCZ Fixed in Version => 6.4.0.891
2018-10-10 19:31 WA9PIE Status resolved => closed
2018-10-10 19:31 WA9PIE Fixed in Version 6.4.0.891 => 6.4.0.893
2018-10-10 19:31 WA9PIE Testing Not Started => Beta Successful
2018-10-10 19:31 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe