View Issue Details

IDProjectCategoryView StatusLast Update
0002917Ham Radio DeluxeBugpublic2019-02-24 15:13
ReporterWA9PIEAssigned ToWA9PIE 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionopen 
Product Version 
Target VersionFixed in Version6.5.0.196 
Summary0002917: "South Stop" implementation has problems and needs to be fixed or removed
DescriptionA good number of customers have reported that the displayed heading and/or rotor azimuth are off by 180 degrees since we implemented a "south stop" option. Actually, I don't think it's ever worked as intended.

I am creating this as a parent to 8 existing bugs related to this topic.

We have been told that the controller hardware should be configured for its north or south orientation and - because of this - there should be no need to attempt to do this in software.

We need to verify this conceptually with all the controller manufacturers and - if true - we need to remove the south stop code. If we DO need the south stop code, it needs to be defined and correctly implemented.
Steps To ReproduceThe steps to reproduce are contained within the child records.
Additional InformationConceptually, the "north/south stop" topic is as follows:

For hams in the southern hemisphere, the antenna would most often need to travel THROUGH the 0 (zero) degrees position. For example - a ham in Argentina may want to move the antenna from pointing towards East Asia to Europe. This would require travel through 0 degrees. So the stopping point of the router would physically be oriented to the south... placing the physical stopping point at 180 degrees - where it would be less likely to require travel through.

Conversely...

For hams in the northern hemisphere, the antenna would most often need to travel THROUGH the 180 degrees position. For example - a ham in Alaska may want to move the antenna from pointing towards East Asia to South America. This would require travel through 180 degrees. So the stopping point of the router would physically be oriented to the north... placing the physical stopping point at 0 degrees - where it would be less likely to require travel through.

If hardware settings on the rotor controller account for the physical orientation of the rotor, the south stop (or north stop) options are unnecessary and (frankly) just make a mess.

Must fix.
TagsSouth Stop
ModuleRotator
Sub-ModuleRotators
Testing Beta Successful

Relationships

parent of 0001384 closedJOSE Rotators with south stop stop positions (Yaesu G-540) do not work correctly 
parent of 0001637 closedJOSE Rotator DCU-2 North/South Stop not working correctly 
parent of 0001689 closedJOSE Yaesu Rotor not pointing accurately. 
parent of 0001715 closedJOSE Rotator - "Flip 180" button does not work 
parent of 0001779 closedJOSE Yaesu Rotor Visual Display Corrupted 
parent of 0001833 closedJOSE HRD Rotor - When South Stop is selected, East becomes 270 dgrees 
parent of 0002751 closedWA9PIE Documentation: "South Stop" option not described in documentation 

Activities

PD9FER

2018-10-24 09:20

viewer   ~0006345

Still getting tickets in about this issue.

JOSE

2019-01-29 20:43

developer   ~0007142

Cannot resolved issue because of 2751 and 1730. 1730 says that North/South stop doesn't fix the issue so might not be related at all.

WA9PIE

2019-01-29 23:46

administrator   ~0007148

I'll close out this parent with these other items get solved. I can see that they're all posted to the 188 build except 1730. Should it be in the 188 build?

WA9PIE

2019-02-23 10:59

administrator   ~0007491

All related items have been validated.

Issue History

Date Modified Username Field Change
2018-10-16 23:00 WA9PIE New Issue
2018-10-16 23:00 WA9PIE Status new => assigned
2018-10-16 23:00 WA9PIE Assigned To => JOSE
2018-10-16 23:00 WA9PIE Tag Attached: South Stop
2018-10-16 23:00 WA9PIE Relationship added parent of 0001384
2018-10-16 23:01 WA9PIE Relationship added parent of 0001637
2018-10-16 23:01 WA9PIE Relationship added parent of 0001689
2018-10-16 23:04 WA9PIE Relationship added parent of 0001715
2018-10-16 23:04 WA9PIE Relationship added parent of 0001730
2018-10-16 23:04 WA9PIE Relationship added parent of 0001779
2018-10-16 23:05 WA9PIE Relationship added parent of 0001833
2018-10-16 23:06 WA9PIE Relationship added parent of 0002751
2018-10-24 09:20 PD9FER Note Added: 0006345
2019-01-29 20:41 JOSE Assigned To JOSE => WA9PIE
2019-01-29 20:43 JOSE Note Added: 0007142
2019-01-29 23:46 WA9PIE Note Added: 0007148
2019-01-30 00:09 WA9PIE Relationship deleted parent of 0001730
2019-01-30 00:11 WA9PIE Status assigned => resolved
2019-01-30 00:11 WA9PIE Fixed in Version => 6.5.0.188
2019-02-23 10:59 WA9PIE Status resolved => closed
2019-02-23 10:59 WA9PIE Fixed in Version 6.5.0.188 => 6.5.0.195
2019-02-23 10:59 WA9PIE Testing Not Started => Beta Successful
2019-02-23 10:59 WA9PIE Note Added: 0007491
2019-02-24 14:36 WA9PIE Fixed in Version 6.5.0.195 => 6.5.0.196
2019-02-24 15:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe