View Issue Details

IDProjectCategoryView StatusLast Update
0002922Ham Radio DeluxeBugpublic2018-11-11 00:34
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status closedResolutionfixed 
Product Version6.4.0.898 
Target VersionFixed in Version6.4.0.902 
Summary0002922: Logbook: can crash when handling database command in database dropdown menu
DescriptionThe Dev Dashboard shows a few crashes in the OnRangeDatabase() handler in the Logbook application. This handler implements switching to (or opening) the different databases configured in the application. The commands are reachable in the dropdown menu attached to the "manager" button in the main toolbar of the Logbook application.

From the call stack (attached in an Excel spreadsheet) it looks like the view object is invalid. Maybe this means that the application is shutting down, or the view has been closed. Either way, it's easy to remediate the crash.

Steps To Reproduce
From the Microsoft Dev Center Dashboard, so no repro is available.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleData
Testing Not Tested

Relationships

Activities

K7ZCZ

2018-10-22 17:03

manager   ~0006328

fixed with this checkin
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4388

K7ZCZ

2018-10-22 23:20

manager   ~0006332

Oops! Forgot to add the stack trace spreadsheet. It is attached here.

Mantis2922Stack.xlsx (14,288 bytes)

WA9PIE

2018-11-05 11:45

administrator   ~0006374

Accepted without testing, due to the nature of the change.

Issue History

Date Modified Username Field Change
2018-10-22 16:56 K7ZCZ New Issue
2018-10-22 17:03 K7ZCZ Assigned To => K7ZCZ
2018-10-22 17:03 K7ZCZ Status new => resolved
2018-10-22 17:03 K7ZCZ Resolution open => fixed
2018-10-22 17:03 K7ZCZ Note Added: 0006328
2018-10-22 23:20 K7ZCZ File Added: Mantis2922Stack.xlsx
2018-10-22 23:20 K7ZCZ Note Added: 0006332
2018-11-04 07:49 K7ZCZ Fixed in Version => 6.4.0.900
2018-11-05 11:45 WA9PIE Status resolved => closed
2018-11-05 11:45 WA9PIE Steps to Reproduce Updated View Revisions
2018-11-05 11:45 WA9PIE Testing Not Started => Not Tested
2018-11-05 11:45 WA9PIE Note Added: 0006374
2018-11-11 00:34 WA9PIE Fixed in Version 6.4.0.900 => 6.4.0.902
2018-11-11 00:34 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe