View Issue Details

IDProjectCategoryView StatusLast Update
0002923Ham Radio DeluxeBugpublic2018-11-11 00:34
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.902 
Summary0002923: HRDStation: unchecked call to mbstowcs_s() causes crashes
DescriptionThe attached callstack reveals that there's a crash calling mbstowcs_s() from the ClientCallsignProc() in HRDStation. Looks like the buffer is too small, and the function doesn't cope with bad input properly. At the moment, this is about four percent of the crashes in the Rig Control app, according to the dashboard.
Steps To ReproduceNo specific repro steps, as this issue comes from analyzing a dump on the Microsoft Dev Center website.
TagsNo tags attached.
ModuleRig Control
Sub-ModuleVarious
Testing Not Tested

Relationships

related to 0002820 new 3 - Current Dev List All: many calls to wcstombs_s() are incorrect, all are unnecessary 

Activities

K7ZCZ

2018-10-22 23:18

manager  

Mantis2923Stack.xlsx (9,350 bytes)

K7ZCZ

2018-10-23 16:41

manager   ~0006342

This is one of many instances where mbcstowcs_s() is called in an incorrect pattern, as described in Mantis 2820.

K7ZCZ

2018-10-24 07:41

manager   ~0006343

fixed with this checkin
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4394

WA9PIE

2018-11-05 11:49

administrator   ~0006378

Accepted without testing, due to the nature of the change.

Issue History

Date Modified Username Field Change
2018-10-22 23:17 K7ZCZ New Issue
2018-10-22 23:18 K7ZCZ File Added: Mantis2923Stack.xlsx
2018-10-23 16:41 K7ZCZ Relationship added related to 0002820
2018-10-23 16:41 K7ZCZ Note Added: 0006342
2018-10-24 07:41 K7ZCZ Assigned To => K7ZCZ
2018-10-24 07:41 K7ZCZ Status new => resolved
2018-10-24 07:41 K7ZCZ Resolution open => fixed
2018-10-24 07:41 K7ZCZ Note Added: 0006343
2018-11-04 07:49 K7ZCZ Fixed in Version => 6.4.0.900
2018-11-05 11:49 WA9PIE Status resolved => closed
2018-11-05 11:49 WA9PIE Description Updated View Revisions
2018-11-05 11:49 WA9PIE Testing Not Started => Not Tested
2018-11-05 11:49 WA9PIE Note Added: 0006378
2018-11-11 00:34 WA9PIE Fixed in Version 6.4.0.900 => 6.4.0.902
2018-11-11 00:34 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe