View Issue Details

IDProjectCategoryView StatusLast Update
0002931Ham Radio DeluxeBugpublic2018-11-11 00:34
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version6.4.0.899 
Target VersionFixed in Version6.4.0.902 
Summary0002931: Logbook: "Selection" pane choice isn't highlighted when re-opened, but still applied
Description
The "Selection" setting applies a filtering query to the rows in the logbook. When the Logbook application re-opens after being closed, the selection setting is applied to the rows shown in the logbook view, but no visual indication is given that a selection is applied--leaving the user potentially confused about why all of their data isn't being displayed.

The layout restoration code should be fixed to highlight the applied "selection" in the pane, so the user has a visual que that there is a filter in place. Or, the selection should not be re-applied when the layout is restored.
Steps To Reproduce1) Open the Logbook application
2) Open your favorite database
3) In the view for that database, activate the "Selection" group in the "Display" pane
4) Chose any limiting query -- something that shows less than all of the rows in your database
5) Close the logbook
6) Open the logbook again. Your database and view should be restored
7) activate the "Display" pane and expand the "Selection" group


BUG#1) The rows are still filtered from the database, but the "Selection" pane shows no active filter. This is confusing -- it implies that no filter is active, but rows will be missing from the display because a filter actually is active.


TagsNo tags attached.
ModuleLogbook
Sub-ModuleAppearance/UI
Testing Beta Successful

Relationships

Activities

K7ZCZ

2018-11-03 09:51

manager   ~0006366

fixed with this checkin
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4404

WA9PIE

2018-11-06 00:24

administrator   ~0006392

I tried and cannot figure out how to repeat these steps.

K7ZCZ

2018-11-06 08:53

manager   ~0006395

Is there a question I can answer about the repro steps?

WA9PIE

2018-11-08 23:44

administrator   ~0006412

I'm not able to find the "Selection pane."

K7ZCZ

2018-11-09 18:27

manager   ~0006414

The Selection group is in the Display pane. The display pane appears to the left of the records list in each Logbook database view. This screenshot shows the Display pane prominently, with the "CW" query selected within the "Selection" group.

With the "CW" query selected, only records matching that query are displayed. We can clearly see the orange highlight around the "CW" choice in the Selection group, so we know there is a query active. The problem this bug resolves is that, at restart, a query might be applied, but the Selection group doesn't show anything highlighted -- so it's not apparent to the user that the rows in the Logbook database view are being filtered.

SelectionGroup.png (70,848 bytes)
SelectionGroup.png (70,848 bytes)

WA9PIE

2018-11-09 21:41

administrator   ~0006415

Ok, now that I understand it... I was able to test it and I can confirm that it exhibited the desired behavior.

Issue History

Date Modified Username Field Change
2018-11-02 13:09 K7ZCZ New Issue
2018-11-03 09:51 K7ZCZ Assigned To => K7ZCZ
2018-11-03 09:51 K7ZCZ Status new => resolved
2018-11-03 09:51 K7ZCZ Resolution open => fixed
2018-11-03 09:51 K7ZCZ Note Added: 0006366
2018-11-04 07:49 K7ZCZ Fixed in Version => 6.4.0.900
2018-11-06 00:24 WA9PIE Note Added: 0006392
2018-11-06 08:53 K7ZCZ Note Added: 0006395
2018-11-08 23:44 WA9PIE Note Added: 0006412
2018-11-09 18:27 K7ZCZ File Added: SelectionGroup.png
2018-11-09 18:27 K7ZCZ Note Added: 0006414
2018-11-09 21:41 WA9PIE Status resolved => closed
2018-11-09 21:41 WA9PIE Description Updated View Revisions
2018-11-09 21:41 WA9PIE Steps to Reproduce Updated View Revisions
2018-11-09 21:41 WA9PIE Testing Not Started => Beta Successful
2018-11-09 21:41 WA9PIE Note Added: 0006415
2018-11-11 00:34 WA9PIE Fixed in Version 6.4.0.900 => 6.4.0.902
2018-11-11 00:34 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe