View Issue Details

IDProjectCategoryView StatusLast Update
0002936Ham Radio DeluxeEnhancementpublic2018-12-01 08:14
ReporterKB3NPH 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.4.0.902 
Summary0002936: FTDX-5000 will not power on via HRD
DescriptionTicket #824428 - Customer reports that the FTDX-5000 can not be powered on via the HRD software. He claims that if he sets HRD up as an FT-950, the power on/power off function of the FTDX-5000 works, but when having the HRD set up as an FTDX-5000, the power off works from the software, but the software will not turn the radio back on. Below is from the CAT command Reference manual for the Power ON/OFF command in the FTDX-5000.

AI AUTO INFORMATION
Set 1 2 3 4 5 6 7 8 9 10 P1 0:Auto Information “OFF”
                                                                                                     1:Auto Information “ON”
                                                                                                     This parameter is set to “0" (OFF) automatically when the transceiver is turned “OFF.”
A i pi
Read 1 2 3 4 5 6 7 8 9 10
A i
Answer 1 2 3 4 5 6 7 8 9 10
A i pi

TagsFTDX-5000, Yaesu
ModuleRig Control
Sub-ModuleRadio Support
Testing Beta Successful

Relationships

Activities

K7ZCZ

2018-11-07 11:43

manager   ~0006396

This is more of an enhancement, since the FTDX 5000 never had code to support power on or off.

I've also set the module and sub-module fields so that tracking is a bit easier.

Note that the provide documentation is for the "Auto Information" command, which is not the command used to turn the radio on or off. The PC command ("Power Control") is used to turn the radio on or off.

K7ZCZ

2018-11-07 12:16

manager   ~0006397

Fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4408

I do not have access to an FT DX 5000, so please get back with the customer to see if the beta build with this change addresses their concern.

g3ucq

2018-11-08 00:39

viewer   ~0006401

Unable to test

WA9PIE

2018-11-08 22:44

administrator   ~0006411

My FTdx5000 is boxed up. Maybe another beta tester can try.

w4elp

2018-11-09 06:07

viewer   ~0006413

Power button in Rig Control does work to turn FTdx5000 off and on.
Check box in Rig Control options to prompt to turn radio off when closing, but no prompt.

WA9PIE

2018-11-09 21:45

administrator   ~0006416

W4ELP - what kind of interface are you using?

I've always used a microKEYER II. And because that devices was always powered up, I never had a problem with the power on/off. It seemed to me that other rig control interfaces weren't powered... and the rig wasn't powered... so the command wasn't recognized by the radio to turn on (though the OFF worked). We had a few complaints about this.

Ron Whitsel, W3RJW, has a 5000. I'm hoping he can confirm. I do need to know what rig control devices are being used.

I'd like to wrap this up within the next 24 hrs.

w4elp

2018-11-10 04:36

viewer   ~0006417

My rig control interface is just a simple cheapie USB to serial adapter with the FTDI chipset. Audio interface is also a cheapie USB audio adapter. They are both continuously powered from a powered USB hub.


Note that the FTdx5000, even with power off, is still "listening" on its com port. So it should be able to respond to a power-on command. Mine works ok in this regard. I never used that feature of Rig Control before, but it would sorta nice to automatically power the radio on and off when Rig Control is started of stopped.

WA9PIE

2018-11-10 11:12

administrator   ~0006418

Tested and confirmed by Ron.

Issue History

Date Modified Username Field Change
2018-11-06 09:29 KB3NPH New Issue
2018-11-07 11:43 K7ZCZ Category Bug => Enhancement
2018-11-07 11:43 K7ZCZ Module (select) => Rig Control
2018-11-07 11:43 K7ZCZ Sub-Module (select) => Radio Support
2018-11-07 11:43 K7ZCZ Note Added: 0006396
2018-11-07 12:16 K7ZCZ Assigned To => K7ZCZ
2018-11-07 12:16 K7ZCZ Status new => resolved
2018-11-07 12:16 K7ZCZ Resolution open => fixed
2018-11-07 12:16 K7ZCZ Note Added: 0006397
2018-11-07 20:47 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2018-11-07 20:47 K7ZCZ Fixed in Version => 6.4.0.901
2018-11-08 00:39 g3ucq Note Added: 0006401
2018-11-08 22:44 WA9PIE Note Added: 0006411
2018-11-09 06:07 w4elp Note Added: 0006413
2018-11-09 21:45 WA9PIE Note Added: 0006416
2018-11-10 04:36 w4elp Note Added: 0006417
2018-11-10 11:12 WA9PIE Status resolved => closed
2018-11-10 11:12 WA9PIE Testing Not Started => Beta Successful
2018-11-10 11:12 WA9PIE Note Added: 0006418
2018-11-11 00:34 WA9PIE Fixed in Version 6.4.0.901 => 6.4.0.902
2018-11-11 00:34 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2018-12-01 08:14 WA9PIE Tag Attached: FTDX-5000
2018-12-01 08:14 WA9PIE Tag Attached: Yaesu