View Issue Details

IDProjectCategoryView StatusLast Update
0002940Ham Radio DeluxeBugpublic2019-01-16 22:05
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.5.0.183 
Summary0002940: Logbook: Don't ship HRD001.DLL
DescriptionThis DLL is a failed attempt to build a relational database, and a corresponding C-level API, around the Logbook database. It's hopelessly flawed, doesn't work, isn't used by the application itself, isn't tested, and isn't documented.

We're better off not shipping it at all.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleInterfacing
Testing Not Tested

Relationships

related to 0003041 new 3 - Current Dev List Remove HRDLog001 project from the build 

Activities

K7ZCZ

2018-11-11 15:04

manager   ~0006423

The HRDLog001 project is disabled in the build as of this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4426

Need to actually trim it out of setup, too, and maybe modify the build script.

K7ZCZ

2018-11-11 20:44

manager   ~0006425

This was checked in to the 6.5 branch to remove HRDLog001 from the install scripts.
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4432

WA9PIE

2018-12-21 00:43

administrator   ~0006758

Bravo!

K7ZCZ

2019-01-06 14:20

manager   ~0006892

This checkin removes the HRDLog001 project and its code from our source tree.
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4669

K7ZCZ

2019-01-06 14:49

manager   ~0006894

This checkin reverts the previous removal. Turns out there are some dependencies from DM780 on the HRDLog001 code, even though HRDLog001 isn't built directly. It looks like there is a lot of dead code that can be removed once HRDLog001 is actually removed from the project.

https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4670

Issue History

Date Modified Username Field Change
2018-11-10 05:09 K7ZCZ New Issue
2018-11-11 15:04 K7ZCZ Note Added: 0006423
2018-11-11 20:44 K7ZCZ Note Added: 0006425
2018-11-23 10:57 K7ZCZ Assigned To => K7ZCZ
2018-11-23 10:57 K7ZCZ Status new => resolved
2018-11-23 10:57 K7ZCZ Resolution open => fixed
2018-12-09 15:44 K7ZCZ Fixed in Version => 6.5.0.132
2018-12-21 00:43 WA9PIE Status resolved => closed
2018-12-21 00:43 WA9PIE Testing Not Started => Not Tested
2018-12-21 00:43 WA9PIE Note Added: 0006758
2019-01-06 14:20 K7ZCZ Note Added: 0006892
2019-01-06 14:49 K7ZCZ Note Added: 0006894
2019-01-06 15:29 K7ZCZ Relationship added related to 0003041
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.132 => 6.5.0.183
2019-01-16 22:05 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe