View Issue Details

IDProjectCategoryView StatusLast Update
0002948Ham Radio DeluxeBugpublic2019-11-07 05:46
ReporterK7ZCZAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformIntel i7-5960XOSWindows 10 Professional x64OS Version16299
Product Version6.4.0.907 
Target VersionFixed in Version6.5.0.196 
Summary0002948: Logbook: Manual QRZ upload doesn't work reliably
DescriptionUsing commands to manually upload records from the Logbook to QRZ doesn't actually work.

The code is broken in such a way that sometimes some records might update, depending on how many were selected. And it probably works fine if all items are selected. But it's trivial to make a case where selecting a combination of individual items and asking them to upload simply doesn't work.
Steps To Reproduce1) Fire up the Logbook
2) Open your favorite database. We need a database with a couple dozen records, at least.
3) Select the second record in the Logbook view
4) Right-click on that same entry in the Logbook view
5) In the resulting context menu, click "File"
6) In the resulting tear-off menu, click "QRZ"
7) In the resulting tear-off menu, click "Upload"

8) In the resulting "qrz.com Upload" dialog, make sure your API key is entered
9) Press the "OK" button

BUG#1) The window updates and says this:

OK: 0
Warning: 0
Error: 0
Updating Local Database: 1


which doesn't make sense. Since no items are OK, none were updated; and there's nothing to update in the local database, so saying that 1 item should be updated isn't true. And that item isn't updated, and nothing was sent to QRZ anyway.

Note that the same repro can be done with "QRZ" command under the "File" tear-off in the "Logbook" drop-down menu in the Logbook's main frame window.
TagsNo tags attached.
ModuleLogbook
Sub-Module(select)
Testing Beta Successful

Relationships

has duplicate 0001962 closedKB3NPH 5 - Closed w/o Action QRZ and eQSL Log upload failures 

Activities

K7ZCZ

2018-11-23 16:49

administrator  

QZRUploadDialog.png (10,041 bytes)
QZRUploadDialog.png (10,041 bytes)

K7ZCZ

2018-11-23 18:58

administrator   ~0006453

fixed in the 6.5 branch with this checkin
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4485

WA9PIE

2018-12-22 00:06

administrator   ~0006791

Validated

Issue History

Date Modified Username Field Change
2018-11-23 16:49 K7ZCZ New Issue
2018-11-23 16:49 K7ZCZ File Added: QZRUploadDialog.png
2018-11-23 18:58 K7ZCZ Assigned To => K7ZCZ
2018-11-23 18:58 K7ZCZ Status new => resolved
2018-11-23 18:58 K7ZCZ Resolution open => fixed
2018-11-23 18:58 K7ZCZ Note Added: 0006453
2018-12-09 15:42 K7ZCZ Fixed in Version => 6.5.0.132
2018-12-15 12:49 K7ZCZ Relationship added has duplicate 0001962
2018-12-22 00:06 WA9PIE Status resolved => closed
2018-12-22 00:06 WA9PIE Description Updated View Revisions
2018-12-22 00:06 WA9PIE Steps to Reproduce Updated View Revisions
2018-12-22 00:06 WA9PIE Testing Not Started => Beta Successful
2018-12-22 00:06 WA9PIE Note Added: 0006791
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.132 => 6.5.0.183
2019-01-16 22:04 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2019-11-07 05:46 WA9PIE Fixed in Version 6.5.0.183 => 6.5.0.196