View Issue Details

IDProjectCategoryView StatusLast Update
0002949Ham Radio DeluxeBugpublic2019-01-16 22:04
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformIntel i7-5960XOSWindows 10 Professional x64OS Version16299
Product Version6.4.0.907 
Target VersionFixed in Version6.5.0.183 
Summary0002949: Logook: Manual QRZ upload shouldn't try to upload when no items selected
DescriptionThe QRZ upload process tries to upload data when there is no data to upload. It could be smarter, and therefore provide a better user experience.

The commands to bring up this dialog should be disabled when nothing is selected.
Steps To Reproduce1) Fire up the Logbook
2) Open your favorite database. We need a database with a couple dozen records, at least.
3) Make sure that no items are selected in the Logbook view.
4) Use the "QRZ" command in the "File" tear-off of the "Logbook" drop-down menu in the Logbook's main frame window.

BUG#1) The "qrz.com Upload" dialog opens. There's no work for it to do, though, because nothing is selected.

5) Press the "OK" button in the dialog

BUG#2) The window tries to do nothing. It shouldn't have been accessible in the first place. It ends up showing this status:

OK: 0
Warning: 0
Error: 0
Updating Local Database: 0



TagsNo tags attached.
ModuleLogbook
Sub-ModuleInterfacing
Testing Beta Successful

Relationships

Activities

K7ZCZ

2018-11-24 10:57

manager   ~0006461

Fixed in the 6.5 branch with this checkin
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4490

WA9PIE

2018-12-22 00:08

administrator   ~0006793

Validated

Issue History

Date Modified Username Field Change
2018-11-23 16:52 K7ZCZ New Issue
2018-11-24 10:57 K7ZCZ Assigned To => K7ZCZ
2018-11-24 10:57 K7ZCZ Status new => resolved
2018-11-24 10:57 K7ZCZ Resolution open => fixed
2018-11-24 10:57 K7ZCZ Note Added: 0006461
2018-12-09 15:42 K7ZCZ Fixed in Version => 6.5.0.132
2018-12-22 00:08 WA9PIE Status resolved => closed
2018-12-22 00:08 WA9PIE Steps to Reproduce Updated View Revisions
2018-12-22 00:08 WA9PIE Sub-Module (select) => Interfacing
2018-12-22 00:08 WA9PIE Testing Not Started => Beta Successful
2018-12-22 00:08 WA9PIE Note Added: 0006793
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.132 => 6.5.0.183
2019-01-16 22:04 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe