View Issue Details

IDProjectCategoryView StatusLast Update
0002953Ham Radio DeluxeBugpublic2019-01-16 22:04
ReporterKB3NPH 
Assigned ToK7ZCZ 
PriorityhighSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.5.0.183 
Summary0002953: FT-991 and FT-991A Frequency changes very SLOW!
DescriptionMany customers who use the FT-991 and 991A radios are reporting when they change frequency from HRD rig control, the radio is very slow to respond. They also report that changing frequency from the radio it takes an unusually long time before Rig Control reflects the change in the GUI. This has been happening for quit some time.

It appears this is not related to any specific version of Windows and has been happening in the last several updates to Ham Radio Deluxe, so the problem appears to definitely associated with the CAT control of these radios.

We have attempted to resolve this via support by trying different port baud rates and refresh rates in Rig Control, but nothing we try seems to resolve this problem.

TagsFT-991, FT-991A, Yaesu
ModuleRig Control
Sub-ModuleFunctional
Testing Beta Successful

Relationships

has duplicate 0002928 closedK7ZCZ 4 - Closed w/o Action FT-991 and 991A - Response to Rig Control very slow 

Activities

K7ZCZ

2018-11-24 10:52

manager   ~0006460

How is this different than 2928? Do we need to have both issues open?

KC7FPF

2018-12-10 12:19

viewer   ~0006565

Received call from customer W1DMS/KO4MDS indicating he is experencing the same issue(s) as well with FT991A

K7ZCZ

2018-12-13 11:21

manager   ~0006600

fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4555

WA9PIE

2019-01-01 21:53

administrator   ~0006843

I'm going to pass this one. I've tried it at 4800 bps. And it seems fine to me now.

However...

It sure looks like a redundant command is being sent. That is...

It seems to be sending (1) set frequency, (2) set mode, and then (3) another set frequency.

If I'm correct, it should be (1) set mode and then (2) set frequency. (The order is important due to the frequency offset caused by changing modes after the frequency is changed... which is most likely why there could be an extra set frequency here now.)

Issue History

Date Modified Username Field Change
2018-11-24 00:06 KB3NPH New Issue
2018-11-24 10:52 K7ZCZ Note Added: 0006460
2018-11-24 10:52 K7ZCZ Relationship added related to 0002928
2018-11-27 11:56 WA9PIE Tag Attached: FT-991
2018-11-29 00:17 WA9PIE Tag Attached: Yaesu FT-991(A)
2018-11-29 00:18 WA9PIE Tag Detached: FT-991
2018-11-30 18:12 WA9PIE Tag Attached: Yaesu
2018-11-30 18:13 WA9PIE Tag Attached: FT-991
2018-11-30 18:14 WA9PIE Tag Attached: FT-991A
2018-11-30 18:14 WA9PIE Tag Detached: FT-991
2018-11-30 18:14 WA9PIE Tag Detached: Yaesu FT-991(A)
2018-12-10 12:19 KC7FPF Note Added: 0006565
2018-12-12 17:58 K7ZCZ Relationship replaced has duplicate 0002928
2018-12-13 00:01 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-12-13 11:21 K7ZCZ Assigned To => K7ZCZ
2018-12-13 11:21 K7ZCZ Status new => resolved
2018-12-13 11:21 K7ZCZ Resolution open => fixed
2018-12-13 11:21 K7ZCZ Note Added: 0006600
2018-12-14 17:14 K7ZCZ Tag Attached: FT-991
2018-12-14 17:14 K7ZCZ Fixed in Version => 6.5.0.137
2019-01-01 21:53 WA9PIE Status resolved => closed
2019-01-01 21:53 WA9PIE Testing Not Started => Beta Successful
2019-01-01 21:53 WA9PIE Note Added: 0006843
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.137 => 6.5.0.183
2019-01-16 22:04 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe