View Issue Details

IDProjectCategoryView StatusLast Update
0002957Ham Radio DeluxeBugpublic2019-01-16 22:04
ReporterPD9FERAssigned ToK7ZCZ 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.5.0.183 
Summary0002957: New Beta 6.5.0.130 Digital Master crashes on loading.
DescriptionDigital Master crashes on startup creating a Minidump (attached in the related Dumps folder)
This is confirmed by the Beta team.
Steps To ReproduceInstall Beta 6.5.0.130
Start RC
Start LB
Start DM (crash)
TagsNo tags attached.
ModuleDM780
Sub-ModuleVarious
Testing Beta Successful

Activities

PD9FER

2018-11-29 05:18

viewer   ~0006478

In the Dumps\Mantis 2957\DigitalMaster_20181129_111102.rar

K7ZCZ

2018-11-29 16:24

manager   ~0006486

Here's the callstack from this dump:

0:000> .ecxr
eax=00000000 ebx=0ccfbd80 ecx=0ce353b0 edx=016f8f4c esi=0ccfbd80 edi=0044ded0
eip=0123cdf2 esp=0044dd8c ebp=0044ddf8 iopl=0         nv up ei pl nz na po nc
cs=0023  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00010202
Digital_Master!CStandardFormInput::OnUpdateButtonPlay+0x72:
0123cdf2 8b8048200400    mov     eax,dword ptr [eax+42048h] ds:002b:00042048=????????
0:000> kb
  *** Stack trace for last set context - .thread/.cxr resets it
 # ChildEBP RetAddr  Args to Child              
00 0044ddf8 012c7d6e 0044ded0 ffffffff 017beae8 Digital_Master!CStandardFormInput::OnUpdateButtonPlay+0x72 [c:\hrd65\digital master\digital master\standardforminput.cpp @ 892] 
01 0044de10 012c7a96 0ccfbd80 0000809f ffffffff Digital_Master!_AfxDispatchCmdMsg+0x122 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\cmdtarg.cpp @ 281] 
02 0044de48 012c2eae 0000809f ffffffff 0044ded0 Digital_Master!CCmdTarget::OnCmdMsg+0x154 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\cmdtarg.cpp @ 372] 
03 0044de70 012c7805 0000809f ffffffff 0044ded0 Digital_Master!CDialog::OnCmdMsg+0x1c [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\dlgcore.cpp @ 85] 
04 0044dea0 0146b545 0ccfbd80 00000001 0ce353b0 Digital_Master!CCmdUI::DoUpdate+0x40 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\cmdtarg.cpp @ 760] 
05 0044deb4 0146e143 0ccfbd80 00000001 7fffffff Digital_Master!CXTPCommandBar::CCommandBarCmdUI::DoUpdate+0x25 [c:\program files (x86)\codejock software\mfc\xtreme toolkitpro v18.3.0\source\commandbars\xtpcommandbar.cpp @ 750] 
06 0044df10 0146d237 0146d270 0146d27c 00000001 Digital_Master!CXTPCommandBar::OnUpdateCmdUI+0x163 [c:\program files (x86)\codejock software\mfc\xtreme toolkitpro v18.3.0\source\commandbars\xtpcommandbar.cpp @ 842] 
07 0044df18 0146d27c 00000001 00000000 012bf10e Digital_Master!CXTPCommandBar::OnIdleUpdateCmdUI+0x27 [c:\program files (x86)\codejock software\mfc\xtreme toolkitpro v18.3.0\source\commandbars\xtpcommandbar.cpp @ 668] 
08 0044df24 012bf10e 811b6c8a 0ce45b00 0146e170 Digital_Master!CXTPCommandBar::OnInitialUpdate+0xc [c:\program files (x86)\codejock software\mfc\xtreme toolkitpro v18.3.0\source\commandbars\xtpcommandbar.cpp @ 760] 
09 0044dfec 0146e19b 00000364 00000000 00000000 Digital_Master!CWnd::OnWndMsg+0x53e [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 2465] 
0a 0044e008 012c052a 00000364 00000000 00000000 Digital_Master!CXTPCommandBar::OnWndMsg+0x2b [c:\program files (x86)\codejock software\mfc\xtreme toolkitpro v18.3.0\source\commandbars\xtpcommandbar.cpp @ 2615] 
0b 0044e02c 012bb3a8 00000364 00000000 00000000 Digital_Master!CWnd::WindowProc+0x2d [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 2099] 
0c 0044e0a0 012bfe9d 0ce45b00 00011772 00000364 Digital_Master!AfxCallWndProc+0xc6 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 268] 
0d 0044e0c0 012bfed5 00011766 00000364 00000000 Digital_Master!CWnd::SendMessageToDescendants+0x31 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 3025] 
0e 0044e0e4 012bfed5 00011762 00000364 00000000 Digital_Master!CWnd::SendMessageToDescendants+0x69 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 3013] 
0f 0044e108 012bfed5 0001156c 00000364 00000000 Digital_Master!CWnd::SendMessageToDescendants+0x69 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 3013] 
10 0044e12c 012d284f 00081150 00000364 00000000 Digital_Master!CWnd::SendMessageToDescendants+0x69 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\wincore.cpp @ 3013] 
11 (Inline) -------- -------- -------- -------- Digital_Master!CWnd::SendMessageToDescendants+0x15 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\include\afxwin2.inl @ 129] 
12 0044e158 0139840d 0c9ef568 00000001 0044e1a4 Digital_Master!CFrameWnd::InitialUpdateFrame+0x5e [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\winfrm.cpp @ 817] 
13 0044e168 012f276e 0ccfb5a0 0c9ef568 00000001 Digital_Master!CDocTemplate::InitialUpdateFrame+0x11 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\doctempl.cpp @ 408] 
14 0044e1a4 012f25d6 00000000 00000001 00000001 Digital_Master!CMultiDocTemplate::OpenDocumentFile+0x192 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\docmulti.cpp @ 171] 
15 0044e1c0 0116560c 00000000 00000001 811b50e6 Digital_Master!CMultiDocTemplate::OpenDocumentFile+0x23 [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\docmulti.cpp @ 109] 
16 0044e380 010fe95e 811b48f6 018899c0 010fcad0 Digital_Master!CMainFrame::LoadLayout+0xe2c [c:\hrd65\digital master\digital master\mainfrm.cpp @ 9640] 
17 0044fb90 016784fb 00000000 01cde9bc 7efde000 Digital_Master!CDigitalMasterApp::InitInstance+0x1e8e [c:\hrd65\digital master\digital master\digital master.cpp @ 1238] 
18 0044fba8 01410d95 010c0000 00000000 008126b4 Digital_Master!AfxWinMain+0x5f [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\winmain.cpp @ 37] 
19 (Inline) -------- -------- -------- -------- Digital_Master!invoke_main+0x1a [d:\agent\_work\3\s\src\vctools\crt\vcstartup\src\startup\exe_common.inl @ 118] 
1a 0044fbf4 7530343d 7efde000 0044fc40 77b89802 Digital_Master!__scrt_common_main_seh+0xf8 [d:\agent\_work\3\s\src\vctools\crt\vcstartup\src\startup\exe_common.inl @ 288] 
1b 0044fc00 77b89802 7efde000 77925c3a 00000000 kernel32!BaseThreadInitThunk+0xe
1c 0044fc40 77b897d5 01410e19 7efde000 00000000 ntdll!__RtlUserThreadStart+0x70
1d 0044fc58 00000000 01410e19 7efde000 00000000 ntdll!_RtlUserThreadStart+0x1b

K7ZCZ

2018-11-29 16:25

manager   ~0006487

Completely different call stacks mean that this is not a duplicate of 2956.

K7ZCZ

2018-11-29 17:05

manager   ~0006488

This bug has existed for a while, I think. Code that's meant to enable and lable the play button examines the wrong variable to see if a window exists before dereferencing the pointer to that window:

    else if (m_pSuperView)
        nIndex = m_pSuperFrame->QSOOutput().GetModeIndex();

K7ZCZ

2018-11-30 09:10

manager   ~0006491

Last edited: 2018-11-30 09:10

View 2 revisions

The bad check above was copied-and-pasted throughout this module in https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/2041. I've fixed it in all places. I don't crash at startup anymore on my test case, so I think this is fixed.

K7ZCZ

2018-11-30 09:13

manager   ~0006492

fixed with this change set: https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4498

PD9FER

2018-11-30 09:19

viewer   ~0006494

Thanks... I let you know the results when the next beta is there

PD9FER

2018-12-01 04:10

viewer   ~0006496

Fixed in 6.5.0.131

g3ucq

2018-12-14 06:10

viewer   ~0006629

Fixed for me.

Issue History

Date Modified Username Field Change
2018-11-29 05:15 PD9FER New Issue
2018-11-29 05:18 PD9FER Note Added: 0006478
2018-11-29 05:21 PD9FER Relationship added has duplicate 0002956
2018-11-29 16:24 K7ZCZ Note Added: 0006486
2018-11-29 16:24 K7ZCZ Relationship deleted has duplicate 0002956
2018-11-29 16:25 K7ZCZ Note Added: 0006487
2018-11-29 17:05 K7ZCZ Note Added: 0006488
2018-11-30 09:10 K7ZCZ Note Added: 0006491
2018-11-30 09:10 K7ZCZ Note Edited: 0006491 View Revisions
2018-11-30 09:13 K7ZCZ Assigned To => K7ZCZ
2018-11-30 09:13 K7ZCZ Status new => resolved
2018-11-30 09:13 K7ZCZ Resolution open => fixed
2018-11-30 09:13 K7ZCZ Note Added: 0006492
2018-11-30 09:19 PD9FER Note Added: 0006494
2018-12-01 04:10 PD9FER Note Added: 0006496
2018-12-05 11:24 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2018-12-09 15:42 K7ZCZ Fixed in Version => 6.5.0.132
2018-12-14 06:10 g3ucq Note Added: 0006629
2018-12-20 22:32 WA9PIE Status resolved => closed
2018-12-20 22:32 WA9PIE Testing Not Started => Beta Successful
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.132 => 6.5.0.183
2019-01-16 22:04 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe