View Issue Details

IDProjectCategoryView StatusLast Update
0002959Ham Radio DeluxeBugpublic2019-01-16 22:04
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version6.5.0.130 
Target VersionFixed in Version6.5.0.183 
Summary0002959: Rig Control: can't connect to DemoMatic radios
DescriptionIn build 6.5.130, I can't connect to demomatic radios.
Steps To Reproduce1) Start Rig Control
2) Select Company = DemoMatic
3) Select Radio = "FT-950: Demo", for example. Seems to repro with any DemoMatic radio
4) Press Connect.

BUG#1) Can't connect. An error is shown as if system is trying to connect to a real radio, about can't read the frequency from the COM port. This message box is displayed:

---------------------------
Error
---------------------------
FT-950: Demo, COM3, 57600, Failed to read frequency

Make sure your radio is switched on and not in memory mode.
If you are using a homemade/non-standard cable you may need to select RTS and/or DTR.

---------------------------
OK   
---------------------------
TagsNo tags attached.
ModuleRig Control
Sub-ModuleRadio Support
Testing Beta Successful

Relationships

has duplicate 0002973 closedK7ZCZ 4 - Closed w/o Action Demomatic "Orion: Demo" doesn't work as a demo; tries to find COM ports 

Activities

K7ZCZ

2018-11-29 14:54

manager   ~0006483

Fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4496

WA9PIE

2018-12-11 20:36

administrator   ~0006581

Looks like the only one left that has this problem is the Orion demo.

K7ZCZ

2018-12-12 09:15

manager   ~0006586

The Orion DemoMatic radio was broken with change 4051, which I made while pursuing a fix for the 40m issue with the real radio, as in Mantis 2578.

This checkin removes the 40m change from the code path used for DemoMatic Orion connections:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4546

WA9PIE

2018-12-12 11:40

administrator   ~0006588

I validated the change for the Orion.

Issue History

Date Modified Username Field Change
2018-11-29 13:58 K7ZCZ New Issue
2018-11-29 14:54 K7ZCZ Assigned To => K7ZCZ
2018-11-29 14:54 K7ZCZ Status new => resolved
2018-11-29 14:54 K7ZCZ Resolution open => fixed
2018-11-29 14:54 K7ZCZ Note Added: 0006483
2018-12-08 19:40 K7ZCZ Relationship added has duplicate 0002973
2018-12-09 15:42 K7ZCZ Fixed in Version => 6.5.0.132
2018-12-11 20:36 WA9PIE Status resolved => feedback
2018-12-11 20:36 WA9PIE Resolution fixed => reopened
2018-12-11 20:36 WA9PIE Steps to Reproduce Updated View Revisions
2018-12-11 20:36 WA9PIE Note Added: 0006581
2018-12-12 09:15 K7ZCZ Status feedback => resolved
2018-12-12 09:15 K7ZCZ Resolution reopened => fixed
2018-12-12 09:15 K7ZCZ Note Added: 0006586
2018-12-12 11:40 WA9PIE Status resolved => closed
2018-12-12 11:40 WA9PIE Fixed in Version 6.5.0.132 => 6.5.0.133
2018-12-12 11:40 WA9PIE Testing Not Started => Beta Successful
2018-12-12 11:40 WA9PIE Note Added: 0006588
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.133 => 6.5.0.183
2019-01-16 22:04 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe