View Issue Details

IDProjectCategoryView StatusLast Update
0002960Ham Radio DeluxeMaintenancepublic2019-11-08 02:32
ReporterKB3NPHAssigned ToK7ZCZ 
PriorityhighSeveritymajorReproducibilityN/A
Status closedResolutionduplicate 
Product Version 
Target VersionFixed in Version6.7.0.244 
Summary0002960: DM-780 Data Controller
DescriptionFor 2+ years I have been requesting the Data Controller option in DM-780 removed, but it has fallen on deaf ears. The Data Controller was put into DM-780 about 4 years ago to try to support the Timewave/AEA PK232 series TNCs. From day one, this option has NEVER worked. For the years since, it has caused more support requests than almost any other issue we run into with the software. At first, the "Auto-Connect" option in the Data Controller pane was checked by default. When this was checked, people would get an error when starting DM-780 indicating the connection to the port was not allowed. Finally Mike B removed the default check mark and that slowed down the support requests, however t did not resolve the problem completely.

Many users, even those using the SignaLink USB think they are using a TNC or Data Controller, so they open that pane and check that "Auto-Connect" option, which only generates the "Access Denied" error, so they open a support ticket about it. It waists a support techs time to respond to these unnecessarily generated errors and support requests.

Over the past 2 years, I have talked with Randy on several occasions, the latest being just this past fall while doing the remote demo for the HRO store in Milwaukee, WI. Timewave has been working on a re-write of the old PacRATT software and had plans on interfacing that with DM-780 for support of the Timewave/AEA TNCs. As of the HRO show, according to Randy, there is no timeline as to when this rewrite will be completed. Still, Randy doesn't feel we should remove that Data Controller option from DM as it will be the groundwork for interfacing the PacRATT software to DM once it is completed.

It's my opinion along with the other support techs that at the very least, this Data Controller option in DM-780 should be "hidden" from view of the end users so it doesn't cause a lot of unnecessary errors resulting in support requests.

PLEASE take this into serious consideration for the next and future builds of HRD, at least until such time that Timewave completes their software rewrite and it could then become a functional part of DM-780.

TagsNo tags attached.
ModuleDM780
Sub-ModuleFunctional
Testing Beta Successful

Relationships

duplicate of 0001959 closedPD9FER Data Controller comport is enabled when 1st installed 
related to 0001780 closedK7ZCZ In Data Contoller Mode Wrong Mode Sent to TNC 
related to 0001781 closedK7ZCZ In Data Controller Mode, unable to reconnect to TNC after Disconnect 
related to 0001782 closedK7ZCZ In Data Controller Mode still shows normal SC in Waterfall 

Activities

K7ZCZ

2019-10-05 11:07

administrator   ~0008752

As far as I can tell, this is a duplicate of 1959

g3ucq

2019-10-23 03:47

viewer   ~0008919

Unable to test

WA9PIE

2019-10-23 04:09

administrator   ~0008930

Validated as part of 0001959.

Issue History

Date Modified Username Field Change
2018-11-30 09:23 KB3NPH New Issue
2018-11-30 09:26 K7ZCZ Relationship added related to 0001780
2018-11-30 09:26 K7ZCZ Relationship added related to 0001781
2018-11-30 09:26 K7ZCZ Relationship added related to 0001782
2018-11-30 09:26 K7ZCZ Relationship added related to 0001959
2019-10-05 11:07 K7ZCZ Assigned To => K7ZCZ
2019-10-05 11:07 K7ZCZ Status new => resolved
2019-10-05 11:07 K7ZCZ Resolution open => fixed
2019-10-05 11:07 K7ZCZ Note Added: 0008752
2019-10-05 11:07 K7ZCZ Relationship replaced duplicate of 0001959
2019-10-06 18:32 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2019-10-21 17:01 K7ZCZ Fixed in Version => 6.7.0.235
2019-10-23 03:47 g3ucq Note Added: 0008919
2019-10-23 04:09 WA9PIE Status resolved => closed
2019-10-23 04:09 WA9PIE Resolution fixed => duplicate
2019-10-23 04:09 WA9PIE Testing Not Started => Beta Successful
2019-10-23 04:09 WA9PIE Note Added: 0008930
2019-11-08 02:12 WA9PIE Fixed in Version 6.7.0.235 => 6.7.0.244
2019-11-08 02:32 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe