View Issue Details

IDProjectCategoryView StatusLast Update
00029612 - Next Dev List (Holding Area)Bugpublic2019-06-16 17:40
ReporterPD9FERAssigned ToKB3NPH 
PrioritynormalSeverityminorReproducibilityunable to reproduce
Status newResolutionfixed 
Summary0002961: Remote client no trace of HRDSerialPortClient.exe
DescriptionCustomer reports:

“Error starting ”C:\Program Files (x86)\HRD Software LLC\Ham Radio Deluxe\HRDSerialPortClient.exe” -The specified file was not found”
I have searched in all folders, but the program HRDSerialPortClient.exe is not in any folder on the PC.
My conclusion is simply that the program HRDSerialPortClient.exe is not included when you install the HRD program.

*End of comment
Steps To ReproduceStart a remote session and see if the client comes up with that error.
Additional InformationTicket #367843
No one can replicate this
The HRDSerialPortClient.exe does not exists here...
I suggested to try a install on a fresh OS.

Out of my hands.
TagsNo tags attached.
ModuleRig Control
Sub-ModuleVarious
Testing Beta Failed

Activities

K7ZCZ

2018-12-09 10:57

administrator   ~0006554

It fell out of the setup project somehow. I've added it back.

Fixed in the 6.4 branch with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4532

Fixed in the 6.5 branch with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4531

PD9FER

2018-12-10 06:57

updater   ~0006556

Informed customer, Let you know when he gets back to me.

PD9FER

2018-12-14 08:58

updater   ~0006632

I notice this file is still not existing in the latest beta 6.5.0.133

WA9PIE

2018-12-16 11:50

administrator   ~0006676

Changed status based on Ferry's feedback

PD9FER

2018-12-16 12:00

updater   ~0006677

Also no trace of HRDSerialPortClient.exe in Beta 6.5.0.137

K7ZCZ

2018-12-19 17:17

administrator   ~0006723

I think there's some confusion here. In the checkins above, I added HRDSerialPortSvr.exe to the product's setup package.

I don't think we've ever shipped a file named HRDSerialPortClient.exe. I don't see it on a VM where I have Build 794 installed, and I can't find source code for a program of that name in the project.

Exhaustively searching the 70 setup images I have available, starting at Build 647 of the 6.4 product reveals no file of that name:

F:\HRDReleases>7z l setupHRD*.exe | findstr /i "HRDSerialPortClient.exe"

F:\HRDReleases>

PD9FER

2018-12-20 05:16

updater   ~0006729

This error must come from somewhere.
We tried everything, but the error keeps popping up (even on a Fresh installed OS)

error.png (69,449 bytes)
error.png (69,449 bytes)

K7ZCZ

2018-12-20 09:41

administrator   ~0006731

What is it that the customer is doing when this message pops up? What do they want to do with the Serial Port Client program?

K7ZCZ

2018-12-20 11:07

administrator   ~0006733

I've found a way to reproduce this error:

1) Start Rig Control. Don't need to connect to a radio, but it's OK to do so.
2) Use the "Program" command in the "View" menu to assure that the "Program" toolbar is visible
3) Click on the down-arrow icon at the right edge of the "program" toolbar to get a "Add or Remove Buttons" context menu
4) Tear off the "Add or Remove Buttons" context menu to find a "Programs" tear off.
5) Tear off the "Progarms" tear off to reveal a menu with a list of configurable buttons on the toolbar.
6) In that resulting menu, mark "Serial" to assure that the "Serial" button is shown on the "Programs" menu.
7) Click the now-visible "Serial" button on the "Programs" menu.

BUG#1) This error is shown:

---------------------------
Error
---------------------------
Error starting "C:\HRD65\Debug\HRDSerialPortClient.exe" -

The specified file was not found.
---------------------------
OK   
---------------------------



We don't ship the HRDSerialPortClient.EXE program. I can't find a version of the product which includes it, in fact. I don't have the source code to build it.

If I had come across the code for this toolbar button in review, I would have simply removed it.

However, this bug is asking that the program be added to the product. The ticket makes it clear that the customer expects to use it, but doesn't give any indication of why. (And it would've really helped to have some solid repro steps.)

As a result, we have a much more difficult question to solve: What is this program meant to do, why does this customer need it? And if it's actually necessary, how do we write a replacement?

K7ZCZ

2018-12-20 15:51

administrator   ~0006738

In the 2018-12-20 triage call, Tim agreed to write a spec explaining what a replacement for this feature would do.

PD9FER

2019-03-27 11:53

updater   ~0007777

New Ticket #730453

K7ZCZ

2019-06-13 14:17

administrator   ~0008066

In the 2019-06-13 team call, we agreed this was a bug.

KB3NPH

2019-06-14 10:08

administrator   ~0008072

Last edited: 2019-06-14 10:17

View 2 revisions

In ref. to note 0006738 I apologize for not following up on it. I'll try to explain here exactly what the Serial Port remote thing did and what it needs to do. I can only go by how it worked in the past and as to how it is supposed to work.

Originally there were TWO servers involved in this "REMOTE" operation. There was the "Remote Server", which handled ONLY the Rig Control via port 7805. This port was used only for remote connection to the Rig Control functions on the HOST computer (the computer in the shack that was connected directly to the radio). A second remote "Serial Port Server" which used port 7806 was configured to be able to remotely control accessories connected on the HOST computer like Rotors, keyers, or other accessories that used a different com port on the host computer other than the one that connected directly to the radio for Rig Control. It also allowed for connection to the modern radios like many of the Icoms, which, when the drivers are installed, like for the IC-7300 which installs 2 com ports (Standard and Extended) where one of the ports is used for Rig Control and the second port can be configured to use the RTS and DTR lines for CW (via RTS) and RTTY (FSK) (via DTR).

Initially BOTH the Remote Server and the Serial Port Server were configured using "identical" TEXT files (RemoteSVR.cfg and SerialPortSVR.cfg).

Basically the .cfg files contained instructions for the Remote Server service running on the HOST computer to listen on Port 7805 for instructions that would be sent to the configured com ports on the host machine, such as a single com port (com1), or a number of comma delimited ports could be configured (com1, com2, com3) so that the host could connect to the radio that was connected to that particular com port on the HOST.

The SerialPortSVR.cfg contained exactly the same instructions as the RemoteSVR.cfg file except these instructions would be sent from the "REMOTE" computer via port 7806.

Both the RemoteSVR.cfg and the SerialPortSVR.cfg files also contained the list of authorized users, which included the username and password of each user that was authorized to connect to the HOST computer.

Several years ago. it was decided to create a new interface for the remote server and set it up as it currently is, with the information that was contained in the RemoteSVR.cfg file being stored in the HOST computer's registry instead of in the cfg file, thus eliminating the need for the .cfg file.

Unfortunately, the Remote Server was the only thing that was basically completed. The Serial Port Server has never worked since our previous programmers screwed things up with this new interface as it is now, so, the Serial Port server needs to be reconfigured so it will work. As far as that "HRDSerialPortClient.exe" program goes, it IS most definitely included in the HRD V5.0 versions where both the Remote Server and Serial Port Server worked flawlessly from a remote laptop running HRD. When it was lost from the 6.0 versions I have no idea. The only thing I can assume that it was removed from the builds sometime around the time Rick and Erik changed the Remote Server GUI in the software.

Maybe the information I have just provided is helpful, and maybe it isn't, but this is all I do know for sure. The REMOTE server, as we have it configured NOW does work when the operators set things up properly. I have assisted many operators in configuring the Remote server and it works. The SERIAL PORT Server hasn't worked since Rick and Erik added the current GUI for configuring the Remote Server.

I've added an image to this ticket showing the HRDSerialPortClient application in a VM installation from our setuphrd52438 which we released on 1/3/2015.

Dang it!!!. It didn't add the image when I loaded it into this ticket.

Issue History

Date Modified Username Field Change
2018-11-30 13:47 PD9FER New Issue
2018-12-09 10:57 K7ZCZ Assigned To => K7ZCZ
2018-12-09 10:57 K7ZCZ Status new => resolved
2018-12-09 10:57 K7ZCZ Resolution open => fixed
2018-12-09 10:57 K7ZCZ Note Added: 0006554
2018-12-09 15:40 K7ZCZ Project 1 - Backlog => 3 - Current Dev List
2018-12-09 15:42 K7ZCZ Fixed in Version => 6.5.0.132
2018-12-10 06:57 PD9FER Note Added: 0006556
2018-12-14 08:58 PD9FER Note Added: 0006632
2018-12-16 11:50 WA9PIE Status resolved => assigned
2018-12-16 11:50 WA9PIE Product Version => 6.5.0.137
2018-12-16 11:50 WA9PIE Fixed in Version 6.5.0.132 =>
2018-12-16 11:50 WA9PIE Testing Not Started => Beta Failed
2018-12-16 11:50 WA9PIE Note Added: 0006676
2018-12-16 12:00 PD9FER Note Added: 0006677
2018-12-19 17:17 K7ZCZ Note Added: 0006723
2018-12-20 05:16 PD9FER File Added: error.png
2018-12-20 05:16 PD9FER Note Added: 0006729
2018-12-20 09:41 K7ZCZ Assigned To K7ZCZ => PD9FER
2018-12-20 09:41 K7ZCZ Status assigned => feedback
2018-12-20 09:41 K7ZCZ Note Added: 0006731
2018-12-20 11:07 K7ZCZ Note Added: 0006733
2018-12-20 15:51 K7ZCZ Assigned To PD9FER => KB3NPH
2018-12-20 15:51 K7ZCZ Status feedback => new
2018-12-20 15:51 K7ZCZ Note Added: 0006738
2019-03-27 11:53 PD9FER Note Added: 0007777
2019-06-13 14:17 K7ZCZ Category General => Bug
2019-06-13 14:17 K7ZCZ Note Added: 0008066
2019-06-14 10:08 KB3NPH Note Added: 0008072
2019-06-14 10:17 KB3NPH Note Edited: 0008072 View Revisions
2019-06-16 17:40 WA9PIE Project 3 - Current Dev List => 2 - Next Dev List (Holding Area)