View Issue Details

IDProjectCategoryView StatusLast Update
0002962Ham Radio DeluxeBugpublic2019-02-15 11:07
ReporterWA9PIE 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version6.5.0.131 
Target VersionFixed in Version6.5.0.183 
Summary0002962: Column headers truncated; "Width" button/function does not resize to the column header
DescriptionThe column headers are truncated in both the Logbook pane and the DX Cluster pane. The "Width" button/function in each of these panes do not resize to the contents of the column header.
Steps To ReproduceLaunch Logbook
Connect to cluster
Observe column headers
Try the "Width" button/function for each
Column is not resized to fit contents of column header
TagsNo tags attached.
ModuleLogbook
Sub-ModuleAppearance/UI
Testing Beta Successful

Relationships

Activities

WA9PIE

2018-12-01 08:33

administrator  

TruncatedColumnHeaders.PNG (382,013 bytes)

K7ZCZ

2018-12-01 09:40

manager   ~0006504

It's not clear to me what the "Width" button/function is. I assume you're pressing the "Width" button in the tool bar -- is that correct?

For me, the "Width" button resizes the columns in the database view successfully. It seems by-design that the "Width" button does not resize the columns in the DX Cluster window, since the Width button is in the toolbar of the database tab and not the DX Cluster pane.

Are you able to resize the columns by dragging the column header border with the mouse?

WA9PIE

2018-12-01 10:14

administrator   ~0006505

Yes. Pressing the "Width" button in the toolbar for the Logbook tab (er, database tab).

The columns in the DX cluster pane had previously expanded automatically to fit the column header.

Are you able to resize the columns by dragging the column header border with the mouse?
- In the Logbook (database) tab, yes. And the widths are retained when restarting the program
- In the DX cluster tab, no. When the next spot comes along, it resizes the columns and the headers are again truncated.

K7ZCZ

2018-12-01 10:21

manager   ~0006506

Thanks. Nothing has explicitly changed in this area of our code. The autosizing implementation asks the header control to size itself using the text in the header. Our code initiates the sizing, but it's the Windows control that does the width computation and sizing action itself.

K7ZCZ

2018-12-01 15:44

manager   ~0006512

Are you using a high-DPI display?

WA9PIE

2018-12-17 03:08

administrator   ~0006682

My first test was on a Dell Inspiron 15. It's 1900 x 1080 (if that helps). That said... I just got this laptop.

So I went back to my trusty Microsoft Surface Pro 3 that I've been using as my main laptop for about five years. After installing the 157 build, I get the exact same behavior.

I've never seen this before. I suspect I could take it back to 907 to see if the problem goes away.

I wouldn't be comfortable releasing with this... if there's a possibility that others will experience this.

K7ZCZ

2018-12-17 03:31

manager   ~0006683

It doesn't repro for me, so I need to know more about the machines where it does repro. And promptly, if you want to consider it a ship-stopper.

g3ucq

2018-12-17 06:14

viewer   ~0006687

My display is 1920x1080 and Width works for me.
However, is it possible to revisit 0002204 again please?

K7ZCZ

2018-12-17 07:53

manager   ~0006689

The resooution of the display doesn't tell me if the display is shown to Windows as a high DPI device or not.

WA9PIE

2018-12-17 12:27

administrator   ~0006697

I uninstalled the 6.5.0.157 beta build and then installed the 6.4.0.907 build. The columns in 907 resized as expected.

I'll try to find more out about the DPI of these computers (both computers I've tried 6.5.x on thus far has had this problem).

K7ZCZ

2018-12-21 10:21

manager   ~0006778

Still looking for information about the configuration of the machines where this problem repros.

It would be useful to re-test against 161, since that includes the CJ changes we were hoping might help.

In the development team call on 2018-12-18, we identified a workaround that seems to help. Can that workaround be documented? Is it adequate as a fix, or are we looking for something more invasive in the code?

g3ucq

2018-12-21 10:52

viewer   ~0006781

My monitor dpi is 92 dpi. HTH

K7ZCZ

2019-01-09 11:03

manager   ~0006909

I've been able to reproduce and debug this probelem on a high-DPI display machine. It is an issue with the CodeJock libraries. I've opened a support ticket with them; here is the mail I sent.

-- SNIP -- SNIP -- SNIP -- SNIP --

I am experiencing a bug in the CodeJock libraries. I'm using ToolKit Pro 18.6 and Visual C++ 2017.

I've attached a minimal application that demonstrates the issue I'm seeing. It's a Dialog-based MFC application that contains just a List Control, implemented with CXTPListCtrl.

The program uses the list control in "report view" mode. It adds three columns, then calls AutoSizecolumn() to have the columns resize to an appropriate width.

This program works fine on regular displays. On high-DPI displays, the column sizing is too narrow and truncates the columns. Thye show an elipsis in the header. A column with the heading "much longer (to test)", for example, becomes "much longer (to te...".

The column size is only a few pixels too short. To me, it looks like problem is in the AutoSizeColumn() implementation, which adds 12 or 36 pixels to the width of the column after measuring it. These values are too small for high-DPI displays, and should be scaled with the LOGPIXELS value returned from GetSystemMetrics().

(But, maybe my analysis isn't correct.)

I hope this issue can be fixed soon, as it gives my customers a poor user experience.

Thank you for your help. Please let me know if you have any questions!

-- SNIP -- SNIP -- SNIP -- SNIP --

BadColumnsDemo.7z (60,840 bytes)

K7ZCZ

2019-01-09 12:38

manager   ~0006910

I've worked around the CodeJock bug with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4681

That leaves the complaint that "the width button/function does not resize to the column header". The "Width" button actually does work fine, it's just that it is designed to set the widths for the database record list view, not the DX Cluster window. This is cued by the fact that the "Width" button is in a toolbar attached to the record list view, in a different pane than the DX Cluster window. Controls for one pane shouldn't be expected to affect a different view.

We'll need to monitor CodeJock's response to this issue to see if a future release offers a more permanent fix.

K7ZCZ

2019-01-10 09:12

manager   ~0006940

CodeJock has opened this issue for me.
http://support.codejock.com/Issue_View.asp?IssueNbr=37140

K7ZCZ

2019-01-10 15:40

manager   ~0006947

In the triage call on 2019-01-10, we agreed that we wouldn't change the behaviour of auto-sizing column widths on each incoming spot.

WA9PIE

2019-01-10 21:58

administrator   ~0006952

The column widths for the logbook view still have truncated column headers in the 171 build.

g3ucq

2019-01-11 07:44

viewer   ~0006953

I requested Word Wrap for column headers in 0002105.
Would that help here?

WA9PIE

2019-01-11 09:19

administrator   ~0006955

I think it's a bit different, John. Even if they wrapped, the column headers for the logbook pane will still be truncated - if I understand all this correctly.

WA9PIE

2019-01-11 09:21

administrator   ~0006956

I'm failing this one. I'm getting the same result as I have in the image I posted previously. The column headers in the logbook view are truncated and you can't resize them with the Width button.

g3ucq

2019-01-11 10:18

viewer   ~0006960

Mike C. My reason for suggesting Word Wrap would mean that the column header would not have to be so wide and take up so much room on the header.
Or have a User means of renaming the column header.

K7ZCZ

2019-01-11 10:29

manager   ~0006961

When I run previous builds on a high-DPI machine, the columns headers are truncated. After the fix I made, the column headers are not truncated.

If you're getting different results, then there must be some other problem, which we can't fix and I'll need more information from you to diagnose the issue. At this point, I don't know what other fix I could make.

WA9PIE

2019-01-11 11:03

administrator   ~0006962

Here's what I've got with the 171 build (attached image).

K7ZCZ

2019-01-11 17:15

manager   ~0006969

This issue was discussed in chat today and I want to capture that discssion to maintain the documentation in this issue.

First, there are at last three separate notes here:

1) Logbook database view column titles are truncated
2) DX Cluster pane column titles are truncated
3) The "Width" button in the Logbook database view doesn't resize the to contents of the column header
4) The "Width" button in the DX Cluster Pane doesn't resize the to contents of the column header

Let's try to take them one by one:

1) These are truncated, but can be resized by the user. The saved size is still working.
2) DX Cluster pane column titles are truncated. We don't have infomration on the machines where this is happening, but it seems like the issue unique to high DPI machines. I've coded a workaround for this whic happeared in build 171. The screenshot in comment #6962 shows that fix is working.
3) The width button in the logbook database view does resize the columns. It's just that it picks the same too-narrow width that automatic sizing does. And that appears to only be a problem on high DPI displays, too.
4) The DX Cluster Pane doesn't have a "Width" button. The Width button in the logbook database view isn't expected to affect anything but the Logbook database view. So, there's nothing to do here.

So then, at this moment:

1) I can fix this by applying the same fix as was done for #2. There's a ton of copy-paste and reimplementation in the product, so one fix isn't precisely compatible with the other implemnetation, so two fixes are necessary.
2) This is fixed, as the #6962 capture shows.
3) This would be fixed with #1.
4) There's nothing to fix here.

K7ZCZ

2019-01-12 17:19

manager   ~0006981

#1 as enumerated in my previous post is fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4713

Note that the feature which saves column widths saves widths -- it doesn't annotate the user's preference to auto-size the column. As such, users will hvae to hit the "Width" button or set the column width to their preference if they don't like the way the column is sized.

WA9PIE

2019-01-13 14:30

administrator   ~0006987

Validated

K7ZCZ

2019-02-15 11:07

manager   ~0007402

I'm having problems iwth the CodeJock ticketing system. I recieved no notifications from them, then the closed the ticket. Only then I noticed a comment that they couldn't download the sample project I had created. I've opened this new ticket:

https://support.codejock.com/Issue_View.asp?IssueNbr=37227

Issue History

Date Modified Username Field Change
2018-12-01 08:33 WA9PIE New Issue
2018-12-01 08:33 WA9PIE Status new => assigned
2018-12-01 08:33 WA9PIE Assigned To => K7ZCZ
2018-12-01 08:33 WA9PIE File Added: TruncatedColumnHeaders.PNG
2018-12-01 09:40 K7ZCZ Status assigned => feedback
2018-12-01 09:40 K7ZCZ Note Added: 0006504
2018-12-01 10:14 WA9PIE Note Added: 0006505
2018-12-01 10:14 WA9PIE Status feedback => assigned
2018-12-01 10:21 K7ZCZ Note Added: 0006506
2018-12-01 15:44 K7ZCZ Note Added: 0006512
2018-12-02 18:32 K7ZCZ Assigned To K7ZCZ => WA9PIE
2018-12-17 03:08 WA9PIE Assigned To WA9PIE => K7ZCZ
2018-12-17 03:08 WA9PIE Steps to Reproduce Updated View Revisions
2018-12-17 03:08 WA9PIE Note Added: 0006682
2018-12-17 03:31 K7ZCZ Status assigned => feedback
2018-12-17 03:31 K7ZCZ Note Added: 0006683
2018-12-17 06:14 g3ucq Note Added: 0006687
2018-12-17 07:53 K7ZCZ Note Added: 0006689
2018-12-17 12:27 WA9PIE Note Added: 0006697
2018-12-17 12:27 WA9PIE Status feedback => assigned
2018-12-21 10:21 K7ZCZ Assigned To K7ZCZ => WA9PIE
2018-12-21 10:21 K7ZCZ Note Added: 0006778
2018-12-21 10:52 g3ucq Note Added: 0006781
2019-01-09 11:03 K7ZCZ File Added: BadColumnsDemo.7z
2019-01-09 11:03 K7ZCZ Note Added: 0006909
2019-01-09 12:38 K7ZCZ Status assigned => resolved
2019-01-09 12:38 K7ZCZ Resolution open => fixed
2019-01-09 12:38 K7ZCZ Note Added: 0006910
2019-01-10 09:12 K7ZCZ Note Added: 0006940
2019-01-10 15:40 K7ZCZ Note Added: 0006947
2019-01-10 21:54 WA9PIE Fixed in Version => 6.5.0.171
2019-01-10 21:58 WA9PIE Note Added: 0006952
2019-01-11 07:44 g3ucq Note Added: 0006953
2019-01-11 09:19 WA9PIE Note Added: 0006955
2019-01-11 09:21 WA9PIE Status resolved => feedback
2019-01-11 09:21 WA9PIE Resolution fixed => reopened
2019-01-11 09:21 WA9PIE Testing Not Started => Beta Failed
2019-01-11 09:21 WA9PIE Note Added: 0006956
2019-01-11 10:18 g3ucq Note Added: 0006960
2019-01-11 10:29 K7ZCZ Note Added: 0006961
2019-01-11 11:03 WA9PIE File Added: ColumnHeadersTruncated.PNG
2019-01-11 11:03 WA9PIE Note Added: 0006962
2019-01-11 11:04 WA9PIE Assigned To WA9PIE => K7ZCZ
2019-01-11 11:48 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-01-11 12:03 WA9PIE Assigned To WA9PIE => K7ZCZ
2019-01-11 17:15 K7ZCZ Note Added: 0006969
2019-01-12 17:19 K7ZCZ Status feedback => resolved
2019-01-12 17:19 K7ZCZ Resolution reopened => fixed
2019-01-12 17:19 K7ZCZ Note Added: 0006981
2019-01-13 14:30 WA9PIE Status resolved => closed
2019-01-13 14:30 WA9PIE Fixed in Version 6.5.0.171 => 6.5.0.180
2019-01-13 14:30 WA9PIE Testing Beta Failed => Beta Successful
2019-01-13 14:30 WA9PIE Note Added: 0006987
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.180 => 6.5.0.183
2019-01-16 22:05 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2019-02-15 11:07 K7ZCZ Note Added: 0007402