View Issue Details

IDProjectCategoryView StatusLast Update
0002971Ham Radio DeluxeBugpublic2019-01-16 22:04
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformIntel i7-5960XOSWindows 10 Professional x64OS Version16299
Product Version6.5.0.131 
Target VersionFixed in Version6.5.0.183 
Summary0002971: Rig Control: Layout Size isn't checked in context menu
DescriptionThere are four choices for the size of the Rig Control layout: Small, Medium, Large, X Large. These are shown in a tear-off from a context menu in the Rig Control radio view.

Since there are a finite number of choices and a selected state, the the menu should reflect that state with a checkmark at the selected item.
Steps To Reproduce1) Fire up Rig Control. OK to connect to a DemoMatic radio
2) Right-click on a blank area of the radio view.
3) In the resulting context menu, click on the "Layout Size" tear-off

BUG#1) There is no check mark on any of the size choices

4) Select "Small" in the tear-off menu. The Rig Control window will repaint.
5) Right-click for the context menu again; access the "Layout size" tear-off

BUG#2) "Small" should have a check mark. It doesn't.
TagsNo tags attached.
ModuleRig Control
Sub-ModuleAppearance/UI
Testing Beta Successful

Relationships

Activities

K7ZCZ

2018-12-06 23:02

manager   ~0006544

Turns out the CodeJock toolbars get involved with handling COMMAND_UPDATE on a popup menu.
Fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4517

g3ucq

2018-12-21 09:43

viewer   ~0006776

Confirm the fix.

WA9PIE

2018-12-22 00:22

administrator   ~0006794

I also validated this one.

Issue History

Date Modified Username Field Change
2018-12-06 16:59 K7ZCZ New Issue
2018-12-06 23:02 K7ZCZ Assigned To => K7ZCZ
2018-12-06 23:02 K7ZCZ Status new => resolved
2018-12-06 23:02 K7ZCZ Resolution open => fixed
2018-12-06 23:02 K7ZCZ Note Added: 0006544
2018-12-09 15:42 K7ZCZ Fixed in Version => 6.5.0.132
2018-12-21 09:43 g3ucq Note Added: 0006776
2018-12-22 00:22 WA9PIE Status resolved => closed
2018-12-22 00:22 WA9PIE Description Updated View Revisions
2018-12-22 00:22 WA9PIE Steps to Reproduce Updated View Revisions
2018-12-22 00:22 WA9PIE Testing Not Started => Beta Successful
2018-12-22 00:22 WA9PIE Note Added: 0006794
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.132 => 6.5.0.183
2019-01-16 22:04 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe