View Issue Details

IDProjectCategoryView StatusLast Update
0002974Ham Radio DeluxeBugpublic2019-01-16 22:04
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.5.0.183 
Summary0002974: Logbook: empty dates will not always sort correctly
DescriptionSorting data with conditional dates (like the "QSL Sent") can result in empty dates not sorting correctly relative to other dates in the list.

I don't provide a repro as this issue is apparent in code review.
TagsNo tags attached.
ModuleLogbook
Sub-ModuleData
Testing Beta Successful

Relationships

Activities

K7ZCZ

2018-12-10 09:38

manager   ~0006562

Fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4534

WA9PIE

2018-12-11 01:13

administrator   ~0006572

I edited this because Product Version was updated instead of FIV.

WA9PIE

2018-12-21 23:42

administrator   ~0006787

I validated this using LOTW Rcvd date.

Issue History

Date Modified Username Field Change
2018-12-10 09:32 K7ZCZ New Issue
2018-12-10 09:38 K7ZCZ Assigned To => K7ZCZ
2018-12-10 09:38 K7ZCZ Status new => resolved
2018-12-10 09:38 K7ZCZ Resolution open => fixed
2018-12-10 09:38 K7ZCZ Note Added: 0006562
2018-12-11 01:13 WA9PIE Product Version 6.5.0.132 =>
2018-12-11 01:13 WA9PIE Fixed in Version => 6.5.0.132
2018-12-11 01:13 WA9PIE Description Updated View Revisions
2018-12-11 01:13 WA9PIE Note Added: 0006572
2018-12-21 23:42 WA9PIE Note Added: 0006787
2018-12-21 23:42 WA9PIE Status resolved => closed
2018-12-22 00:11 WA9PIE Testing Not Started => Beta Successful
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.132 => 6.5.0.183
2019-01-16 22:04 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe