View Issue Details

IDProjectCategoryView StatusLast Update
0002986Ham Radio DeluxeBugpublic2019-01-16 22:05
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformIntel i7-5960XOSWindows 10 Professional x64OS Version16299
Product Version6.4.0.907 
Target VersionFixed in Version6.5.0.183 
Summary0002986: Rig Control: APF and Contour on/off buttons don't work for FT-991
DescriptionThe "Contour" button in rig control doesn't turn on/off the Contour feature in the radio. The button in Rig Control doesn't reflect the state of the feature in the radio.

"APF" feature can't be controlled by Rig Control because the on/off button doesn't exist in rig control. (This is a special case of "doesn't work".)

Steps To Reproduce1) Fire up Rig Control
2) Connect to a FT-991 radio
3) Use the "F/M-List" button on the radio to switch to the menu
4) Us the "FWD" or "BACK" buttons on the radio to move to the menu page with the "CONT" setting
5) Use the "CONT" button on Rig Control

BUG#1) The radio doesn't turn the contour filter on or off.
BUG#2) Rig Control doesn't reflect the on/off state for the contour filter that the radio has.

TagsFT-991, FT-991A, Yaesu
ModuleRig Control
Sub-ModuleRadio Support
Testing Beta Successful

Relationships

has duplicate 0002627 closedK7ZCZ Miscellaneous fixes for FT-991 Rig Control 

Activities

K7ZCZ

2018-12-13 11:25

manager   ~0006607

fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4555

WA9PIE

2019-01-02 12:45

administrator   ~0006865

APF Slider : Set it and it reverts back to zero

K7ZCZ

2019-01-02 12:55

manager   ~0006866

I can confirm that the APF slider works when the radio is set to "CW-LSB" or "CW-USB". The APF slider resets to -250 hertz when the radio is in "LSB", "USB", "AM", "FM", "RTTY-LSB", "RTTY-USB", "C4FM", "DATA-LSB", "DATA-USB", or "DATA-FM" modes.

This matches the design of the radio. According to page 56 of the FT991A product manual, the APF filter is only available when the radio is in a CW mode. I also can't find an enabled APF frequency setting on the radio's UI when not in a CW mode.

Are you seeing something different? If so, please let me know which mode your radio is set to when setting the APF slider in Rig Control.

WA9PIE

2019-01-05 18:54

administrator   ~0006887

The following feedback comes from Dan Schaaf (K3ZXL) who tested this for me:

----------

In the slider list, there should be an item “111 APF WIDTH” according to Page 60 in the FT-991A manual. This slider item is not available.
However, there is a slider item labeled APF with a variable width available.
But I am not convinced that it functions for the 991 and 991A.
 
So, in my opinion, the 111 APF WIDTH should be added to the slider selection drop down.
 
The APF ON/OFF Button does work now.

K7ZCZ

2019-01-06 13:02

manager   ~0006891

Looks like the problem is that there should be three controls. One pushbutton to enable or disable the filter; one to set the width, and one to set the center frequency.

That slider is added with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4668

WA9PIE

2019-01-09 15:02

administrator   ~0006926

Validated most recent changes with the 168 build. All three functions look good.

Issue History

Date Modified Username Field Change
2018-12-13 11:18 K7ZCZ New Issue
2018-12-13 11:18 K7ZCZ Tag Attached: FT-991A
2018-12-13 11:18 K7ZCZ Tag Attached: Yaesu
2018-12-13 11:18 K7ZCZ Tag Attached: FT-991
2018-12-13 11:18 K7ZCZ Assigned To => K7ZCZ
2018-12-13 11:18 K7ZCZ Status new => assigned
2018-12-13 11:25 K7ZCZ Status assigned => resolved
2018-12-13 11:25 K7ZCZ Resolution open => fixed
2018-12-13 11:25 K7ZCZ Note Added: 0006607
2018-12-13 13:59 K7ZCZ Relationship added related to 0002627
2018-12-13 13:59 K7ZCZ Relationship deleted related to 0002627
2018-12-13 13:59 K7ZCZ Relationship added has duplicate 0002627
2018-12-13 14:04 K7ZCZ Relationship added related to 0002760
2018-12-13 14:05 K7ZCZ Relationship deleted related to 0002760
2018-12-14 17:19 K7ZCZ Fixed in Version => 6.5.0.137
2019-01-01 21:20 WA9PIE Status resolved => closed
2019-01-01 21:20 WA9PIE Testing Not Started => Beta Successful
2019-01-02 12:27 WA9PIE Status closed => resolved
2019-01-02 12:27 WA9PIE Testing Beta Successful => Beta Failed
2019-01-02 12:39 WA9PIE Status resolved => closed
2019-01-02 12:39 WA9PIE Testing Beta Failed => Beta Successful
2019-01-02 12:45 WA9PIE Status closed => resolved
2019-01-02 12:45 WA9PIE Testing Beta Successful => Beta Failed
2019-01-02 12:45 WA9PIE Note Added: 0006865
2019-01-02 12:55 K7ZCZ Note Added: 0006866
2019-01-02 12:56 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-01-05 18:54 WA9PIE Note Added: 0006887
2019-01-05 18:55 WA9PIE Assigned To WA9PIE => K7ZCZ
2019-01-05 18:55 WA9PIE Status resolved => feedback
2019-01-05 18:55 WA9PIE Resolution fixed => reopened
2019-01-06 13:02 K7ZCZ Status feedback => resolved
2019-01-06 13:02 K7ZCZ Resolution reopened => fixed
2019-01-06 13:02 K7ZCZ Note Added: 0006891
2019-01-09 15:02 WA9PIE Status resolved => closed
2019-01-09 15:02 WA9PIE Testing Beta Failed => Beta Successful
2019-01-09 15:02 WA9PIE Note Added: 0006926
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.137 => 6.5.0.183
2019-01-16 22:05 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe