View Issue Details

IDProjectCategoryView StatusLast Update
0002991Ham Radio DeluxeBugpublic2019-01-16 22:05
ReporterK7ZCZ 
Assigned ToWA9PIE 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformIntel i7-5960XOSWindows 10 Professional x64OS Version16299
Product Version6.5.0.132 
Target VersionFixed in Version6.5.0.183 
Summary0002991: Rig Control: FT-991 and FT-991A have unsupported "VFO Dimmer" slider
DescriptionThe radio doesn't support dimming of the VFO -- there's no VFO display, just the TFT. The "VFO dimmer" slider should be removed.


Steps To Reproduce1) Start Rig Control
2) Connect to an FT-991 or FT-991A
3) Make sure you've got the "VFO dimmer" slider configured
4) Exercise the "VFO dimmer" slider

BUG#1) Nothing happens to the radio. The slider snaps back to its original position.
TagsFT-991, FT-991A, Yaesu
ModuleRig Control
Sub-ModuleRadio Support
Testing Beta Successful

Relationships

Activities

K7ZCZ

2018-12-14 11:45

manager   ~0006639

fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4560

WA9PIE

2019-01-01 21:42

administrator   ~0006838

I can't find any "VFO Dimmer" slider to enable. Do you know where I can find it?

K7ZCZ

2019-01-02 10:42

manager   ~0006858

That's the point! The radio has a TFT display, and a keypad. It doesn't have an independent VFO display.

Previous to this fix, Rig Control still offered a slider to dim the VFO display. How could such a slider possibly work when there's no VFO display to be dimmed?

Because the radio doesn't support dimming the VFO display, the slider that claimed to dim the VFO display was removed from the product. If you can't find it, then I would say that the change was successful.

WA9PIE

2019-01-09 15:05

administrator   ~0006928

With that explanation, I consider this validated.

Issue History

Date Modified Username Field Change
2018-12-14 11:24 K7ZCZ New Issue
2018-12-14 11:30 K7ZCZ Tag Attached: Yaesu
2018-12-14 11:30 K7ZCZ Tag Attached: FT-991A
2018-12-14 11:31 K7ZCZ Tag Attached: FT-991
2018-12-14 11:45 K7ZCZ Assigned To => K7ZCZ
2018-12-14 11:45 K7ZCZ Status new => resolved
2018-12-14 11:45 K7ZCZ Resolution open => fixed
2018-12-14 11:45 K7ZCZ Note Added: 0006639
2018-12-14 17:19 K7ZCZ Fixed in Version => 6.5.0.137
2019-01-01 21:42 WA9PIE Status resolved => feedback
2019-01-01 21:42 WA9PIE Resolution fixed => reopened
2019-01-01 21:42 WA9PIE Note Added: 0006838
2019-01-02 10:42 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-01-02 10:42 K7ZCZ Status feedback => assigned
2019-01-02 10:42 K7ZCZ Resolution reopened => fixed
2019-01-02 10:42 K7ZCZ Note Added: 0006858
2019-01-09 15:05 WA9PIE Status assigned => closed
2019-01-09 15:05 WA9PIE Testing Not Started => Beta Successful
2019-01-09 15:05 WA9PIE Note Added: 0006928
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.137 => 6.5.0.183
2019-01-16 22:05 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe