View Issue Details

IDProjectCategoryView StatusLast Update
0002999Ham Radio DeluxeBugpublic2019-01-16 22:05
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformIntel i7-5960XOSWindows 10 Professional x64OS Version16299
Product Version6.5.0.137 
Target VersionFixed in Version6.5.0.183 
Summary0002999: Rig Control: can't set FT-991 to C4FM mode
DescriptionRig Control fails to set the FT-991 radio to C4FM mode, and fails to read that mode setting from the radio.
Steps To Reproduce1) Fire up Rig Control
2) Connect to the FT-991
3) Use the mode drop-down to set the radio to C4FM

BUG#1) The radio sets to C4FM, but the drop-down is blank. If the mode status is enabled in the frequency display, it goes blank, too.

4) Use the front panel of the radio to set the mode to USB. This works fine, the mode settings reappear in Rig Control.
5) Use the front panel of the radio to set the mode to C4FM.

BUG#2) The radio sets to C4FM, of course, but the drop-down and mode status in Rig Control go blank again.



TagsFT-991
ModuleRig Control
Sub-ModuleRadio Support
Testing Beta Successful

Relationships

Activities

K7ZCZ

2018-12-18 15:28

manager   ~0006704

The KenwoodSend() function is called for all Kenwood-protocol radios ... modern Kenwood radios, plus the modern Yaesu radios which use ASCII strings for commands.

This function was looking for error strings in responses, but doing a terrible job of it. It seems only a few Kenwood radios actually send errors in that way, but all radios were trapping errors. The error check was flawed because it looks for "E;" at the end of a response, which might come naturally as part of the data. When the mode on an FT-991 is set to C4FM, for example, the mode command is "MD" and the response is "MD0E;". That's not an error ... it's just Mode #E.

I've removed most of the bogus tests; some remain because they do seem properly implemented. More refinement might be necessary, though.

K7ZCZ

2018-12-19 08:29

manager   ~0006710

fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4623

WA9PIE

2019-01-01 22:47

administrator   ~0006849

Validated

Issue History

Date Modified Username Field Change
2018-12-17 14:36 K7ZCZ New Issue
2018-12-18 15:28 K7ZCZ Note Added: 0006704
2018-12-19 08:29 K7ZCZ Assigned To => K7ZCZ
2018-12-19 08:29 K7ZCZ Status new => resolved
2018-12-19 08:29 K7ZCZ Resolution open => fixed
2018-12-19 08:29 K7ZCZ Note Added: 0006710
2018-12-21 01:16 WA9PIE Tag Attached: FT-991
2018-12-27 16:36 WA9PIE Fixed in Version => 6.5.0.161
2018-12-27 16:36 WA9PIE Description Updated View Revisions
2018-12-27 16:36 WA9PIE Steps to Reproduce Updated View Revisions
2019-01-01 22:47 WA9PIE Status resolved => closed
2019-01-01 22:47 WA9PIE Testing Not Started => Beta Successful
2019-01-01 22:47 WA9PIE Note Added: 0006849
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.161 => 6.5.0.183
2019-01-16 22:05 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe