View Issue Details

IDProjectCategoryView StatusLast Update
0003002Ham Radio DeluxeBugpublic2019-01-16 22:04
ReporterK7ZCZ 
Assigned ToK7ZCZ 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformIntel i7-5960XOSWindows 10 Professional x64OS Version16299
Product Version 
Target VersionFixed in Version6.5.0.183 
Summary0003002: Logbook: throws assertion for missing string resource at startup
DescriptionAfter upgrading to CodeJock's 18.6 release of ToolkitPro, the Logbook application won't start.

In debug builds it throws an assertion:

---------------------------
Microsoft Visual C++ Runtime Library
---------------------------
Debug Assertion Failed!

Program: C:\HRD65\Debug\HRDLogbook.exe
File: d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\docmulti.cpp
Line: 187

For information on how your program can cause an assertion
failure, see the Visual C++ documentation on asserts.

(Press Retry to debug the application)

---------------------------
Abort   Retry   Ignore   
---------------------------


and the release build crashes.

Additional Information
Debug call stack to assertion:
>	HRDLogbook.exe!CMultiDocTemplate::SetDefaultTitle(CDocument * pDocument) Line 187	C++
     HRDLogbook.exe!CMultiDocTemplate::OpenDocumentFile(const wchar_t * lpszPathName, int bAddToMRU, int bMakeVisible) Line 138	C++
     HRDLogbook.exe!CMultiDocTemplate::OpenDocumentFile(const wchar_t * lpszPathName, int bMakeVisible) Line 109	C++
     HRDLogbook.exe!CMainFrame::RestoreLayout() Line 3690	C++
     HRDLogbook.exe!CHRDLogbookApp::InitInstance() Line 986	C++
     HRDLogbook.exe!AfxWinMain(HINSTANCE__ * hInstance, HINSTANCE__ * hPrevInstance, wchar_t * lpCmdLine, int nCmdShow) Line 37	C++
     HRDLogbook.exe!wWinMain(HINSTANCE__ * hInstance, HINSTANCE__ * hPrevInstance, wchar_t * lpCmdLine, int nCmdShow) Line 26	C++
     HRDLogbook.exe!invoke_main() Line 123	C++
     HRDLogbook.exe!__scrt_common_main_seh() Line 288	C++
     HRDLogbook.exe!__scrt_common_main() Line 331	C++
     HRDLogbook.exe!wWinMainCRTStartup() Line 17	C++
     kernel32.dll!@BaseThreadInitThunk@12()	Unknown
     ntdll.dll!__RtlUserThreadStart()	Unknown
     ntdll.dll!__RtlUserThreadStart@8()	Unknown
TagsNo tags attached.
ModuleLogbook
Sub-Module(select)
TestingNot Started

Relationships

has duplicate 0003009 closedK7ZCZ 4 - Closed w/o Action Build 160 DM-780 crashes upon opening with Minidump 

Activities

K7ZCZ

2018-12-18 18:19

manager   ~0006705

Looks like this post in the CodeJock forums identifies the problem and offers a workaround in this post:
http://forum.codejock.com/forum_posts.asp?TID=23752

I have made this post in the forum myself:
http://forum.codejock.com/forum_posts.asp?TID=23787&title=staticallylinked-mfc-has-trouble-loading-string-r


I verified that the problem was due to the 18.3 upgrade. Before upgrading, we have no problem. After upgrading, there's trouble. After upgrading, if I re-wire the resource file for the Logbook to use the CodeJock 18.3 sources, the Logbook application works correctly. In debugging,

I'll try to open a support ticket with CodeJock today.

K7ZCZ

2018-12-19 16:46

manager   ~0006719

This is a bug in CodeJock's 18.6 release. We want to keep that release for the H-DPI improvements, so I've patched the libraries, rebuilt them, and checked them back into our project.

When CodeJock next updates, we can overwrite my patch ... if it's no longer needed.

Fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4625

Issue History

Date Modified Username Field Change
2018-12-18 18:17 K7ZCZ New Issue
2018-12-18 18:19 K7ZCZ Note Added: 0006705
2018-12-19 16:46 K7ZCZ Assigned To => K7ZCZ
2018-12-19 16:46 K7ZCZ Status new => resolved
2018-12-19 16:46 K7ZCZ Resolution open => fixed
2018-12-19 16:46 K7ZCZ Note Added: 0006719
2018-12-20 21:11 K7ZCZ Relationship added has duplicate 0003009
2018-12-27 16:35 WA9PIE Status resolved => closed
2018-12-27 16:35 WA9PIE Fixed in Version => 6.5.0.161
2018-12-27 16:35 WA9PIE Description Updated View Revisions
2018-12-27 16:35 WA9PIE Additional Information Updated View Revisions
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.161 => 6.5.0.183
2019-01-16 22:04 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe