View Issue Details

IDProjectCategoryView StatusLast Update
0003010Ham Radio DeluxeBugpublic2019-01-16 22:04
Reporterg3ypp 
Assigned ToK7ZCZ 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformLaptopOSWindowsOS VersionWindows 10 1803
Product Version 
Target VersionFixed in Version6.5.0.183 
Summary0003010: New installation: logbook crashes and produces minidump
DescriptionI installed .157 on a laptop which had not previously had HRD installed on it.

The install process required C++ redistributable 2017 to be installed, which it did and the computer rebooted.
HRD install did not restart on its own.
I re-ran HRD install and it completed ok. Rig control ran properly.
On starting logbook, the program crashed immediately and a minidumb was produced.
Every attempt to start logbook resulted in a minidump file.

I then installed .161 to see if this would resolve the problem. It did not. Rig control and DM780 operate correctly but logbook crashes at start up and a minidump is created.


Steps To ReproduceOpen logbook
logbook fails to open and minidump produced
TagsNo tags attached.
ModuleLogbook
Sub-ModuleInstall
TestingNot Started

Relationships

Activities

g3ypp

2018-12-22 09:46

viewer  

HRDLogbook_20181221_162625.mdmp (275,118 bytes)
HRDLogbook_20181221_162817.mdmp (252,991 bytes)
HRDLogbook_20181221_174814.mdmp (241,886 bytes)
HRDLogbook_20181221_162649.mdmp (266,559 bytes)

K7ZCZ

2018-12-22 18:46

manager   ~0006797

All of the dumps here are the same call stack. They're against the 161 build of the product.

0:000> .ecxr
eax=fffffff0 ebx=00c1f6e4 ecx=00c1f738 edx=00630074 esi=fffffff0 edi=00c1f788
eip=00dd0ff8 esp=00c1f670 ebp=00c1f678 iopl=0         nv up ei ng nz na pe cy
cs=0023  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00010287
HRDLogbook!ATL::CSimpleStringT<wchar_t,0>::CloneData+0x8:
00dd0ff8 8b0e            mov     ecx,dword ptr [esi]  ds:002b:fffffff0=????????
0:000> kb
  *** Stack trace for last set context - .thread/.cxr resets it
 # ChildEBP RetAddr  Args to Child              
00 00c1f678 01048ec8 fffffff0 b3b38970 061443f8 HRDLogbook!ATL::CSimpleStringT<wchar_t,0>::CloneData+0x8 [c:\program files (x86)\microsoft visual studio\2017\community\vc\tools\msvc\14.16.27023\atlmfc\include\atlsimpstr.h @ 882] 
01 (Inline) -------- -------- -------- -------- HRDLogbook!ATL::CSimpleStringT<wchar_t,0>::{ctor}+0xb [c:\program files (x86)\microsoft visual studio\2017\community\vc\tools\msvc\14.16.27023\atlmfc\include\atlsimpstr.h @ 213] 
02 (Inline) -------- -------- -------- -------- HRDLogbook!ATL::CStringT<wchar_t,StrTraitMFC<wchar_t,ATL::ChTraitsCRT<wchar_t> > >::{ctor}+0xb [c:\program files (x86)\microsoft visual studio\2017\community\vc\tools\msvc\14.16.27023\atlmfc\include\cstringt.h @ 1027] 
03 00c1f6e4 00f19cc7 061443f8 00c1f788 05ce82fc HRDLogbook!CXMLMgr::AddAttribute+0x58 [c:\hrd65\hrdcommon\xmlmgr.cpp @ 1872] 
04 00c1f7f0 00f1808b b3b3877c ffffffff 018418b0 HRDLogbook!CLogbookAnalysisDefns::Save+0xb57 [c:\hrd65\logbook\hrdlogbook\logbookanalysisdefns.cpp @ 644] 
05 00c1f8d4 00eca788 b3b38218 018418b0 00ec9aa0 HRDLogbook!CLogbookAnalysisDefns::LoadDefaults+0x58b [c:\hrd65\logbook\hrdlogbook\logbookanalysisdefns.cpp @ 506] 
06 00c1fdb0 0157b43f 00000000 01a5b91c 00010100 HRDLogbook!CHRDLogbookApp::InitInstance+0xce8 [c:\hrd65\logbook\hrdlogbook\hrdlogbook.cpp @ 722] 
07 00c1fdc8 011b65b1 00dc0000 00000000 000d20f8 HRDLogbook!AfxWinMain+0x5f [d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmfc\src\mfc\winmain.cpp @ 37] 
08 (Inline) -------- -------- -------- -------- HRDLogbook!invoke_main+0x1a [d:\agent\_work\2\s\src\vctools\crt\vcstartup\src\startup\exe_common.inl @ 118] 
09 00c1fe14 74b08484 028cb000 74b08460 dcf71841 HRDLogbook!__scrt_common_main_seh+0xf8 [d:\agent\_work\2\s\src\vctools\crt\vcstartup\src\startup\exe_common.inl @ 288] 
0a 00c1fe28 773e3ab8 028cb000 d3fde2ea 00000000 kernel32!BaseThreadInitThunk+0x24
0b 00c1fe70 773e3a88 ffffffff 773ff301 00000000 ntdll!__RtlUserThreadStart+0x2f
0c 00c1fe80 00000000 011b6635 028cb000 00000000 ntdll!_RtlUserThreadStart+0x1b

K7ZCZ

2018-12-22 18:46

manager   ~0006798

It's easy to reproduce this when the LogbookAnalysisDefns.XML file doesn't exist. (It should be in the users\yourname\AppData\Roaming\HRDLLC\HRD Logbook dirsectory.) Maybe there are other ways to reproduce it, like editing and saving Analysis Definitions.

It turns out that Analysis Definitions are closely related to Logbook filter queries. When I did some work a couple months ago to enhance the filters (adding date support, for example), I changed the number of clauses in a query from 4 to 6. I thought this change was local to the query code.

Turns out that the Analysis Definitions allow only 4 queries. Yet, sometimes and erroneously, they use the maximum nubmer of queries to count instead of the naximum number of Definitions to count. That mismatch caused the crash.

K7ZCZ

2018-12-22 18:47

manager   ~0006799

Fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4641

g3ypp

2018-12-27 08:33

viewer   ~0006809

Yes, installed .163 on new laptop, and installed perfectly. Logbook does not crash. Sorted for me.

Issue History

Date Modified Username Field Change
2018-12-22 09:46 g3ypp New Issue
2018-12-22 09:46 g3ypp File Added: HRDLogbook_20181221_162625.mdmp
2018-12-22 09:46 g3ypp File Added: HRDLogbook_20181221_162649.mdmp
2018-12-22 09:46 g3ypp File Added: HRDLogbook_20181221_162817.mdmp
2018-12-22 09:46 g3ypp File Added: HRDLogbook_20181221_174814.mdmp
2018-12-22 09:50 g3ypp Description Updated View Revisions
2018-12-22 18:46 K7ZCZ Note Added: 0006797
2018-12-22 18:46 K7ZCZ Note Added: 0006798
2018-12-22 18:47 K7ZCZ Assigned To => K7ZCZ
2018-12-22 18:47 K7ZCZ Status new => resolved
2018-12-22 18:47 K7ZCZ Resolution open => fixed
2018-12-22 18:47 K7ZCZ Note Added: 0006799
2018-12-22 18:54 WA9PIE Project 2 - Next Dev List (Holding Area) => 3 - Current Dev List
2018-12-27 08:33 g3ypp Note Added: 0006809
2018-12-27 16:25 WA9PIE Status resolved => closed
2018-12-27 16:25 WA9PIE Fixed in Version => 6.5.0.163
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.163 => 6.5.0.183
2019-01-16 22:04 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe