View Issue Details

IDProjectCategoryView StatusLast Update
0003039Ham Radio DeluxeBugpublic2019-01-16 22:05
ReporterPD9FER 
Assigned ToK7ZCZ 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.5.0.183 
Summary0003039: Yaesu FT-991A and FTDX-3000 not keying Via Rigcontroll and DM-780 Beta 6.5.0.164
DescriptionFrom a customer:
Mike wa9pie ask me to contact tech support.
With this beta release the PTT is not activated by DM780 or by the TX button.
The Tune button does work.

This is the case for the FT-991A and FTDX-3000
Steps To ReproduceIn Rig control click the TX Button... NO TX
It does go in TX when clicking the Tune Button
In Digital Master go to Program Options > PTT
Set PTT via Ham Radio Deluxe, try to TX in PSK-31 (or other mode) NO TX
Additional Information Ticket #711518

Looks like both radio's using the same CAT command set for activating the PTT
This is broken somewhere down the line.

This happening from 6.5.0.161 to 6.5.0.166 (as far I am aware)
TagsFT-991A, FTDX-3000, Yaesu
ModuleRig Control
Sub-ModuleRig Control
Testing Beta Successful

Relationships

related to 0003051 closedPD9FER Beta 6.5.0.168 Macro's in Digital Master won't activate TX 

Activities

PD9FER

2019-01-06 14:41

viewer   ~0006893

Extra tests:

With both radio's, go in Rig Control
Run the Tools > Command Tester, select the correct comport and further settings...
Input the CAT command string to put the radio in TX... SUCCESS!
This makes me think the TX button does not send the correct CAT code to the radio

K7ZCZ

2019-01-06 15:47

manager   ~0006895

This issue was caused by the fix for 2877 and 1449, both issue around the transmit meters (SWR, Power, and ALC) not working in the rig control UI.

We can think of the buttons in Rig Control "declaring" a feature of the radio. The definition of a button tells us which command to send to activate the feature and which to turn it off. The button definition also tells us how to query the radio to see if the radio says the feature is on or off.

In this case, the "TX" button declares the transmit "feature". HRD occasionally (continuously, kind of) polls the radio for its status, including asking it if it is transmitting ... by using the commands defined for each radio by the "TX" button declaration for that radio. If the radio reports that it is transmitting, the values of the displayed meters are queried and then displayed. If the radio doesn't say it is transmitting, the values of the transmit meters aren't queried and they're set to zero in the Rig Control UI.

Turns out some radios discern between transmit initiation by CAT command or by the key on the microphone. The FT-991A and FTDX-3000 are two such radios. They send different status values when queried depending on if the radio was commanded (by CAT) to key down, or if the microphone key was actually down.

In bugs 1449 and 2877, the radios were never queried for the transmit meter readings because Rig Control was using the wrong status command to get the transmit status. In fixing that issue, I upset the transmit command sent by rig control to turn on transmit.

K7ZCZ

2019-01-06 15:49

manager   ~0006896

this issue is fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4671

WA9PIE

2019-01-07 20:16

administrator   ~0006904

I have two users verifying that this is fixed.

HOWEVER... one user reports the following (that is likely unrelated):

"The TX button in both rig control and dm780 will transmit. However a macro for calling cq will not transmit automatically which it did before."

Issue History

Date Modified Username Field Change
2019-01-06 04:33 PD9FER New Issue
2019-01-06 04:33 PD9FER Tag Attached: FT-991A
2019-01-06 04:33 PD9FER Tag Attached: FTDX-3000
2019-01-06 04:33 PD9FER Tag Attached: Yaesu
2019-01-06 04:35 PD9FER Summary Yaesu FT-991A and FTDX-3000 not keying Via Rigcontroll and DM-780 => Yaesu FT-991A and FTDX-3000 not keying Via Rigcontroll and DM-780 Beta 6.5.0.164
2019-01-06 04:35 PD9FER Additional Information Updated View Revisions
2019-01-06 14:16 WA9PIE Assigned To => K7ZCZ
2019-01-06 14:16 WA9PIE Status new => assigned
2019-01-06 14:16 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2019-01-06 14:41 PD9FER Note Added: 0006893
2019-01-06 15:47 K7ZCZ Note Added: 0006895
2019-01-06 15:49 K7ZCZ Status assigned => resolved
2019-01-06 15:49 K7ZCZ Resolution open => fixed
2019-01-06 15:49 K7ZCZ Note Added: 0006896
2019-01-07 18:06 K7ZCZ Fixed in Version => 6.5.0.168
2019-01-07 20:16 WA9PIE Status resolved => closed
2019-01-07 20:16 WA9PIE Testing Not Started => Beta Successful
2019-01-07 20:16 WA9PIE Note Added: 0006904
2019-01-08 12:23 PD9FER Relationship added related to 0003051
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.168 => 6.5.0.183
2019-01-16 22:05 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe