View Issue Details

IDProjectCategoryView StatusLast Update
0003052Ham Radio DeluxeEnhancementpublic2019-11-07 05:35
ReporterK7ZCZAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version6.5.0.168 
Target VersionFixed in Version6.5.0.196 
Summary0003052: Provide reliable web service with solar data in Logbook
DescriptionThe logbook provides solar data. (It's available from the "View" menu in a "Solar Cylce" tear-off, at the "Display" command.) There are three different sources of data that are downloaded periodically by the Logbook, glued together, and drawn on a graph. If any data source fails, the user ends up looking at stale data.

Thing is, the data sources are unreliable. Three data sources come from websites, which aren't too bad though they occasionally fial. The fourth data source comes from an FTP site which is slow and unreliable. I've not been able to find any terms-of-service guarantee (or any other documentation, for that matter) from the data source provider. I imagine that the large number of HRD users frequently hitting the FTP and web sites are not making the site administrators too happy.

We can solve both of these problems by re-publishing the data in our own web service. I propose building a web servre that downloads tihs data a few times a day -- once every eight hours is probably more than often enough. When the data is downloaded successfully, it is retained and made available from a known URL. Maybe the URL is served by a CDN.

The HRD applications are changed to download only from that known URL. This relieves the load on the third-party servers.

It also puts us back in control of our own customer experience. If we can assure that the data is downloaded rapidly and reliably, our customers are happy and we're not left to blame an unknown third-party for a bad user experience.
TagsNo tags attached.
ModuleLogbook
Sub-Module(select)
Testing Beta Successful

Relationships

related to 0002941 closedWA9PIE LB: Solar Cycle Progression broke 

Activities

WA9PIE

2019-01-16 12:38

administrator   ~0007009

For the moment, I have placed this file at https://downloads.hamradiodeluxe.com/RecentIndices.txt

This was a manual effort. I'll do this manually until I automate it.

Let's go forward with this.

K7ZCZ

2019-01-16 14:18

administrator   ~0007011

This checkin uses the new hamradiodeluxe.com URL.
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4726

Will we also move the other files to the hamradiodeluxe.com site? If so, please let know when they're changed and what the new URLs are.

This change moves us away from FTP, but to HTTPS. HTTPS has problems on some OSes because it requires a good TLS configuration. Until we stop supporting downlevel OSes (see Mantis 2757), we'll have to test features like this to see if they work correctly without TLS support in the OS.


WA9PIE

2019-01-16 14:21

administrator   ~0007012

When I can automate the file transfer, I’ll pick up the remaining files.

WA9PIE

2019-01-16 18:03

administrator   ~0007015

Validated

Issue History

Date Modified Username Field Change
2019-01-08 14:39 K7ZCZ New Issue
2019-01-08 14:45 K7ZCZ Relationship added related to 0002941
2019-01-16 12:38 WA9PIE Note Added: 0007009
2019-01-16 12:38 WA9PIE Assigned To => K7ZCZ
2019-01-16 12:38 WA9PIE Status new => assigned
2019-01-16 14:18 K7ZCZ Status assigned => resolved
2019-01-16 14:18 K7ZCZ Resolution open => fixed
2019-01-16 14:18 K7ZCZ Note Added: 0007011
2019-01-16 14:21 WA9PIE Note Added: 0007012
2019-01-16 17:53 WA9PIE Fixed in Version => 6.5.0.182
2019-01-16 18:03 WA9PIE Status resolved => closed
2019-01-16 18:03 WA9PIE Testing Not Started => Beta Successful
2019-01-16 18:03 WA9PIE Note Added: 0007015
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.182 => 6.5.0.183
2019-01-16 22:04 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2019-11-07 05:35 WA9PIE Fixed in Version 6.5.0.183 => 6.5.0.196