View Issue Details

IDProjectCategoryView StatusLast Update
0003054Ham Radio DeluxeEnhancementpublic2019-11-07 05:35
ReporterK7ZCZAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.5.0.196 
Summary0003054: Update Logbook's solar data in each build
DescriptionThe Logbook includes a graph of solar data that's plotted from information downloaded from the internet. If the user accesses the graph before the data is downloaded, or if data is not successfully downloaded, some copies of the data built-in to the application's resources are used.

The resource files have these names:

predict_default.txt
predict_high.txt
predict_low.txt
recent_indicies.txt


At their source, this data is updated daily or monthly. The copies of the files built-in to the product haven't been updated since 2015.

Because our users might not be connected to the internet, and because even when they are the internet data source might not reliably supply this data for download. In that event, this old data is shown to customers. To ameliorate this issue, we should update these resources every once in a while.

Ideally, we would update them with each product build. Before buildng the product proper, the build script can go get the newest file, add it to version control, and assure that the produced build of the product has newest available data.
Steps To Reproduce1) Disconnect from the Internets
2) Start up the logbook
3) In the "View" menu, find the "Solar Cycle" tear off.
4) In that tear-off, mark the "Display" command so the solar data is displayed

BUG#1) Since the data can't be downloaded from the Internet, old data will be displayed. It's this old data which we propose to replace.
TagsNo tags attached.
ModuleLogbook
Sub-Module(select)
Testing Beta Successful

Relationships

related to 0002941 closedWA9PIE LB: Solar Cycle Progression broke 

Activities

K7ZCZ

2019-01-11 23:18

administrator   ~0006971

Last edited: 2019-01-11 23:19

View 2 revisions

Mostly fixed with this checkin. Need to add a few more lines of code to check-in the downloaded file.
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4705

K7ZCZ

2019-01-12 10:01

administrator   ~0006975

added code to checkin with this checkin (LOL!):
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4707

WA9PIE

2019-01-13 14:28

administrator   ~0006986

Validated

Issue History

Date Modified Username Field Change
2019-01-08 14:40 K7ZCZ New Issue
2019-01-08 14:45 K7ZCZ Relationship added related to 0002941
2019-01-11 23:18 K7ZCZ Note Added: 0006971
2019-01-11 23:19 K7ZCZ Note Edited: 0006971 View Revisions
2019-01-12 10:01 K7ZCZ Assigned To => K7ZCZ
2019-01-12 10:01 K7ZCZ Status new => resolved
2019-01-12 10:01 K7ZCZ Resolution open => fixed
2019-01-12 10:01 K7ZCZ Note Added: 0006975
2019-01-13 14:17 WA9PIE Fixed in Version => 6.5.0.180
2019-01-13 14:28 WA9PIE Status resolved => closed
2019-01-13 14:28 WA9PIE Description Updated View Revisions
2019-01-13 14:28 WA9PIE Testing Not Started => Beta Successful
2019-01-13 14:28 WA9PIE Note Added: 0006986
2019-01-16 22:04 WA9PIE Fixed in Version 6.5.0.180 => 6.5.0.183
2019-01-16 22:04 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe
2019-11-07 05:35 WA9PIE Fixed in Version 6.5.0.183 => 6.5.0.196