View Issue Details

IDProjectCategoryView StatusLast Update
00030583 - Current Dev ListMaintenancepublic2019-02-09 12:51
ReporterPD9FER 
Assigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.5.0.191 
Summary0003058: FTDX-3000 600 Hz Button not displaying the state it is in
DescriptionI have a series of buttons set up on the RigControl pane.
These include Roofing Filter buttons for 15Khz, 6Khz, 3Khz and 600HZ.
They all effect the correct changes in the radio.
All, but the 600Hz filter have the correct "Normal" and "Selected" indication on the button.
The 600Hz button works fine but there is no "Selected" indication.
Steps To ReproduceIn Rig Control Push the 600 Hz Roofing Filter button.
Note, no indication of the state it is in.
Additional InformationTicket #551350
TagsFTDX-3000, Yaesu
ModuleRig Control
Sub-ModuleAppearance/UI
Testing Beta Successful

Relationships

related to 0002970 closedK7ZCZ Rig Control: consider enhancing drop-down list buttons for mismatched response groups 

Activities

K7ZCZ

2019-01-11 14:54

manager   ~0006968

The FTDX-3000 roofing filter is an example of a mismatched response group. The set commands are these:

RF00 - auto
RF01 - 15 kHz
RF02 - 6 kHz
RF03 - 3 kHz
RF04 - 600 Hz
RF05 - 300 Hz


but the possible response from the radio are these:

RF01- 15 kHz
RF02 - 6 khZ
RF03 - 3 kHz
RF04 - AUTO - 15 kHz
RF05 - AUTO - 6 kHz
RF06 - AUTO - 3 kHz
RF07 - 600 Hz
RF08 - 300 Hz
RF09 - AUTO - 600 Hz
RF0A - AUTO - 300 Hz


Because the set commands don't match the query commands, Rig Control isn't able to manage the setting bidirectionally. This deficiency is tracked by Mantis 2970.

K7ZCZ

2019-02-02 14:56

manager   ~0007226

fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4803

PD9FER

2019-02-02 15:05

updater   ~0007227

Thanks, will ask confirmation when the Beta is posted

PD9FER

2019-02-07 02:09

updater   ~0007301

Confirmed as Fixed in Beta 6.0.5.191 by the customer

WA9PIE

2019-02-09 12:51

administrator   ~0007341

Validated

Issue History

Date Modified Username Field Change
2019-01-11 10:51 PD9FER New Issue
2019-01-11 10:51 PD9FER Tag Attached: FTDX-3000
2019-01-11 10:51 PD9FER Tag Attached: Yaesu
2019-01-11 14:54 K7ZCZ Note Added: 0006968
2019-01-11 14:54 K7ZCZ Relationship added related to 0002970
2019-02-02 14:56 K7ZCZ Assigned To => K7ZCZ
2019-02-02 14:56 K7ZCZ Status new => resolved
2019-02-02 14:56 K7ZCZ Resolution open => fixed
2019-02-02 14:56 K7ZCZ Note Added: 0007226
2019-02-02 15:05 PD9FER Note Added: 0007227
2019-02-02 21:38 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2019-02-06 11:19 K7ZCZ Fixed in Version => 6.5.0.191
2019-02-07 02:09 PD9FER Note Added: 0007301
2019-02-09 12:51 WA9PIE Status resolved => closed
2019-02-09 12:51 WA9PIE Testing Not Started => Beta Successful
2019-02-09 12:51 WA9PIE Note Added: 0007341