View Issue Details

IDProjectCategoryView StatusLast Update
0003085Ham Radio DeluxeBugpublic2019-02-24 15:12
ReporterK7ZCZAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version6.5.0.184 
Target VersionFixed in Version6.5.0.196 
Summary0003085: Logbook's band buttons don't tune FT-891 radio
DescriptionThe Logbook has buttons to tune a radio to a particular band. These buttons don't work with the FT-891.
Steps To Reproduce1) Start up Rig Control. Connect to an FT-891 radio
2) Start up Logbook. Make sure Logbook is connected to Rig Control
3) Use the "Tune Main" button in the main window's toolbar to show the "Tune Main" pane in the Logbook
4) Press any of the band buttons in the "Tune Main" pane

BUG#1) the radio doesn't tune to the selected band
TagsFT-891
ModuleLogbook
Sub-ModuleRadio Support
Testing Beta Successful

Relationships

related to 0002266 closedK7ZCZ 5 - Closed w/o Action Ticket 336826 - FT891 Numerous issues with CAT control 

Activities

K7ZCZ

2019-01-22 16:45

administrator   ~0007059

As far as I can tell, this issue isn't specific to the FT-891; the band buttons in the tuning pane don't work for any radio.

The buttons are labeled and appear based on settings reachable from the "Options" button in the tuning pane (and from the Config menu in the main window).

When a button is pressed, however, a different set of band settings are consulted to determine the desired tuning frequency. These settings come from a file named "LogbookUserBandSettings.xml", which doesn't ship with the product, isn't written by the product. No UI is provided by the application to edit the file, either. The file never exists, the settings are always empty, so there's no known frequency to switch to when a band button is pressed.

Because it wasn't used for used for anything (that worked) and wasn't visible, I've removed the CBandSettings class which wrapped the LogbookUserBandSettings.xml file.

I've adjusted the tuning pane code so that it uses the lowest frequency of the band as defined in the "Bands" tab of that option configuration dialog.

K7ZCZ

2019-01-22 16:46

administrator   ~0007060

Fixed with this checkin
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4750

WA9PIE

2019-02-05 15:19

administrator   ~0007275

Validated

Issue History

Date Modified Username Field Change
2019-01-21 11:33 K7ZCZ New Issue
2019-01-21 11:34 K7ZCZ Relationship added related to 0002266
2019-01-22 16:45 K7ZCZ Note Added: 0007059
2019-01-22 16:46 K7ZCZ Assigned To => K7ZCZ
2019-01-22 16:46 K7ZCZ Status new => resolved
2019-01-22 16:46 K7ZCZ Resolution open => fixed
2019-01-22 16:46 K7ZCZ Note Added: 0007060
2019-01-29 22:47 K7ZCZ Fixed in Version => 6.5.0.188
2019-02-05 15:17 WA9PIE Tag Attached: FT-891
2019-02-05 15:19 WA9PIE Testing Not Started => Beta Successful
2019-02-05 15:19 WA9PIE Note Added: 0007275
2019-02-05 15:20 WA9PIE Status resolved => closed
2019-02-24 14:40 WA9PIE Fixed in Version 6.5.0.188 => 6.5.0.196
2019-02-24 15:12 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe