View Issue Details

IDProjectCategoryView StatusLast Update
00030993 - Current Dev ListEnhancementpublic2019-02-08 18:03
ReporterKC7FPFAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityN/A
Status assignedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0003099: Implement buton access to Voice Recordings Playback Bank, 5 memories, using CAT Command PB Play Back
DescriptionTicket 579817

Please implement button access to Voice Recordings Playback Bank, 5 memories, using CAT Command PB Play Back

Please assign each to it's own button.

Necessary for Contesting and DXing
Additional InformationThis issue was resolved for the Yaesu FT991A Please reference Mantis 2630
TagsIC-7300, ICOM
ModuleRig Control
Sub-ModuleFunctional
TestingNot Started

Relationships

has duplicate 0002897 closedKC7FPF 5 - Closed w/o Action voice recordings in my IC7300 from the keyboard via HRD 

Activities

KC7FPF

2019-01-25 12:56

updater  

dropdwon7300.JPG (126,791 bytes)
dropdwon7300.JPG (126,791 bytes)

K7ZCZ

2019-01-26 21:42

administrator   ~0007082

Icom doesn't document a CI-V command for Voice recorder TX playback on this radio.

From an update to the ticket, it looks like the customer figured out that the IC-7610 command works on his IC-7300, and has programmed a macro button for the feature he wants.

KC7FPF

2019-01-29 08:45

updater   ~0007115

figured it out! One of the CAT commands for the IC-7610 also works for the IC-7300. The specific command for playing the recording at memory T1 is:FE-FE-FE-94-E0-28-00-01-FD. For the recording at memory T2 the " -01- " gets changed to " -02-", and so on. Thanks for your assistance. Feel free to post this on the user forums.

Please see ticket 579817

recorded for ic7300.JPG (41,449 bytes)
recorded for ic7300.JPG (41,449 bytes)

K7ZCZ

2019-02-01 16:03

administrator   ~0007205

During the team call on 2019-01-31, we agreed that we were uncomfortable using undocumented radio commands in the application. We decided that MikeC would contact Icom to see if documentation exists for the voice playback control commands on the IC-7300. If Icom supports their use, we can implement this feature in the product. If not, we'll leavei t to customers to add the workaround at their discretion.

WA9PIE

2019-02-05 22:29

administrator   ~0007286

I have an inquiry in to Ray Novak and I'm awaiting his response.

K7ZCZ

2019-02-06 11:21

administrator   ~0007292

Marking this assigned, since it is actively being worked

WA9PIE

2019-02-08 11:06

administrator   ~0007322

I spoke to Ray here at Hamcation. Ray advises that this capability was added in the IC-7300 with a recent firmware update. ICOM does support this.

He tells me that it's documented in the Japanese version of the documentation and that they expect to update the English language documentation soon. But yes, it is supported... and they're the same commands used for the IC-7610.

K7ZCZ

2019-02-08 14:39

administrator   ~0007331

Oh! I should've thought of looking at the Japanese-language manual.

I can get this implemented ...

Issue History

Date Modified Username Field Change
2019-01-25 12:56 KC7FPF New Issue
2019-01-25 12:56 KC7FPF Status new => assigned
2019-01-25 12:56 KC7FPF Assigned To => K7ZCZ
2019-01-25 12:56 KC7FPF File Added: dropdwon7300.JPG
2019-01-25 12:56 KC7FPF Tag Attached: IC-7300
2019-01-25 12:56 KC7FPF Tag Attached: ICOM
2019-01-26 21:42 K7ZCZ Note Added: 0007082
2019-01-26 21:43 K7ZCZ Status assigned => resolved
2019-01-26 21:43 K7ZCZ Resolution open => won't fix
2019-01-29 08:45 KC7FPF File Added: recorded for ic7300.JPG
2019-01-29 08:45 KC7FPF Note Added: 0007115
2019-01-31 15:16 WA9PIE Project 1 - Backlog => 3 - Current Dev List
2019-02-01 16:03 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-02-01 16:03 K7ZCZ Note Added: 0007205
2019-02-02 23:07 K7ZCZ Relationship added has duplicate 0002897
2019-02-05 22:29 WA9PIE Note Added: 0007286
2019-02-06 11:21 K7ZCZ Status resolved => assigned
2019-02-06 11:21 K7ZCZ Note Added: 0007292
2019-02-08 11:06 WA9PIE Note Added: 0007322
2019-02-08 11:06 WA9PIE Assigned To WA9PIE => K7ZCZ
2019-02-08 14:39 K7ZCZ Note Added: 0007331
2019-02-08 18:03 WA9PIE Resolution won't fix => open
2019-02-08 18:03 WA9PIE Description Updated View Revisions