View Issue Details

IDProjectCategoryView StatusLast Update
0003102Ham Radio DeluxeBugpublic2019-02-24 15:13
ReporterK7ZCZAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version6.5.0.187 
Target VersionFixed in Version6.5.0.196 
Summary0003102: Satellite Tracker shows weird dates for "Last Update" column
DescriptionThe Satellite TRacker has a "Last Updated" column that doesn't seem to make any sense. Maybe this data is actually correct, and we just need to be better at presenting it so its meaning is clear.

If "Last Updated" is intended to mean that updates are necesary, how are they performed?
Steps To Reproduce1) Start up Satellite Tracker
2) Activate the "Satellite Definitions" tab
3) Note the "Last Updated" column for AO-10

BUG#1) for me, it says "3812 04:51:39". That's 1800 years into the future, isn't it? Maybe it's meant to be a number of days, then HH:MM:SS?


4) Note the "Last Updated" column for the ISS

BUG#2) For me, it says "0 00:04:03". Is that 0 BC? Maybe it's 0 days, four hours into the past?

TagsNo tags attached.
ModuleSatellite Tracking
Sub-ModuleAppearance/UI
Testing Beta Successful

Activities

K7ZCZ

2019-02-14 15:08

administrator   ~0007395

Turns out the value displayed is time since the last update for that satellite's data. "1 22:11:30" means that the data was last updated 1 day, 22 hours, 11 minutes and 30 seconds ago.

I've added a "d" to this field, so "1d 22:11:30". I've also changed the heading to "Since Last update".

Fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4826

WA9PIE

2019-02-19 23:54

administrator   ~0007440

Validated (though it seems strange to carry items that are so old; they are in the download files, as far as I can tell; even the "Purge Old Entries" function doesn't purge them)

Issue History

Date Modified Username Field Change
2019-01-26 06:55 K7ZCZ New Issue
2019-02-14 15:08 K7ZCZ Assigned To => K7ZCZ
2019-02-14 15:08 K7ZCZ Status new => resolved
2019-02-14 15:08 K7ZCZ Resolution open => fixed
2019-02-14 15:08 K7ZCZ Sub-Module (select) => Appearance/UI
2019-02-14 15:08 K7ZCZ Note Added: 0007395
2019-02-19 19:05 K7ZCZ Fixed in Version => 6.5.0.194
2019-02-19 23:54 WA9PIE Status resolved => closed
2019-02-19 23:54 WA9PIE Description Updated View Revisions
2019-02-19 23:54 WA9PIE Testing Not Started => Beta Successful
2019-02-19 23:54 WA9PIE Note Added: 0007440
2019-02-24 14:36 WA9PIE Fixed in Version 6.5.0.194 => 6.5.0.196
2019-02-24 15:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe