View Issue Details

IDProjectCategoryView StatusLast Update
00031304 - Closed w/o ActionBugpublic2019-02-28 16:05
ReporterPD9FERAssigned ToPD9FER 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Summary0003130: Logbook ALE lookup disregards position set in Callsign Lookup order
DescriptionCustomer has multiple entries for G7WIR logged in his Logbook
QTH was set to something else (Test for example)

Callsign Lookup order is set to:
Logbook
QRZ.COM
Country List

When opening the ALE and entering G7WIR and do the lookup, QTH is taken from QRZ (Kent)
Whilst it should take info from the previous logged data.
Steps To ReproduceCallsign Lookup options:
1st Logbook
2nd QRZ
3rd Country List
 
(disable all auto logging to QRZ, eQSL and so on)

Open ALE and lookup G7WIR for instance and change his QTH to Test
Add to logbook...
Now open ALE again. and do the lookup for G7WIR again
QTH should read Test, but it keeps taking Kent as per QRZ data.
Additional InformationTicket #844087
TagsNo tags attached.
ModuleLogbook
Sub-ModuleCall lookup
TestingNot Started

Relationships

related to 0003001 acknowledgedK7ZCZ 3 - Current Dev List Callsign lookup function does not appear to be working as designed 
related to 0003147 closedK7ZCZ Ham Radio Deluxe Logbook callsign lookup data source doesn't return much data 
related to 0003145 closedK7ZCZ Ham Radio Deluxe Enhance logging output of callsign lookup feature 

Activities

K7ZCZ

2019-01-28 14:46

administrator   ~0007107

As far as I can tell, the ordering is working just as it should.

The problem demonstrated here is that the Logbook's internal lookup doesn't return the expected data. I think a bit of troubleshooting will help demonstrate what's happening:

1) After the above steps, close the ALE
2) Open the Callsign Lookup settings, and set the data sources so that the Logbook considers the Logbook and the Country List, in that order.
3) Apply and close the Callsign Lookup settings dialog
4) Open the ALE to add a new entry
5) Enter "G7WIR" again for the callsign, and press the "Lookup" button
6) Might need to activate the "Location" tab

BUG#1) the QTH value is not populated, even though the logbook record which matched should've given the changed callsign done and saved in the steps above.

In debugging the code, I get a peek at the data returned from the Logbook to the ALE lookup request. It's here, in XML format:

<?xml version="1.0"?>

<!-- -->

<!-- ===================== WARNING ========================== -->

<!-- | The contents of this file must not be changed if the | -->

<!-- | program is to operate correctly. To avoid problems, | -->

<!-- | please do NOT edit this file. | -->

<!-- ======================================================== -->

<!-- -->

<!-- Filename ..: HRDLogbookRequest-2019-01-28 121008.xml -->

<!-- Created ...: 2019-01-28 12:10:08 -->

<!-- Computer ..: SLED -->

<!-- Username ..: mikeblas -->

<!-- Program ...: HRDLogbook.exe -->

<!-- -->

<!-- c:\hrd65\logbook\hrdlogbook\logbookwndlogbook.cpp line 558 -->

<!-- -->

-<HRD xml:lang="EN" Created="28-Jan-2019 12:10" Description="Logbook Request">

<Request ADIF="PRIMARY_KEY QSO_DATE TIME_ON USER_DEFINED_9 TIME_ON CALL MODE RST_SENT RST_RCVD BAND NAME COUNTRY PRIMARY_KEY" Count="100" Exact="0" Value="G7WIR" Field="CALL"/>


-<Results Count="1">

<QSO USER_DEFINED_9="01/28/2019 195609" TIME_ON="2019-01-28@19:56:09" RST_SENT="599" RST_RCVD="599" NAME="Martin Abbott" MODE="CW" COUNTRY="England" CALL="G7WIR" PRIMARY_KEY="1"/>

</Results>

</HRD>


We can see that the QTH isn't included in the data requested from the logbook; it isn't included in the data sent back to the ALE, either.

In the original scenario, then, we can conclude that the ordering is just fine. The Logbook doesn't return a QTH, even though one is present in the matching record. QRZ.COM is consulted, and it does return a QTH, so that's used in ALE's lookup results.

It sounds like we want to change the Logbook's internal lookup so that it does get the QTH. Maybe some other fields should come back, too. I think all of that is part of specifying how the lookup feature should actually work. Mantis 3001 tracks that work.

PD9FER

2019-01-28 16:53

updater   ~0007109

Correct, it is skipping QTH in previous stored records

PD9FER

2019-01-28 16:54

updater   ~0007110

When removing QRZ from the Callsign Options list, the data from prev QSO's is shown

K7ZCZ

2019-01-28 16:59

administrator   ~0007111

Last edited: 2019-01-28 17:01

View 2 revisions

Can you specify which fields were retrieved? I tested against both 6.4.907, and 6.5.187 and both verisons of the product behaved as I describe. Why do you think you realize different results?

K7ZCZ

2019-01-28 22:10

administrator   ~0007112

Investigating the code verifies that the Logbook lookup isn't requesting the data from Logbook. QTH comes back enpty (because it's not requested) and the callsign lookup process proceeds without it.

Since you're saying that the data does come back, you must be reporting a different problem or scenario than I'm testing. So I can't apply my fix until we figure out what issue you're actually observing.

PD9FER

2019-01-29 00:48

updater   ~0007113

1: when QRZ.com is configured in Callsign lookup (no matter which position it is at, QTH is retrieved from QRZ
2: when QRZ is NOT in the Callsign lookup the data comes from Logbook (if there is a prev. match)

K7ZCZ

2019-01-29 10:27

administrator   ~0007118

The next build will have a fix for 3135, which will log some of the progress of the callsign lookup in the Logfile window. That might help gain insight into what's happening.

I'm unable to reproduce your #2 above; an internal lookup against the logbook never returns QTH. It doesn't return anything else, really; just the fields in the "Request" tag of the XML I quote above. The actual values returned are in the "QSO" tag of that XML document. I need to learn how you're getting the logbook to return anything more. Are there settings you can think of which might influence this behavior? Are there other features which might be relevant?

PD9FER

2019-01-29 11:03

updater   ~0007120

We might discuss this in the next meeting.
So we all can share our ideas on this

K7ZCZ

2019-01-30 17:53

administrator   ~0007170

Please re-run your experiment with the 188 build and provide the logfile. I can add more output to the logfile as we go, but that should give us some insight into what's happening.

PD9FER

2019-01-31 04:15

updater   ~0007177

Well 188 seems to work for me.
I sent it to the customer and let it know.

PD9FER

2019-02-01 10:32

updater   ~0007197

Update...
It still does not works (it looked like it because the QRZ XML was down at the time of testing)

PD9FER

2019-02-01 11:51

updater   ~0007198

See Video on:
https://support.hamradiodeluxe.com/file.php?key=hmvt8ffc_tyl9mcdjix7msk-gszivphm&expires=1549152000&signature=f7798a0ce7bf01af9fa5f2a690b03992d5cb7687

K7ZCZ

2019-02-01 15:53

administrator   ~0007204


During the conference call on 2019-01-31, we agreed to leave this bug as-is for now and pursue fixes for the two related issues identified. Those related issues are 3145 and 3147.

If you'd like to pursue this bug further, I think the best next step is reviewing the logfile output after the lookup operation. In current builds, I believe that the logfile output will show that the lookup source ordering is correct. If it doesn't, then we can zoom-in on the cause.

PD9FER

2019-02-03 12:42

updater   ~0007245

Attached the 2 log files
Do what you think is needed (work on the others 1st)

HRD Logbook Logfile 2019-02-03 181256.txt (14,100 bytes)
18:12:24  Thread                              Callsign Lookup: Creating thread
18:12:24  Thread                              Callsign Lookup: Created thread, handle = 00000E58, errno = 0
18:12:27  WorkedStatus                        Select: (COL_BAND = '') AND (COL_MODE = 'FM') AND (COL_CALL = 'G')
18:12:27  WorkedStatus                        Status: 0
                                              
18:12:27  WorkedStatus                        Select: (COL_BAND = '') AND (COL_MODE = 'FM') AND (COL_CALL = 'GF')
18:12:27  WorkedStatus                        Status: 0
                                              
18:12:28  ALE Worked                          Refresh: Call="G", Country=""

18:12:28  WorkedStatusEx                      Select: (COL_CALL = 'G') OR (COL_CALL LIKE '%/G/%') OR (COL_CALL LIKE '%/G') OR (COL_CALL LIKE 'G/%')
18:12:29  WorkedStatusEx                      Bands:  
18:12:29  WorkedStatus                        Select: (COL_BAND = '') AND (COL_MODE = 'FM') AND (COL_CALL = 'G0')
18:12:29  WorkedStatus                        Status: 0
                                              
18:12:30  WorkedStatus                        Select: (COL_BAND = '') AND (COL_MODE = 'FM') AND (COL_CALL = 'G0O')
18:12:30  WorkedStatus                        Status: 0
                                              
18:12:30  WorkedStatus                        Select: (COL_BAND = '') AND (COL_MODE = 'FM') AND (COL_CALL = 'G0OM')
18:12:30  WorkedStatus                        Status: 0
                                              
18:12:30  WorkedStatus                        Select: (COL_BAND = '') AND (COL_MODE = 'FM') AND (COL_CALL = 'G0OMH')
18:12:30  WorkedStatus                        Status: 0
                                              
18:12:31  ALE Worked                          Refresh: Call="G0OMH", Country=""

18:12:31  WorkedStatusEx                      Select: (COL_CALL = 'G0OMH') OR (COL_CALL LIKE '%/G0OMH/%') OR (COL_CALL LIKE '%/G0OMH') OR (COL_CALL LIKE 'G0OMH/%')
18:12:31  WorkedStatusEx                      Bands:  10m,12m,15m,17m,20m,2m,40m,4m,6m,70cm,80m
18:12:32  CLogbookWndLogbook::SearchCallsign  Callsign G0OMH Force 1 All 0
18:12:32  CLogbookWndLogbook::SearchCallsign  Calling
18:12:32  CLogbookWndLogbook::SendRequest     lpszADIF = "CALL" lpszValue = "G0OMH"
18:12:32  ALE Logbook                         Request DB:: Search for "G0OMH" in "CALL".
18:12:32  LogbookSearch                       Field = CALL, Value = G0OMH, Exact = 0, Count = 100
18:12:32  LogbookSearch                       DSN=G7WIR - VHF - Access;DBQ=C:\Users\Martin\AppData\Roaming\HRDLLC\HRD Logbook\G7WIR - VHF.mdb;DriverId=25;FIL=MS Access Open status 1
18:12:32  LogbookSearch                       SQL: SELECT TOP 100 COL_PRIMARY_KEY,COL_ADDRESS,COL_AGE,COL_A_INDEX,COL_ANT_AZ,COL_ANT_EL,COL_ANT_PATH,COL_ARRL_SECT,COL_BAND,COL_BAND_RX,COL_BIOGRAPHY,COL_CALL,COL_CHECK,COL_CLASS,COL_CNTY,COL_COMMENT,COL_CONT,COL_CONTACTED_OP,COL_CONTEST_ID,COL_COUNTRY,COL_CQZ,COL_DISTANCE,COL_DXCC,COL_EMAIL,COL_EQ_CALL,COL_EQSL_QSLRDATE,COL_EQSL_QSLSDATE,COL_EQSL_QSL_RCVD,COL_EQSL_QSL_SENT,COL_EQSL_STATUS,COL_FORCE_INIT,COL_FREQ,COL_FREQ_RX,COL_GRIDSQUARE,COL_HEADING,COL_IOTA,COL_ITUZ,COL_K_INDEX,COL_LAT,COL_LON,COL_LOTW_QSLRDATE,COL_LOTW_QSLSDATE,COL_LOTW_QSL_RCVD,COL_LOTW_QSL_SENT,COL_LOTW_STATUS,COL_MAX_BURSTS,COL_MODE,COL_MS_SHOWER,COL_MY_CITY,COL_MY_CNTY,COL_MY_COUNTRY,COL_MY_CQ_ZONE,COL_MY_GRIDSQUARE,COL_MY_IOTA,COL_MY_ITU_ZONE,COL_MY_LAT,COL_MY_LON,COL_MY_NAME,COL_MY_POSTAL_CODE,COL_MY_RIG,COL_MY_SIG,COL_MY_SIG_INFO,COL_MY_STATE,COL_MY_STREET,COL_NAME,COL_NOTES,COL_NR_BURSTS,COL_NR_PINGS,COL_OPERATOR,COL_OWNER_CALLSIGN,COL_PFX,COL_PRECEDENCE,COL_PROP_MODE,COL_PUBLIC_KEY,COL_QSLMSG,COL_QSLRDATE,COL_QSLSDATE,COL_QSL_RCVD,COL_QSL_RCVD_VIA,COL_QSL_SENT,COL_QSL_SENT_VIA,COL_QSL_VIA,COL_QSO_COMPLETE,COL_QSO_RANDOM,COL_QTH,COL_RIG,COL_RST_RCVD,COL_RST_SENT,COL_RX_PWR,COL_SAT_MODE,COL_SAT_NAME,COL_SFI,COL_SIG,COL_SIG_INFO,COL_SRX,COL_SRX_STRING,COL_STATE,COL_STATION_CALLSIGN,COL_STX,COL_STX_STRING,COL_SWL,COL_TEN_TEN,COL_TIME_OFF,COL_TIME_ON,COL_TX_PWR,COL_WEB,COL_USER_DEFINED_0,COL_USER_DEFINED_1,COL_USER_DEFINED_2,COL_USER_DEFINED_3,COL_USER_DEFINED_4,COL_USER_DEFINED_5,COL_USER_DEFINED_6,COL_USER_DEFINED_7,COL_USER_DEFINED_8,COL_USER_DEFINED_9,COL_CREDIT_GRANTED,COL_CREDIT_SUBMITTED,COL_ISMULTIPLIER,COL_ROVERLOCATION,COL_HRDCOUNTRYNO FROM [TABLE_HRD_CONTACTS_V01] WHERE (COL_CALL LIKE '%G0OMH%') ORDER BY COL_TIME_ON DESC, COL_CALL DESC
18:12:32  LogbookSearch                       SQL: WHERE (COL_CALL LIKE '%G0OMH%')
18:12:32  LogbookSearch                       Returned 100 records
18:12:32  WorkedStatus                        Select: (COL_BAND = '70cm') AND (COL_MODE = 'FM') AND (COL_CALL = 'G0OMH')
18:12:32  WorkedStatus                        Status: 1
                                              
18:12:32  WorkedStatus                        Select: (COL_BAND = '70cm') AND (COL_MODE = 'FM') AND (COL_DXCC = '223')
18:12:32  WorkedStatus                        Status: 1
                                              
18:12:32  ALE Lookup                          Lookup from Previous Logbook Entry for G0OMH timedout at 0.454 seconds

18:12:32  ALE Lookup                          Lookup from QRZ.com Online Database: G0OMH
18:12:38  ALE                                 Adding Entry "G0OMH" to Logbook.
18:12:39  Add                                 Opening database G7WIR - VHF - Access
18:12:39  Add                                 Open status 1
18:12:39  Add                                 Opening table TABLE_HRD_CONTACTS_V01
18:12:39  ALE                                 Reset.
18:12:39  WorkedStatus                        Select: (COL_BAND = '70cm') AND (COL_MODE = 'FM') AND (COL_DXCC = '223')
18:12:39  WorkedStatus                        Status: 1
                                              
18:12:39  CLogbookWndLogbook::Refresh         All 0 Field CALL Value G0OMH
18:12:39  CLogbookWndLogbook::SendRequest     lpszADIF = "CALL" lpszValue = ""
18:12:39  ALE Logbook                         Request DB:: Search for "" in "CALL".
18:12:39  LogbookSearch                       Field = CALL, Value = , Exact = 1, Count = 100
18:12:39  LogbookSearch                       DSN=G7WIR - VHF - Access;DBQ=C:\Users\Martin\AppData\Roaming\HRDLLC\HRD Logbook\G7WIR - VHF.mdb;DriverId=25;FIL=MS Access Open status 1
18:12:39  LogbookSearch                       SQL: SELECT TOP 100 COL_PRIMARY_KEY,COL_ADDRESS,COL_AGE,COL_A_INDEX,COL_ANT_AZ,COL_ANT_EL,COL_ANT_PATH,COL_ARRL_SECT,COL_BAND,COL_BAND_RX,COL_BIOGRAPHY,COL_CALL,COL_CHECK,COL_CLASS,COL_CNTY,COL_COMMENT,COL_CONT,COL_CONTACTED_OP,COL_CONTEST_ID,COL_COUNTRY,COL_CQZ,COL_DISTANCE,COL_DXCC,COL_EMAIL,COL_EQ_CALL,COL_EQSL_QSLRDATE,COL_EQSL_QSLSDATE,COL_EQSL_QSL_RCVD,COL_EQSL_QSL_SENT,COL_EQSL_STATUS,COL_FORCE_INIT,COL_FREQ,COL_FREQ_RX,COL_GRIDSQUARE,COL_HEADING,COL_IOTA,COL_ITUZ,COL_K_INDEX,COL_LAT,COL_LON,COL_LOTW_QSLRDATE,COL_LOTW_QSLSDATE,COL_LOTW_QSL_RCVD,COL_LOTW_QSL_SENT,COL_LOTW_STATUS,COL_MAX_BURSTS,COL_MODE,COL_MS_SHOWER,COL_MY_CITY,COL_MY_CNTY,COL_MY_COUNTRY,COL_MY_CQ_ZONE,COL_MY_GRIDSQUARE,COL_MY_IOTA,COL_MY_ITU_ZONE,COL_MY_LAT,COL_MY_LON,COL_MY_NAME,COL_MY_POSTAL_CODE,COL_MY_RIG,COL_MY_SIG,COL_MY_SIG_INFO,COL_MY_STATE,COL_MY_STREET,COL_NAME,COL_NOTES,COL_NR_BURSTS,COL_NR_PINGS,COL_OPERATOR,COL_OWNER_CALLSIGN,COL_PFX,COL_PRECEDENCE,COL_PROP_MODE,COL_PUBLIC_KEY,COL_QSLMSG,COL_QSLRDATE,COL_QSLSDATE,COL_QSL_RCVD,COL_QSL_RCVD_VIA,COL_QSL_SENT,COL_QSL_SENT_VIA,COL_QSL_VIA,COL_QSO_COMPLETE,COL_QSO_RANDOM,COL_QTH,COL_RIG,COL_RST_RCVD,COL_RST_SENT,COL_RX_PWR,COL_SAT_MODE,COL_SAT_NAME,COL_SFI,COL_SIG,COL_SIG_INFO,COL_SRX,COL_SRX_STRING,COL_STATE,COL_STATION_CALLSIGN,COL_STX,COL_STX_STRING,COL_SWL,COL_TEN_TEN,COL_TIME_OFF,COL_TIME_ON,COL_TX_PWR,COL_WEB,COL_USER_DEFINED_0,COL_USER_DEFINED_1,COL_USER_DEFINED_2,COL_USER_DEFINED_3,COL_USER_DEFINED_4,COL_USER_DEFINED_5,COL_USER_DEFINED_6,COL_USER_DEFINED_7,COL_USER_DEFINED_8,COL_USER_DEFINED_9,COL_CREDIT_GRANTED,COL_CREDIT_SUBMITTED,COL_ISMULTIPLIER,COL_ROVERLOCATION,COL_HRDCOUNTRYNO FROM [TABLE_HRD_CONTACTS_V01]  ORDER BY COL_TIME_ON DESC, COL_CALL DESC
18:12:39  LogbookSearch                       SQL: 
18:12:39  LogbookSearch                       Returned 100 records
18:12:40  ALE Lookup                          Lookup from QRZ.com Online Database for G0OMH timed out
18:12:40  ALE Lookup                          Lookup from QRZ.com Online Database for G0OMH cancelled at 7.609 seconds

18:12:40  CLogbookWndLogbook::SearchCallsign  Callsign  Force 1 All 0
18:12:40  CLogbookWndLogbook::SearchCallsign  Calling
18:12:40  CLogbookWndLogbook::SendRequest     lpszADIF = "CALL" lpszValue = ""
18:12:40  ALE Logbook                         Request DB:: Search for "" in "CALL".
18:12:40  LogbookSearch                       Field = CALL, Value = , Exact = 1, Count = 100
18:12:40  LogbookSearch                       DSN=G7WIR - VHF - Access;DBQ=C:\Users\Martin\AppData\Roaming\HRDLLC\HRD Logbook\G7WIR - VHF.mdb;DriverId=25;FIL=MS Access Open status 1
18:12:40  LogbookSearch                       SQL: SELECT TOP 100 COL_PRIMARY_KEY,COL_ADDRESS,COL_AGE,COL_A_INDEX,COL_ANT_AZ,COL_ANT_EL,COL_ANT_PATH,COL_ARRL_SECT,COL_BAND,COL_BAND_RX,COL_BIOGRAPHY,COL_CALL,COL_CHECK,COL_CLASS,COL_CNTY,COL_COMMENT,COL_CONT,COL_CONTACTED_OP,COL_CONTEST_ID,COL_COUNTRY,COL_CQZ,COL_DISTANCE,COL_DXCC,COL_EMAIL,COL_EQ_CALL,COL_EQSL_QSLRDATE,COL_EQSL_QSLSDATE,COL_EQSL_QSL_RCVD,COL_EQSL_QSL_SENT,COL_EQSL_STATUS,COL_FORCE_INIT,COL_FREQ,COL_FREQ_RX,COL_GRIDSQUARE,COL_HEADING,COL_IOTA,COL_ITUZ,COL_K_INDEX,COL_LAT,COL_LON,COL_LOTW_QSLRDATE,COL_LOTW_QSLSDATE,COL_LOTW_QSL_RCVD,COL_LOTW_QSL_SENT,COL_LOTW_STATUS,COL_MAX_BURSTS,COL_MODE,COL_MS_SHOWER,COL_MY_CITY,COL_MY_CNTY,COL_MY_COUNTRY,COL_MY_CQ_ZONE,COL_MY_GRIDSQUARE,COL_MY_IOTA,COL_MY_ITU_ZONE,COL_MY_LAT,COL_MY_LON,COL_MY_NAME,COL_MY_POSTAL_CODE,COL_MY_RIG,COL_MY_SIG,COL_MY_SIG_INFO,COL_MY_STATE,COL_MY_STREET,COL_NAME,COL_NOTES,COL_NR_BURSTS,COL_NR_PINGS,COL_OPERATOR,COL_OWNER_CALLSIGN,COL_PFX,COL_PRECEDENCE,COL_PROP_MODE,COL_PUBLIC_KEY,COL_QSLMSG,COL_QSLRDATE,COL_QSLSDATE,COL_QSL_RCVD,COL_QSL_RCVD_VIA,COL_QSL_SENT,COL_QSL_SENT_VIA,COL_QSL_VIA,COL_QSO_COMPLETE,COL_QSO_RANDOM,COL_QTH,COL_RIG,COL_RST_RCVD,COL_RST_SENT,COL_RX_PWR,COL_SAT_MODE,COL_SAT_NAME,COL_SFI,COL_SIG,COL_SIG_INFO,COL_SRX,COL_SRX_STRING,COL_STATE,COL_STATION_CALLSIGN,COL_STX,COL_STX_STRING,COL_SWL,COL_TEN_TEN,COL_TIME_OFF,COL_TIME_ON,COL_TX_PWR,COL_WEB,COL_USER_DEFINED_0,COL_USER_DEFINED_1,COL_USER_DEFINED_2,COL_USER_DEFINED_3,COL_USER_DEFINED_4,COL_USER_DEFINED_5,COL_USER_DEFINED_6,COL_USER_DEFINED_7,COL_USER_DEFINED_8,COL_USER_DEFINED_9,COL_CREDIT_GRANTED,COL_CREDIT_SUBMITTED,COL_ISMULTIPLIER,COL_ROVERLOCATION,COL_HRDCOUNTRYNO FROM [TABLE_HRD_CONTACTS_V01]  ORDER BY COL_TIME_ON DESC, COL_CALL DESC
18:12:40  LogbookSearch                       SQL: 
18:12:40  LogbookSearch                       Returned 100 records
18:12:40  HRD Interface                       Error .: Command  = Get Radio
18:12:40  HRD Interface                       Error .: Status   = Not connected
18:12:40  HRD Interface                       Error .: Elapased = 0ms
18:12:40  HRD Interface                       Error .: History (last 0 commands)
18:12:40  HRD Interface                       Error .: Command  = set button-select split 0
18:12:40  HRD Interface                       Error .: Status   = Not connected
18:12:40  HRD Interface                       Error .: Elapased = 0ms
18:12:40  HRD Interface                       Error .: History (last 0 commands)
18:12:40  HRD Interface                       Error .: Command  = set button-select Spl_Off 1
18:12:40  HRD Interface                       Error .: Status   = Not connected
18:12:40  HRD Interface                       Error .: Elapased = 0ms
18:12:40  HRD Interface                       Error .: History (last 0 commands)
18:12:40  HRD Interface                       Error .: Command  = Get Radio
18:12:40  HRD Interface                       Error .: Status   = Not connected
18:12:40  HRD Interface                       Error .: Elapased = 0ms
18:12:40  HRD Interface                       Error .: History (last 0 commands)
18:12:40  HRD Interface                       Error .: Command  = set button-select split 0
18:12:40  HRD Interface                       Error .: Status   = Not connected
18:12:40  HRD Interface                       Error .: Elapased = 0ms
18:12:40  HRD Interface                       Error .: History (last 0 commands)
18:12:40  HRD Interface                       Error .: Command  = set button-select Spl_Off 1
18:12:40  HRD Interface                       Error .: Status   = Not connected
18:12:40  HRD Interface                       Error .: Elapased = 0ms
18:12:40  HRD Interface                       Error .: History (last 0 commands)
18:12:40  WebLog Upload                       Submitted OK
18:12:40  WebLog Upload                       Upload data .: Callsign=G7WIR&Code=416886c811&ADIFData=<QSO_DATE:8>20190203+<TIME_ON:6>181224+<CALL:5>G0OMH+<BAND:4>70cm+<MODE:2>FM+<RST_SENT:2>59+<RST_RCVD:2>59+<STATION_CALLSIGN:5>G7WIR+<GRIDSQUARE:6>JO01bj+<DXCC:3>223+<DISTANCE:8>0.000000+<QSL_SENT:1>N+<QSL_RCVD:1>N+<QSL_SENT_VIA:1>D+<EOR> -
18:12:40  WebLog Upload                       Status ......: 1
18:12:40  QRZ.com Upload                      ADIF record: ACTION=INSERT&ADIF=<QSO_DATE:8>20190203 <TIME_ON:6>181224 <CALL:5>G0OMH <BAND:4>70cm <MODE:2>FM <OPERATOR:5>G7WIR <MY_COUNTRY:7>England <STATION_CALLSIGN:5>G7WIR <RST_RCVD:2>59 <RST_SENT:2>59 <GRIDSQUARE:6>JO01bj <FREQ_RX:8>0.000000 <DISTANCE:8>0.000000 <QSLMSG:0> <EOR>
18:12:40  Clublog Upload                      Uploading QSO
18:12:40  Clublog Upload                       Clublog ADIF record:
18:12:40  ALE Worked                          Refresh: Call="", Country=""

18:12:40  QRZ.com Upload                      Reply from QRZ.com: 
18:12:47  ALE                                 ALE: Cancelling "".
HRD Logbook Logfile 2019-02-03 181809.txt (29,929 bytes)
18:17:21  WorkedStatus                        Select: (COL_BAND = '70cm') AND (COL_MODE = 'FM') AND (COL_CALL = 'G')
18:17:21  WorkedStatus                        Status: 0
                                              
18:17:21  WorkedStatus                        Select: (COL_BAND = '70cm') AND (COL_MODE = 'FM') AND (COL_CALL = 'G0')
18:17:21  WorkedStatus                        Status: 0
                                              
18:17:21  WorkedStatus                        Select: (COL_BAND = '70cm') AND (COL_MODE = 'FM') AND (COL_CALL = 'G0U')
18:17:21  WorkedStatus                        Status: 0
                                              
18:17:22  WorkedStatus                        Select: (COL_BAND = '70cm') AND (COL_MODE = 'FM') AND (COL_CALL = 'G0UJ')
18:17:22  WorkedStatus                        Status: 0
                                              
18:17:22  WorkedStatus                        Select: (COL_BAND = '70cm') AND (COL_MODE = 'FM') AND (COL_CALL = 'G0UJA')
18:17:22  WorkedStatus                        Status: 1
                                              
18:17:23  ALE Worked                          Refresh: Call="G0UJA", Country=""

18:17:23  WorkedStatusEx                      Select: (COL_CALL = 'G0UJA') OR (COL_CALL LIKE '%/G0UJA/%') OR (COL_CALL LIKE '%/G0UJA') OR (COL_CALL LIKE 'G0UJA/%')
18:17:23  WorkedStatusEx                      Bands:  10m,12m,15m,17m,20m,2m,40m,4m,6m,70cm
18:17:24  CLogbookWndLogbook::SearchCallsign  Callsign G0UJA Force 1 All 0
18:17:24  CLogbookWndLogbook::SearchCallsign  Calling
18:17:24  CLogbookWndLogbook::SendRequest     lpszADIF = "CALL" lpszValue = "G0UJA"
18:17:24  ALE Logbook                         Request DB:: Search for "G0UJA" in "CALL".
18:17:24  LogbookSearch                       Field = CALL, Value = G0UJA, Exact = 0, Count = 100
18:17:24  LogbookSearch                       DSN=G7WIR - VHF - Access;DBQ=C:\Users\Martin\AppData\Roaming\HRDLLC\HRD Logbook\G7WIR - VHF.mdb;DriverId=25;FIL=MS Access Open status 1
18:17:24  LogbookSearch                       SQL: SELECT TOP 100 COL_PRIMARY_KEY,COL_ADDRESS,COL_AGE,COL_A_INDEX,COL_ANT_AZ,COL_ANT_EL,COL_ANT_PATH,COL_ARRL_SECT,COL_BAND,COL_BAND_RX,COL_BIOGRAPHY,COL_CALL,COL_CHECK,COL_CLASS,COL_CNTY,COL_COMMENT,COL_CONT,COL_CONTACTED_OP,COL_CONTEST_ID,COL_COUNTRY,COL_CQZ,COL_DISTANCE,COL_DXCC,COL_EMAIL,COL_EQ_CALL,COL_EQSL_QSLRDATE,COL_EQSL_QSLSDATE,COL_EQSL_QSL_RCVD,COL_EQSL_QSL_SENT,COL_EQSL_STATUS,COL_FORCE_INIT,COL_FREQ,COL_FREQ_RX,COL_GRIDSQUARE,COL_HEADING,COL_IOTA,COL_ITUZ,COL_K_INDEX,COL_LAT,COL_LON,COL_LOTW_QSLRDATE,COL_LOTW_QSLSDATE,COL_LOTW_QSL_RCVD,COL_LOTW_QSL_SENT,COL_LOTW_STATUS,COL_MAX_BURSTS,COL_MODE,COL_MS_SHOWER,COL_MY_CITY,COL_MY_CNTY,COL_MY_COUNTRY,COL_MY_CQ_ZONE,COL_MY_GRIDSQUARE,COL_MY_IOTA,COL_MY_ITU_ZONE,COL_MY_LAT,COL_MY_LON,COL_MY_NAME,COL_MY_POSTAL_CODE,COL_MY_RIG,COL_MY_SIG,COL_MY_SIG_INFO,COL_MY_STATE,COL_MY_STREET,COL_NAME,COL_NOTES,COL_NR_BURSTS,COL_NR_PINGS,COL_OPERATOR,COL_OWNER_CALLSIGN,COL_PFX,COL_PRECEDENCE,COL_PROP_MODE,COL_PUBLIC_KEY,COL_QSLMSG,COL_QSLRDATE,COL_QSLSDATE,COL_QSL_RCVD,COL_QSL_RCVD_VIA,COL_QSL_SENT,COL_QSL_SENT_VIA,COL_QSL_VIA,COL_QSO_COMPLETE,COL_QSO_RANDOM,COL_QTH,COL_RIG,COL_RST_RCVD,COL_RST_SENT,COL_RX_PWR,COL_SAT_MODE,COL_SAT_NAME,COL_SFI,COL_SIG,COL_SIG_INFO,COL_SRX,COL_SRX_STRING,COL_STATE,COL_STATION_CALLSIGN,COL_STX,COL_STX_STRING,COL_SWL,COL_TEN_TEN,COL_TIME_OFF,COL_TIME_ON,COL_TX_PWR,COL_WEB,COL_USER_DEFINED_0,COL_USER_DEFINED_1,COL_USER_DEFINED_2,COL_USER_DEFINED_3,COL_USER_DEFINED_4,COL_USER_DEFINED_5,COL_USER_DEFINED_6,COL_USER_DEFINED_7,COL_USER_DEFINED_8,COL_USER_DEFINED_9,COL_CREDIT_GRANTED,COL_CREDIT_SUBMITTED,COL_ISMULTIPLIER,COL_ROVERLOCATION,COL_HRDCOUNTRYNO FROM [TABLE_HRD_CONTACTS_V01] WHERE (COL_CALL LIKE '%G0UJA%') ORDER BY COL_TIME_ON DESC, COL_CALL DESC
18:17:24  LogbookSearch                       SQL: WHERE (COL_CALL LIKE '%G0UJA%')
18:17:24  LogbookSearch                       Returned 100 records
18:17:25  ALE Lookup                          Lookup from Previous Logbook Entry for G0UJA completed in 0.375 seconds

18:17:25  ALE Lookup                          Lookup from QRZ.com Online Database: G0UJA
18:17:25  ALE Lookup                          Lookup from QRZ.com Online Database for G0UJA completed in 0.063 seconds

18:17:25  ALE Lookup                          Lookup from Country Index for G0UJA completed in 0.000 seconds

18:17:25  CLogbookWndLogbook::SearchCallsign  Callsign G0UJA Force 1 All 0
18:17:25  CLogbookWndLogbook::SearchCallsign  Calling
18:17:25  CLogbookWndLogbook::SendRequest     lpszADIF = "CALL" lpszValue = "G0UJA"
18:17:25  ALE Logbook                         Request DB:: Search for "G0UJA" in "CALL".
18:17:25  LogbookSearch                       Field = CALL, Value = G0UJA, Exact = 1, Count = 100
18:17:25  LogbookSearch                       DSN=G7WIR - VHF - Access;DBQ=C:\Users\Martin\AppData\Roaming\HRDLLC\HRD Logbook\G7WIR - VHF.mdb;DriverId=25;FIL=MS Access Open status 1
18:17:25  LogbookSearch                       SQL: SELECT TOP 100 COL_PRIMARY_KEY,COL_ADDRESS,COL_AGE,COL_A_INDEX,COL_ANT_AZ,COL_ANT_EL,COL_ANT_PATH,COL_ARRL_SECT,COL_BAND,COL_BAND_RX,COL_BIOGRAPHY,COL_CALL,COL_CHECK,COL_CLASS,COL_CNTY,COL_COMMENT,COL_CONT,COL_CONTACTED_OP,COL_CONTEST_ID,COL_COUNTRY,COL_CQZ,COL_DISTANCE,COL_DXCC,COL_EMAIL,COL_EQ_CALL,COL_EQSL_QSLRDATE,COL_EQSL_QSLSDATE,COL_EQSL_QSL_RCVD,COL_EQSL_QSL_SENT,COL_EQSL_STATUS,COL_FORCE_INIT,COL_FREQ,COL_FREQ_RX,COL_GRIDSQUARE,COL_HEADING,COL_IOTA,COL_ITUZ,COL_K_INDEX,COL_LAT,COL_LON,COL_LOTW_QSLRDATE,COL_LOTW_QSLSDATE,COL_LOTW_QSL_RCVD,COL_LOTW_QSL_SENT,COL_LOTW_STATUS,COL_MAX_BURSTS,COL_MODE,COL_MS_SHOWER,COL_MY_CITY,COL_MY_CNTY,COL_MY_COUNTRY,COL_MY_CQ_ZONE,COL_MY_GRIDSQUARE,COL_MY_IOTA,COL_MY_ITU_ZONE,COL_MY_LAT,COL_MY_LON,COL_MY_NAME,COL_MY_POSTAL_CODE,COL_MY_RIG,COL_MY_SIG,COL_MY_SIG_INFO,COL_MY_STATE,COL_MY_STREET,COL_NAME,COL_NOTES,COL_NR_BURSTS,COL_NR_PINGS,COL_OPERATOR,COL_OWNER_CALLSIGN,COL_PFX,COL_PRECEDENCE,COL_PROP_MODE,COL_PUBLIC_KEY,COL_QSLMSG,COL_QSLRDATE,COL_QSLSDATE,COL_QSL_RCVD,COL_QSL_RCVD_VIA,COL_QSL_SENT,COL_QSL_SENT_VIA,COL_QSL_VIA,COL_QSO_COMPLETE,COL_QSO_RANDOM,COL_QTH,COL_RIG,COL_RST_RCVD,COL_RST_SENT,COL_RX_PWR,COL_SAT_MODE,COL_SAT_NAME,COL_SFI,COL_SIG,COL_SIG_INFO,COL_SRX,COL_SRX_STRING,COL_STATE,COL_STATION_CALLSIGN,COL_STX,COL_STX_STRING,COL_SWL,COL_TEN_TEN,COL_TIME_OFF,COL_TIME_ON,COL_TX_PWR,COL_WEB,COL_USER_DEFINED_0,COL_USER_DEFINED_1,COL_USER_DEFINED_2,COL_USER_DEFINED_3,COL_USER_DEFINED_4,COL_USER_DEFINED_5,COL_USER_DEFINED_6,COL_USER_DEFINED_7,COL_USER_DEFINED_8,COL_USER_DEFINED_9,COL_CREDIT_GRANTED,COL_CREDIT_SUBMITTED,COL_ISMULTIPLIER,COL_ROVERLOCATION,COL_HRDCOUNTRYNO FROM [TABLE_HRD_CONTACTS_V01] WHERE (COL_CALL = 'G0UJA') ORDER BY COL_TIME_ON DESC, COL_CALL DESC
18:17:25  LogbookSearch                       SQL: WHERE (COL_CALL = 'G0UJA')
18:17:25  LogbookSearch                       Returned 100 records
18:17:29  ALE                                 Adding Entry "G0UJA" to Logbook.
18:17:30  Add                                 Opening database G7WIR - VHF - Access
18:17:30  Add                                 Open status 1
18:17:30  Add                                 Opening table TABLE_HRD_CONTACTS_V01
18:17:30  ALE                                 Reset.
18:17:30  ALE                                 Reset.
18:17:30  WorkedStatus                        Select: (COL_BAND = '70cm') AND (COL_MODE = 'FM') AND (COL_DXCC = '223')
18:17:30  WorkedStatus                        Status: 1
                                              
18:17:31  CLogbookWndLogbook::Refresh         All 0 Field CALL Value G0UJA
18:17:31  CLogbookWndLogbook::SendRequest     lpszADIF = "CALL" lpszValue = ""
18:17:31  ALE Logbook                         Request DB:: Search for "" in "CALL".
18:17:31  LogbookSearch                       Field = CALL, Value = , Exact = 1, Count = 100
18:17:31  LogbookSearch                       DSN=G7WIR - VHF - Access;DBQ=C:\Users\Martin\AppData\Roaming\HRDLLC\HRD Logbook\G7WIR - VHF.mdb;DriverId=25;FIL=MS Access Open status 1
18:17:31  LogbookSearch                       SQL: SELECT TOP 100 COL_PRIMARY_KEY,COL_ADDRESS,COL_AGE,COL_A_INDEX,COL_ANT_AZ,COL_ANT_EL,COL_ANT_PATH,COL_ARRL_SECT,COL_BAND,COL_BAND_RX,COL_BIOGRAPHY,COL_CALL,COL_CHECK,COL_CLASS,COL_CNTY,COL_COMMENT,COL_CONT,COL_CONTACTED_OP,COL_CONTEST_ID,COL_COUNTRY,COL_CQZ,COL_DISTANCE,COL_DXCC,COL_EMAIL,COL_EQ_CALL,COL_EQSL_QSLRDATE,COL_EQSL_QSLSDATE,COL_EQSL_QSL_RCVD,COL_EQSL_QSL_SENT,COL_EQSL_STATUS,COL_FORCE_INIT,COL_FREQ,COL_FREQ_RX,COL_GRIDSQUARE,COL_HEADING,COL_IOTA,COL_ITUZ,COL_K_INDEX,COL_LAT,COL_LON,COL_LOTW_QSLRDATE,COL_LOTW_QSLSDATE,COL_LOTW_QSL_RCVD,COL_LOTW_QSL_SENT,COL_LOTW_STATUS,COL_MAX_BURSTS,COL_MODE,COL_MS_SHOWER,COL_MY_CITY,COL_MY_CNTY,COL_MY_COUNTRY,COL_MY_CQ_ZONE,COL_MY_GRIDSQUARE,COL_MY_IOTA,COL_MY_ITU_ZONE,COL_MY_LAT,COL_MY_LON,COL_MY_NAME,COL_MY_POSTAL_CODE,COL_MY_RIG,COL_MY_SIG,COL_MY_SIG_INFO,COL_MY_STATE,COL_MY_STREET,COL_NAME,COL_NOTES,COL_NR_BURSTS,COL_NR_PINGS,COL_OPERATOR,COL_OWNER_CALLSIGN,COL_PFX,COL_PRECEDENCE,COL_PROP_MODE,COL_PUBLIC_KEY,COL_QSLMSG,COL_QSLRDATE,COL_QSLSDATE,COL_QSL_RCVD,COL_QSL_RCVD_VIA,COL_QSL_SENT,COL_QSL_SENT_VIA,COL_QSL_VIA,COL_QSO_COMPLETE,COL_QSO_RANDOM,COL_QTH,COL_RIG,COL_RST_RCVD,COL_RST_SENT,COL_RX_PWR,COL_SAT_MODE,COL_SAT_NAME,COL_SFI,COL_SIG,COL_SIG_INFO,COL_SRX,COL_SRX_STRING,COL_STATE,COL_STATION_CALLSIGN,COL_STX,COL_STX_STRING,COL_SWL,COL_TEN_TEN,COL_TIME_OFF,COL_TIME_ON,COL_TX_PWR,COL_WEB,COL_USER_DEFINED_0,COL_USER_DEFINED_1,COL_USER_DEFINED_2,COL_USER_DEFINED_3,COL_USER_DEFINED_4,COL_USER_DEFINED_5,COL_USER_DEFINED_6,COL_USER_DEFINED_7,COL_USER_DEFINED_8,COL_USER_DEFINED_9,COL_CREDIT_GRANTED,COL_CREDIT_SUBMITTED,COL_ISMULTIPLIER,COL_ROVERLOCATION,COL_HRDCOUNTRYNO FROM [TABLE_HRD_CONTACTS_V01]  ORDER BY COL_TIME_ON DESC, COL_CALL DESC
18:17:31  LogbookSearch                       SQL: 
18:17:31  LogbookSearch                       Returned 100 records
18:17:31  HRD Interface                       Error .: Command  = Get Radio
18:17:31  HRD Interface                       Error .: Status   = Not connected
18:17:31  HRD Interface                       Error .: Elapased = 0ms
18:17:31  HRD Interface                       Error .: History (last 0 commands)
18:17:31  HRD Interface                       Error .: Command  = set button-select split 0
18:17:31  HRD Interface                       Error .: Status   = Not connected
18:17:31  HRD Interface                       Error .: Elapased = 0ms
18:17:31  HRD Interface                       Error .: History (last 0 commands)
18:17:31  HRD Interface                       Error .: Command  = set button-select Spl_Off 1
18:17:31  HRD Interface                       Error .: Status   = Not connected
18:17:31  HRD Interface                       Error .: Elapased = 0ms
18:17:31  HRD Interface                       Error .: History (last 0 commands)
18:17:31  Backup                              G7WIR - VHF - Access: Saving...
18:17:31  Backup                              G7WIR - VHF - Access: Database       = G7WIR - VHF
18:17:31  Backup                              G7WIR - VHF - Access: Database type  = ACCESS
18:17:31  Backup                              G7WIR - VHF - Access: Connect string = DSN=G7WIR - VHF - Access;DBQ=C:\Users\Martin\AppData\Roaming\HRDLLC\HRD Logbook\G7WIR - VHF.mdb;DriverId=25;FIL=MS Access
18:17:31  Backup                              G7WIR - VHF - Access: Opening        = G7WIR - VHF
18:17:31  Backup                              G7WIR - VHF - Access: Database type  = ACCESS
18:17:31  Backup                              G7WIR - VHF - Access: Connect string = DSN=G7WIR - VHF - Access;DBQ=C:\Users\Martin\AppData\Roaming\HRDLLC\HRD Logbook\G7WIR - VHF.mdb;DriverId=25;FIL=MS Access
18:17:31  Backup                              G7WIR - VHF - Access: Options        = 0000000C
18:17:31  Backup                              Open status 1
18:17:31  Backup                              Table TABLE_HRD_CONTACTS_V01 contains 1073 records
18:17:31  Backup                              Opening table TABLE_HRD_CONTACTS_V01
18:17:31  HRD Interface                       Error .: Command  = Get Radio
18:17:31  HRD Interface                       Error .: Status   = Not connected
18:17:31  HRD Interface                       Error .: Elapased = 0ms
18:17:31  HRD Interface                       Error .: History (last 0 commands)
18:17:31  HRD Interface                       Error .: Command  = set button-select split 0
18:17:31  HRD Interface                       Error .: Status   = Not connected
18:17:31  HRD Interface                       Error .: Elapased = 0ms
18:17:31  HRD Interface                       Error .: History (last 0 commands)
18:17:31  HRD Interface                       Error .: Command  = set button-select Spl_Off 1
18:17:31  HRD Interface                       Error .: Status   = Not connected
18:17:31  HRD Interface                       Error .: Elapased = 0ms
18:17:31  HRD Interface                       Error .: History (last 0 commands)
18:17:31  WebLog Upload                       Submitted OK
18:17:31  WebLog Upload                       Upload data .: Callsign=G7WIR&Code=416886c811&ADIFData=<QSO_DATE:8>20190203+<TIME_ON:6>181725+<CALL:5>G0UJA+<BAND:4>70cm+<MODE:2>FM+<RST_SENT:2>59+<RST_RCVD:2>59+<STATION_CALLSIGN:5>G7WIR+<GRIDSQUARE:6>JO01aj+<DXCC:3>223+<DISTANCE:8>3.056144+<QSL_SENT:1>N+<QSL_RCVD:1>N+<QSL_SENT_VIA:1>D+<EOR> -
18:17:31  WebLog Upload                       Status ......: 1
18:17:31  QRZ.com Upload                      ADIF record: ACTION=INSERT&ADIF=<QSO_DATE:8>20190203 <TIME_ON:6>181725 <CALL:5>G0UJA <BAND:4>70cm <MODE:2>FM <OPERATOR:5>G7WIR <MY_COUNTRY:7>England <STATION_CALLSIGN:5>G7WIR <RST_RCVD:2>59 <RST_SENT:2>59 <GRIDSQUARE:6>JO01aj <FREQ_RX:8>0.000000 <DISTANCE:8>3.056144 <QSLMSG:0> <EOR>
18:17:31  HRD Interface                       Error .: Command  = Get Radio
18:17:31  HRD Interface                       Error .: Status   = Not connected
18:17:31  HRD Interface                       Error .: Elapased = 0ms
18:17:31  HRD Interface                       Error .: History (last 0 commands)
18:17:31  HRD Interface                       Error .: Command  = set button-select split 0
18:17:31  HRD Interface                       Error .: Status   = Not connected
18:17:31  HRD Interface                       Error .: Elapased = 0ms
18:17:31  HRD Interface                       Error .: History (last 0 commands)
18:17:31  Backup                              G7WIR - VHF - Access: Created  "D:\- HAM RADIO -\- LOGBOOK ADI FILES -\Logbook Backup\G7WIR - VHF backup 2019-02-03 1817.xml"
18:17:31  Backup                              G7WIR - VHF - Access: Archiving "C:\Users\Martin\AppData\Roaming\HRDLLC\HRD Logbook\LogbookBackups.zip"
18:17:31  Backup                              G7WIR - VHF - Access: Finished
18:17:31  HRD Interface                       Error .: Command  = set button-select Spl_Off 1
18:17:31  HRD Interface                       Error .: Status   = Not connected
18:17:31  HRD Interface                       Error .: Elapased = 0ms
18:17:31  HRD Interface                       Error .: History (last 0 commands)
18:17:31  ALE Worked                          Refresh: Call="", Country=""

18:17:31  Clublog Upload                      Uploading QSO
18:17:31  Clublog Upload                       Clublog ADIF record:
18:17:31  QRZ.com Upload                      Reply from QRZ.com: 
18:17:42  WorkedStatus                        Select: (COL_BAND = '70cm') AND (COL_MODE = 'FM') AND (COL_CALL = 'G')
18:17:42  WorkedStatus                        Status: 0
                                              
18:17:42  WorkedStatus                        Select: (COL_BAND = '70cm') AND (COL_MODE = 'FM') AND (COL_CALL = 'G0')
18:17:42  WorkedStatus                        Status: 0
                                              
18:17:42  WorkedStatus                        Select: (COL_BAND = '70cm') AND (COL_MODE = 'FM') AND (COL_CALL = 'G0O')
18:17:42  WorkedStatus                        Status: 0
                                              
18:17:43  ALE Worked                          Refresh: Call="G0O", Country=""

18:17:43  WorkedStatusEx                      Select: (COL_CALL = 'G0O') OR (COL_CALL LIKE '%/G0O/%') OR (COL_CALL LIKE '%/G0O') OR (COL_CALL LIKE 'G0O/%')
18:17:43  WorkedStatusEx                      Bands:  
18:17:43  WorkedStatus                        Select: (COL_BAND = '70cm') AND (COL_MODE = 'FM') AND (COL_CALL = 'G0OM')
18:17:43  WorkedStatus                        Status: 0
                                              
18:17:43  WorkedStatus                        Select: (COL_BAND = '70cm') AND (COL_MODE = 'FM') AND (COL_CALL = 'G0OMH')
18:17:43  WorkedStatus                        Status: 1
                                              
18:17:45  ALE Worked                          Refresh: Call="G0OMH", Country=""

18:17:45  WorkedStatusEx                      Select: (COL_CALL = 'G0OMH') OR (COL_CALL LIKE '%/G0OMH/%') OR (COL_CALL LIKE '%/G0OMH') OR (COL_CALL LIKE 'G0OMH/%')
18:17:45  WorkedStatusEx                      Bands:  10m,12m,15m,17m,20m,2m,40m,4m,6m,70cm,80m
18:17:45  CLogbookWndLogbook::SearchCallsign  Callsign G0OMH Force 1 All 0
18:17:45  CLogbookWndLogbook::SearchCallsign  Calling
18:17:45  CLogbookWndLogbook::SendRequest     lpszADIF = "CALL" lpszValue = "G0OMH"
18:17:45  ALE Logbook                         Request DB:: Search for "G0OMH" in "CALL".
18:17:45  LogbookSearch                       Field = CALL, Value = G0OMH, Exact = 0, Count = 100
18:17:45  LogbookSearch                       DSN=G7WIR - VHF - Access;DBQ=C:\Users\Martin\AppData\Roaming\HRDLLC\HRD Logbook\G7WIR - VHF.mdb;DriverId=25;FIL=MS Access Open status 1
18:17:45  LogbookSearch                       SQL: SELECT TOP 100 COL_PRIMARY_KEY,COL_ADDRESS,COL_AGE,COL_A_INDEX,COL_ANT_AZ,COL_ANT_EL,COL_ANT_PATH,COL_ARRL_SECT,COL_BAND,COL_BAND_RX,COL_BIOGRAPHY,COL_CALL,COL_CHECK,COL_CLASS,COL_CNTY,COL_COMMENT,COL_CONT,COL_CONTACTED_OP,COL_CONTEST_ID,COL_COUNTRY,COL_CQZ,COL_DISTANCE,COL_DXCC,COL_EMAIL,COL_EQ_CALL,COL_EQSL_QSLRDATE,COL_EQSL_QSLSDATE,COL_EQSL_QSL_RCVD,COL_EQSL_QSL_SENT,COL_EQSL_STATUS,COL_FORCE_INIT,COL_FREQ,COL_FREQ_RX,COL_GRIDSQUARE,COL_HEADING,COL_IOTA,COL_ITUZ,COL_K_INDEX,COL_LAT,COL_LON,COL_LOTW_QSLRDATE,COL_LOTW_QSLSDATE,COL_LOTW_QSL_RCVD,COL_LOTW_QSL_SENT,COL_LOTW_STATUS,COL_MAX_BURSTS,COL_MODE,COL_MS_SHOWER,COL_MY_CITY,COL_MY_CNTY,COL_MY_COUNTRY,COL_MY_CQ_ZONE,COL_MY_GRIDSQUARE,COL_MY_IOTA,COL_MY_ITU_ZONE,COL_MY_LAT,COL_MY_LON,COL_MY_NAME,COL_MY_POSTAL_CODE,COL_MY_RIG,COL_MY_SIG,COL_MY_SIG_INFO,COL_MY_STATE,COL_MY_STREET,COL_NAME,COL_NOTES,COL_NR_BURSTS,COL_NR_PINGS,COL_OPERATOR,COL_OWNER_CALLSIGN,COL_PFX,COL_PRECEDENCE,COL_PROP_MODE,COL_PUBLIC_KEY,COL_QSLMSG,COL_QSLRDATE,COL_QSLSDATE,COL_QSL_RCVD,COL_QSL_RCVD_VIA,COL_QSL_SENT,COL_QSL_SENT_VIA,COL_QSL_VIA,COL_QSO_COMPLETE,COL_QSO_RANDOM,COL_QTH,COL_RIG,COL_RST_RCVD,COL_RST_SENT,COL_RX_PWR,COL_SAT_MODE,COL_SAT_NAME,COL_SFI,COL_SIG,COL_SIG_INFO,COL_SRX,COL_SRX_STRING,COL_STATE,COL_STATION_CALLSIGN,COL_STX,COL_STX_STRING,COL_SWL,COL_TEN_TEN,COL_TIME_OFF,COL_TIME_ON,COL_TX_PWR,COL_WEB,COL_USER_DEFINED_0,COL_USER_DEFINED_1,COL_USER_DEFINED_2,COL_USER_DEFINED_3,COL_USER_DEFINED_4,COL_USER_DEFINED_5,COL_USER_DEFINED_6,COL_USER_DEFINED_7,COL_USER_DEFINED_8,COL_USER_DEFINED_9,COL_CREDIT_GRANTED,COL_CREDIT_SUBMITTED,COL_ISMULTIPLIER,COL_ROVERLOCATION,COL_HRDCOUNTRYNO FROM [TABLE_HRD_CONTACTS_V01] WHERE (COL_CALL LIKE '%G0OMH%') ORDER BY COL_TIME_ON DESC, COL_CALL DESC
18:17:45  LogbookSearch                       SQL: WHERE (COL_CALL LIKE '%G0OMH%')
18:17:45  LogbookSearch                       Returned 100 records
18:17:45  ALE Lookup                          Lookup from Previous Logbook Entry for G0OMH completed in 0.328 seconds

18:17:45  ALE Lookup                          Lookup from QRZ.com Online Database: G0OMH
18:17:45  ALE Lookup                          Lookup from QRZ.com Online Database for G0OMH completed in 0.078 seconds

18:17:45  ALE Lookup                          Lookup from Country Index for G0OMH completed in 0.000 seconds

18:17:45  CLogbookWndLogbook::SearchCallsign  Callsign G0OMH Force 1 All 0
18:17:45  CLogbookWndLogbook::SearchCallsign  Calling
18:17:45  CLogbookWndLogbook::SendRequest     lpszADIF = "CALL" lpszValue = "G0OMH"
18:17:45  ALE Logbook                         Request DB:: Search for "G0OMH" in "CALL".
18:17:45  LogbookSearch                       Field = CALL, Value = G0OMH, Exact = 1, Count = 100
18:17:45  LogbookSearch                       DSN=G7WIR - VHF - Access;DBQ=C:\Users\Martin\AppData\Roaming\HRDLLC\HRD Logbook\G7WIR - VHF.mdb;DriverId=25;FIL=MS Access Open status 1
18:17:45  LogbookSearch                       SQL: SELECT TOP 100 COL_PRIMARY_KEY,COL_ADDRESS,COL_AGE,COL_A_INDEX,COL_ANT_AZ,COL_ANT_EL,COL_ANT_PATH,COL_ARRL_SECT,COL_BAND,COL_BAND_RX,COL_BIOGRAPHY,COL_CALL,COL_CHECK,COL_CLASS,COL_CNTY,COL_COMMENT,COL_CONT,COL_CONTACTED_OP,COL_CONTEST_ID,COL_COUNTRY,COL_CQZ,COL_DISTANCE,COL_DXCC,COL_EMAIL,COL_EQ_CALL,COL_EQSL_QSLRDATE,COL_EQSL_QSLSDATE,COL_EQSL_QSL_RCVD,COL_EQSL_QSL_SENT,COL_EQSL_STATUS,COL_FORCE_INIT,COL_FREQ,COL_FREQ_RX,COL_GRIDSQUARE,COL_HEADING,COL_IOTA,COL_ITUZ,COL_K_INDEX,COL_LAT,COL_LON,COL_LOTW_QSLRDATE,COL_LOTW_QSLSDATE,COL_LOTW_QSL_RCVD,COL_LOTW_QSL_SENT,COL_LOTW_STATUS,COL_MAX_BURSTS,COL_MODE,COL_MS_SHOWER,COL_MY_CITY,COL_MY_CNTY,COL_MY_COUNTRY,COL_MY_CQ_ZONE,COL_MY_GRIDSQUARE,COL_MY_IOTA,COL_MY_ITU_ZONE,COL_MY_LAT,COL_MY_LON,COL_MY_NAME,COL_MY_POSTAL_CODE,COL_MY_RIG,COL_MY_SIG,COL_MY_SIG_INFO,COL_MY_STATE,COL_MY_STREET,COL_NAME,COL_NOTES,COL_NR_BURSTS,COL_NR_PINGS,COL_OPERATOR,COL_OWNER_CALLSIGN,COL_PFX,COL_PRECEDENCE,COL_PROP_MODE,COL_PUBLIC_KEY,COL_QSLMSG,COL_QSLRDATE,COL_QSLSDATE,COL_QSL_RCVD,COL_QSL_RCVD_VIA,COL_QSL_SENT,COL_QSL_SENT_VIA,COL_QSL_VIA,COL_QSO_COMPLETE,COL_QSO_RANDOM,COL_QTH,COL_RIG,COL_RST_RCVD,COL_RST_SENT,COL_RX_PWR,COL_SAT_MODE,COL_SAT_NAME,COL_SFI,COL_SIG,COL_SIG_INFO,COL_SRX,COL_SRX_STRING,COL_STATE,COL_STATION_CALLSIGN,COL_STX,COL_STX_STRING,COL_SWL,COL_TEN_TEN,COL_TIME_OFF,COL_TIME_ON,COL_TX_PWR,COL_WEB,COL_USER_DEFINED_0,COL_USER_DEFINED_1,COL_USER_DEFINED_2,COL_USER_DEFINED_3,COL_USER_DEFINED_4,COL_USER_DEFINED_5,COL_USER_DEFINED_6,COL_USER_DEFINED_7,COL_USER_DEFINED_8,COL_USER_DEFINED_9,COL_CREDIT_GRANTED,COL_CREDIT_SUBMITTED,COL_ISMULTIPLIER,COL_ROVERLOCATION,COL_HRDCOUNTRYNO FROM [TABLE_HRD_CONTACTS_V01] WHERE (COL_CALL = 'G0OMH') ORDER BY COL_TIME_ON DESC, COL_CALL DESC
18:17:45  LogbookSearch                       SQL: WHERE (COL_CALL = 'G0OMH')
18:17:46  LogbookSearch                       Returned 100 records
18:17:48  ALE                                 Adding Entry "G0OMH" to Logbook.
18:17:48  Add                                 Opening database G7WIR - VHF - Access
18:17:49  Add                                 Open status 1
18:17:49  Add                                 Opening table TABLE_HRD_CONTACTS_V01
18:17:49  ALE                                 Reset.
18:17:49  ALE                                 Reset.
18:17:49  WorkedStatus                        Select: (COL_BAND = '70cm') AND (COL_MODE = 'FM') AND (COL_DXCC = '223')
18:17:49  WorkedStatus                        Status: 1
                                              
18:17:49  CLogbookWndLogbook::Refresh         All 0 Field CALL Value G0OMH
18:17:49  CLogbookWndLogbook::SendRequest     lpszADIF = "CALL" lpszValue = ""
18:17:49  ALE Logbook                         Request DB:: Search for "" in "CALL".
18:17:49  LogbookSearch                       Field = CALL, Value = , Exact = 1, Count = 100
18:17:49  LogbookSearch                       DSN=G7WIR - VHF - Access;DBQ=C:\Users\Martin\AppData\Roaming\HRDLLC\HRD Logbook\G7WIR - VHF.mdb;DriverId=25;FIL=MS Access Open status 1
18:17:49  LogbookSearch                       SQL: SELECT TOP 100 COL_PRIMARY_KEY,COL_ADDRESS,COL_AGE,COL_A_INDEX,COL_ANT_AZ,COL_ANT_EL,COL_ANT_PATH,COL_ARRL_SECT,COL_BAND,COL_BAND_RX,COL_BIOGRAPHY,COL_CALL,COL_CHECK,COL_CLASS,COL_CNTY,COL_COMMENT,COL_CONT,COL_CONTACTED_OP,COL_CONTEST_ID,COL_COUNTRY,COL_CQZ,COL_DISTANCE,COL_DXCC,COL_EMAIL,COL_EQ_CALL,COL_EQSL_QSLRDATE,COL_EQSL_QSLSDATE,COL_EQSL_QSL_RCVD,COL_EQSL_QSL_SENT,COL_EQSL_STATUS,COL_FORCE_INIT,COL_FREQ,COL_FREQ_RX,COL_GRIDSQUARE,COL_HEADING,COL_IOTA,COL_ITUZ,COL_K_INDEX,COL_LAT,COL_LON,COL_LOTW_QSLRDATE,COL_LOTW_QSLSDATE,COL_LOTW_QSL_RCVD,COL_LOTW_QSL_SENT,COL_LOTW_STATUS,COL_MAX_BURSTS,COL_MODE,COL_MS_SHOWER,COL_MY_CITY,COL_MY_CNTY,COL_MY_COUNTRY,COL_MY_CQ_ZONE,COL_MY_GRIDSQUARE,COL_MY_IOTA,COL_MY_ITU_ZONE,COL_MY_LAT,COL_MY_LON,COL_MY_NAME,COL_MY_POSTAL_CODE,COL_MY_RIG,COL_MY_SIG,COL_MY_SIG_INFO,COL_MY_STATE,COL_MY_STREET,COL_NAME,COL_NOTES,COL_NR_BURSTS,COL_NR_PINGS,COL_OPERATOR,COL_OWNER_CALLSIGN,COL_PFX,COL_PRECEDENCE,COL_PROP_MODE,COL_PUBLIC_KEY,COL_QSLMSG,COL_QSLRDATE,COL_QSLSDATE,COL_QSL_RCVD,COL_QSL_RCVD_VIA,COL_QSL_SENT,COL_QSL_SENT_VIA,COL_QSL_VIA,COL_QSO_COMPLETE,COL_QSO_RANDOM,COL_QTH,COL_RIG,COL_RST_RCVD,COL_RST_SENT,COL_RX_PWR,COL_SAT_MODE,COL_SAT_NAME,COL_SFI,COL_SIG,COL_SIG_INFO,COL_SRX,COL_SRX_STRING,COL_STATE,COL_STATION_CALLSIGN,COL_STX,COL_STX_STRING,COL_SWL,COL_TEN_TEN,COL_TIME_OFF,COL_TIME_ON,COL_TX_PWR,COL_WEB,COL_USER_DEFINED_0,COL_USER_DEFINED_1,COL_USER_DEFINED_2,COL_USER_DEFINED_3,COL_USER_DEFINED_4,COL_USER_DEFINED_5,COL_USER_DEFINED_6,COL_USER_DEFINED_7,COL_USER_DEFINED_8,COL_USER_DEFINED_9,COL_CREDIT_GRANTED,COL_CREDIT_SUBMITTED,COL_ISMULTIPLIER,COL_ROVERLOCATION,COL_HRDCOUNTRYNO FROM [TABLE_HRD_CONTACTS_V01]  ORDER BY COL_TIME_ON DESC, COL_CALL DESC
18:17:49  LogbookSearch                       SQL: 
18:17:50  LogbookSearch                       Returned 100 records
18:17:50  HRD Interface                       Error .: Command  = Get Radio
18:17:50  HRD Interface                       Error .: Status   = Not connected
18:17:50  HRD Interface                       Error .: Elapased = 0ms
18:17:50  HRD Interface                       Error .: History (last 0 commands)
18:17:50  HRD Interface                       Error .: Command  = set button-select split 0
18:17:50  HRD Interface                       Error .: Status   = Not connected
18:17:50  HRD Interface                       Error .: Elapased = 0ms
18:17:50  HRD Interface                       Error .: History (last 0 commands)
18:17:50  HRD Interface                       Error .: Command  = set button-select Spl_Off 1
18:17:50  HRD Interface                       Error .: Status   = Not connected
18:17:50  HRD Interface                       Error .: Elapased = 0ms
18:17:50  HRD Interface                       Error .: History (last 0 commands)
18:17:50  HRD Interface                       Error .: Command  = Get Radio
18:17:50  HRD Interface                       Error .: Status   = Not connected
18:17:50  HRD Interface                       Error .: Elapased = 0ms
18:17:50  HRD Interface                       Error .: History (last 0 commands)
18:17:50  HRD Interface                       Error .: Command  = set button-select split 0
18:17:50  HRD Interface                       Error .: Status   = Not connected
18:17:50  HRD Interface                       Error .: Elapased = 0ms
18:17:50  HRD Interface                       Error .: History (last 0 commands)
18:17:50  HRD Interface                       Error .: Command  = set button-select Spl_Off 1
18:17:50  HRD Interface                       Error .: Status   = Not connected
18:17:50  HRD Interface                       Error .: Elapased = 0ms
18:17:50  HRD Interface                       Error .: History (last 0 commands)
18:17:50  WebLog Upload                       Submitted OK
18:17:50  WebLog Upload                       Upload data .: Callsign=G7WIR&Code=416886c811&ADIFData=<QSO_DATE:8>20190203+<TIME_ON:6>181745+<CALL:5>G0OMH+<BAND:4>70cm+<MODE:2>FM+<RST_SENT:2>59+<RST_RCVD:2>59+<STATION_CALLSIGN:5>G7WIR+<GRIDSQUARE:6>JO01bj+<DXCC:3>223+<DISTANCE:8>1.242414+<QSL_SENT:1>N+<QSL_RCVD:1>N+<QSL_SENT_VIA:1>D+<EOR> -
18:17:50  WebLog Upload                       Status ......: 1
18:17:50  QRZ.com Upload                      ADIF record: ACTION=INSERT&ADIF=<QSO_DATE:8>20190203 <TIME_ON:6>181745 <CALL:5>G0OMH <BAND:4>70cm <MODE:2>FM <OPERATOR:5>G7WIR <MY_COUNTRY:7>England <STATION_CALLSIGN:5>G7WIR <RST_RCVD:2>59 <RST_SENT:2>59 <GRIDSQUARE:6>JO01bj <FREQ_RX:8>0.000000 <DISTANCE:8>1.242414 <QSLMSG:0> <EOR>
18:17:50  HRD Interface                       Error .: Command  = Get Radio
18:17:50  HRD Interface                       Error .: Status   = Not connected
18:17:50  HRD Interface                       Error .: Elapased = 0ms
18:17:50  HRD Interface                       Error .: History (last 0 commands)
18:17:50  HRD Interface                       Error .: Command  = set button-select split 0
18:17:50  HRD Interface                       Error .: Status   = Not connected
18:17:50  HRD Interface                       Error .: Elapased = 0ms
18:17:50  HRD Interface                       Error .: History (last 0 commands)
18:17:50  HRD Interface                       Error .: Command  = set button-select Spl_Off 1
18:17:50  HRD Interface                       Error .: Status   = Not connected
18:17:50  HRD Interface                       Error .: Elapased = 0ms
18:17:50  HRD Interface                       Error .: History (last 0 commands)
18:17:50  Clublog Upload                      Uploading QSO
18:17:50  Clublog Upload                       Clublog ADIF record:
18:17:50  ALE Worked                          Refresh: Call="", Country=""

18:17:50  QRZ.com Upload                      Reply from QRZ.com: 

K7ZCZ

2019-02-03 18:03

administrator   ~0007250

Lookup at the 181809 file, we see the lookup order is as expected:
18:17:25  ALE Lookup                          Lookup from Previous Logbook Entry for G0UJA completed in 0.375 seconds

18:17:25  ALE Lookup                          Lookup from QRZ.com Online Database: G0UJA
18:17:25  ALE Lookup                          Lookup from QRZ.com Online Database for G0UJA completed in 0.063 seconds

18:17:25  ALE Lookup                          Lookup from Country Index for G0UJA completed in 0.000 seconds
18:17:45  ALE Lookup                          Lookup from Previous Logbook Entry for G0OMH completed in 0.328 seconds

18:17:45  ALE Lookup                          Lookup from QRZ.com Online Database: G0OMH
18:17:45  ALE Lookup                          Lookup from QRZ.com Online Database for G0OMH completed in 0.078 seconds

18:17:45  ALE Lookup                          Lookup from Country Index for G0OMH completed in 0.000 seconds



Then this is the 181256 file:

18:12:32  ALE Lookup                          Lookup from Previous Logbook Entry for G0OMH timedout at 0.454 seconds

18:12:32  ALE Lookup                          Lookup from QRZ.com Online Database: G0OMH
18:12:40  ALE Lookup                          Lookup from QRZ.com Online Database for G0OMH timed out
18:12:40  ALE Lookup                          Lookup from QRZ.com Online Database for G0OMH cancelled at 7.609 seconds


Is this not what you expect? The ordering matches your repro steps.

g3ucq

2019-02-18 10:59

updater   ~0007427

There are a few disgruntled users that this bug still exists.
I suggest a fix is implemented soon.

K7ZCZ

2019-02-19 09:30

administrator   ~0007429

I'm not able to reproduce the problem described in this issue -- I never have been. The logging output in note #7250 above shows that the logbook is being searched, the QRZ is being queried -- which also matches the ordering settings given in the repro case.

Mantis 3147 is fixed in the 194 beta. That issue can present symptoms which might be interpreted as the ordering being wrong, so I suggest testing with that build and watching the logfile output. The logfile output was further enhanced by changes made with Mantis 3145, which was fixed a couple weeks ago.

g3ucq

2019-02-19 10:46

updater   ~0007430

1: Add a Contact for G3UCQ at his Home QTH Hayle
G3UCQ travels /M to Plymouth
2: Add a Contact for G3UCQ/M QTH Plymouth
3: Add another Contact for G3UCQ/M and note that the Callsign Lookup is showing the QTH as Hayle, not Plymouth.
The order for Callsign Lookup is Logbook then QRZ.com.

g3ucq

2019-02-20 04:48

updater   ~0007454

This seems to be the same issue as in Mantis 3147 in which case the problem has been fixed with .194

Issue History

Date Modified Username Field Change
2019-01-28 06:47 PD9FER New Issue
2019-01-28 14:46 K7ZCZ Relationship added related to 0003001
2019-01-28 14:46 K7ZCZ Note Added: 0007107
2019-01-28 16:53 PD9FER Note Added: 0007109
2019-01-28 16:54 PD9FER Note Added: 0007110
2019-01-28 16:59 K7ZCZ Note Added: 0007111
2019-01-28 17:01 K7ZCZ Note Edited: 0007111 View Revisions
2019-01-28 22:10 K7ZCZ Note Added: 0007112
2019-01-29 00:48 PD9FER Note Added: 0007113
2019-01-29 10:27 K7ZCZ Note Added: 0007118
2019-01-29 11:03 PD9FER Note Added: 0007120
2019-01-30 17:53 K7ZCZ Note Added: 0007170
2019-01-31 04:15 PD9FER Note Added: 0007177
2019-02-01 10:32 PD9FER Note Added: 0007197
2019-02-01 11:51 PD9FER Note Added: 0007198
2019-02-01 15:48 K7ZCZ Relationship added related to 0003147
2019-02-01 15:48 K7ZCZ Relationship added related to 0003145
2019-02-01 15:53 K7ZCZ Assigned To => PD9FER
2019-02-01 15:53 K7ZCZ Status new => feedback
2019-02-01 15:53 K7ZCZ Note Added: 0007204
2019-02-03 12:42 PD9FER File Added: HRD Logbook Logfile 2019-02-03 181256.txt
2019-02-03 12:42 PD9FER File Added: HRD Logbook Logfile 2019-02-03 181809.txt
2019-02-03 12:42 PD9FER Note Added: 0007245
2019-02-03 18:03 K7ZCZ Note Added: 0007250
2019-02-06 08:31 K7ZCZ Summary Logbook ALE lookup disregards position set in Callsing Lookup order => Logbook ALE lookup disregards position set in Callsign Lookup order
2019-02-18 10:59 g3ucq Note Added: 0007427
2019-02-19 09:30 K7ZCZ Note Added: 0007429
2019-02-19 10:46 g3ucq Note Added: 0007430
2019-02-20 04:48 g3ucq Note Added: 0007454
2019-02-28 16:05 WA9PIE Status feedback => closed
2019-02-28 16:05 WA9PIE Resolution open => duplicate
2019-02-28 16:05 WA9PIE Project 1 - Backlog => 4 - Closed w/o Action