View Issue Details

IDProjectCategoryView StatusLast Update
0003152Ham Radio DeluxeEnhancementpublic2019-02-24 15:13
ReporterWA9PIEAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version6.5.0.196 
Summary0003152: Add seconds to the hh:mm display above the "Next Pass" time graphs
DescriptionI'm getting feedback from AMSAT operators that HRD Satellite Tracking "is a few seconds behind the actual satellite pass."

There's no way to know this for certain until we do some more testing. But for sure, we need to add seconds to the Next Pass AOS time that is shown above the time graph.

See attached image.

We would need this for either time format selected by the user - Local TIme or UTC (GMT).
TagsNo tags attached.
ModuleSatellite Tracking
Sub-ModuleAppearance/UI
Testing Beta Successful

Relationships

related to 0003169 closedWA9PIE 4 - Closed w/o Action HRD SatTrack seems to be several seconds behind the actual and accurate tracking. 

Activities

WA9PIE

2019-02-02 14:05

administrator  

SatellitePassComparisonAddSeconds.png (747,401 bytes)

K7ZCZ

2019-02-02 14:51

administrator   ~0007224

Pass times, to the second, are already available in the text view.

K7ZCZ

2019-02-06 14:21

administrator   ~0007293

If the detailed times in the text view aren't adequate for testing, it's not clear to me where they should be reformatted. The screenshots here indicate the "Next Passes" pane. Should the format be changed only there, or should it be added to the Next Passes view, as well?

WA9PIE

2019-02-06 14:35

administrator   ~0007294

It’s not so much “testing”, but the time above the time graph should match the time on AMSAT’s charts so they’re easy to compare (given the concerns about our product being several seconds behind).

K7ZCZ

2019-02-06 14:51

administrator   ~0007296

The text view is available by following these steps. These instructions also highlight the difference between the "next passes" dockable pane and the "Next Passes" view.

1) Start Satellite Tracker
2) Click on the "satellite Definitions" tab
3) Click on the "Enable None" button to unselect all satellites
4) Mark the checkbox for any single satellite definition in the list to select it
5) Click on the "Next passes" button in the main toolbar. This creates a "next passes" view for that satellite. Note that the "Next passes" view is a different window, with a different implementation, than the dockable "Next passes" pane.

6) In the toolbar in the Next Passes view for the selected satellite, click the "Text" button in the toolbar.

7) This (eventually; it's quite slow) produces a text description of the satellite passes. For the satellite I happened to select, at my location, today, these are the first few lines shown:

Satellite                  AOS       LOS  Duration  Peak AZ  Peak EL
--------------------------------------------------------------------
ALMASAT-1  2019-02-06 19:25:45  19:34:26  00:08:41    53.8°    24.8°
ALMASAT-1  2019-02-07 10:33:21  10:42:54  00:09:33   114.9°    31.3°
ALMASAT-1  2019-02-07 20:10:15  20:19:07  00:08:52   245.5°    33.3°
ALMASAT-1  2019-02-08 11:17:56  11:27:23  00:09:27   303.4°    32.4°
ALMASAT-1  2019-02-08 19:20:00  19:29:03  00:09:03    58.5°    58.6°
ALMASAT-1  2019-02-09 10:27:33  10:37:15  00:09:42   122.3°    73.9°
ALMASAT-1  2019-02-09 18:29:57  18:38:24  00:08:27    52.7°    18.8°
ALMASAT-1  2019-02-10 09:37:42  09:46:49  00:09:07   112.6°    22.2°
ALMASAT-1  2019-02-10 19:14:13  19:23:17  00:09:04   244.1°    51.0°

K7ZCZ

2019-02-06 20:03

administrator   ~0007298

Last edited: 2019-02-07 10:06

View 2 revisions

HH:MM times are shown in several places:

1) Next Passes view in elevation mode
2) Next Passes docking pane in elevation mode (as pictured above)
3) Next Passes view in radar mode
4) Next Passes docking pane in radar mode
5) Next Passes view in world map mode
6) Next Passes docking pane in world map mode

It's not hard to switch one (or all) of these to include seconds. Just need to know which we want.

I'm asking because the issue seems to say only the docking view, and only elevation mode should be changed and it doesn't seem like we'd purposefully ignore the other settings.

Further, if the goal is to be able to comapre to-the-second data to another site, it seems like the text view is really the easiest way to do that. The text view already shows seconds.

WA9PIE

2019-02-07 03:21

administrator   ~0007303

I'll give this some consideration. But for consistency's sake, I'm not sure why the we're the only ones not consistently displaying ss in all the references to times for the passes. It leads to questions about being accurate, compared to AMSAT's data.

K7ZCZ

2019-02-07 07:58

administrator   ~0007304

There can be lots of rationale for limiting precision. I've no way of knowing why a previous decision was made. It seems best to focus on what we want in the future, and work towards that.

Once we decide what we want, I can implement it. Let me know.

WA9PIE

2019-02-08 11:22

administrator   ~0007323

Based on a side-by-side review of the text version in HRD SatTrack... to AMSAT's tracking site... it leads me to conclude that the feedback from the AMSAT operators is accurate. That is - HRD SatTrack seems to be several seconds behind the actual and accurate tracking.

There are some AMSAT guys here at Hamcation. I'mm going to see if they know who it is that understands the math well.

This may be a dumb question, but...

Can you slice or describe the formula used to calculate the path of the satellite's pass times?

K7ZCZ

2019-02-08 11:43

administrator   ~0007324

Last edited: 2019-02-08 11:44

View 2 revisions

This issue is about changing the formatting of the display of AOS and LOS times. If we're concerned about the accuracy of those times, I must insist that's a different issue and should be tracked separately, in its own Mantis issue. When we use a single Mantis issue to track multiple problems, measuring progress, testing, and resolution become more difficult than they should be.

Once that issue is opened, I can add notes about the math to it.

If we'd still like to add seconds to certain displays of AOS and LOS times in the Satellite Tracker, please let me know which places should display in that format and I can make the change. If we no longer want to consider that change, we should resolve this issue as "won't fix".

K7ZCZ

2019-02-08 13:21

administrator   ~0007328

I have created Mantis 3169 to track (LOL!) the accuracy concerns.

WA9PIE

2019-02-08 18:02

administrator   ~0007333

Thanks.

The accuracy being a different issue, let's resolve to change our approach in SatTrack to where all times are displayed in hh:mm:ss. I was looking through images of competing software for this today and all of them use hh:mm:ss format.

So let's change 'em all.

K7ZCZ

2019-02-08 18:53

administrator   ~0007334

All the time displays I could find now inclue seconds with this change set:

https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4817

WA9PIE

2019-02-13 14:38

administrator   ~0007380

Validated

Issue History

Date Modified Username Field Change
2019-02-02 14:05 WA9PIE New Issue
2019-02-02 14:05 WA9PIE Status new => assigned
2019-02-02 14:05 WA9PIE Assigned To => K7ZCZ
2019-02-02 14:05 WA9PIE File Added: SatellitePassComparisonAddSeconds.png
2019-02-02 14:51 K7ZCZ Note Added: 0007224
2019-02-06 14:21 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-02-06 14:21 K7ZCZ Status assigned => feedback
2019-02-06 14:21 K7ZCZ Note Added: 0007293
2019-02-06 14:35 WA9PIE Note Added: 0007294
2019-02-06 14:35 WA9PIE Assigned To WA9PIE => K7ZCZ
2019-02-06 14:51 K7ZCZ Note Added: 0007296
2019-02-06 20:03 K7ZCZ Note Added: 0007298
2019-02-06 20:03 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-02-07 03:21 WA9PIE Note Added: 0007303
2019-02-07 07:58 K7ZCZ Note Added: 0007304
2019-02-07 10:06 K7ZCZ Note Edited: 0007298 View Revisions
2019-02-08 11:22 WA9PIE Note Added: 0007323
2019-02-08 11:22 WA9PIE Assigned To WA9PIE => K7ZCZ
2019-02-08 11:43 K7ZCZ Note Added: 0007324
2019-02-08 11:43 K7ZCZ Assigned To K7ZCZ => WA9PIE
2019-02-08 11:44 K7ZCZ Note Edited: 0007324 View Revisions
2019-02-08 13:21 K7ZCZ Relationship added related to 0003169
2019-02-08 13:21 K7ZCZ Note Added: 0007328
2019-02-08 18:02 WA9PIE Note Added: 0007333
2019-02-08 18:02 WA9PIE Assigned To WA9PIE => K7ZCZ
2019-02-08 18:53 K7ZCZ Status feedback => resolved
2019-02-08 18:53 K7ZCZ Resolution open => fixed
2019-02-08 18:53 K7ZCZ Note Added: 0007334
2019-02-13 07:59 K7ZCZ Fixed in Version => 6.5.0.192
2019-02-13 14:38 WA9PIE Status resolved => closed
2019-02-13 14:38 WA9PIE Description Updated View Revisions
2019-02-13 14:38 WA9PIE Testing Not Started => Beta Successful
2019-02-13 14:38 WA9PIE Note Added: 0007380
2019-02-24 14:36 WA9PIE Fixed in Version 6.5.0.192 => 6.5.0.196
2019-02-24 15:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe