View Issue Details

IDProjectCategoryView StatusLast Update
0003170Ham Radio DeluxeBugpublic2019-02-24 15:13
ReporterK7ZCZAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version6.5.0.183 
Target VersionFixed in Version6.5.0.196 
Summary0003170: Rig Control sometimes shows duplicate COM ports
DescriptionI've been migrating the Rig Control code to use a faster, more reliable COM port enumeration function. The new enumeration works great, it's much faster. It's capable of enumerating all devices that are configured, or enumerating only the devices configured and also actually connected to the machine.

Unfortunately, that's backward in a few spots. For example, in the Rig Control's main connect dialog, the drop-down for the COM port on a new connection include all configured COM devices, when it should only show those that are actually connected.

This problem also exists in a few other spots -- WinKeyer connection dialog, ATU connection dialog, and so on. The Virtual 3rd Party config dialog is one place where we must list all devices, not just those connected, as virtual devices don't have a connected state that perfectly matches our context.


Steps To Reproduce1) Fire up Rig Control
2) In the connect dialog, drop down the list of available COM ports

BUG#1) It probably includes duplicate names -- the same COM port number is listed multiple times.



TagsNo tags attached.
ModuleRig Control
Sub-ModuleRadio Support
Testing Beta Successful

Relationships

related to 0003076 closedK7ZCZ 3rd-Party Serial Port dialog is slow to open 
related to 0003070 closedK7ZCZ Opening Command Tester in Rig Control is very slow 

Activities

K7ZCZ

2019-02-08 14:17

manager   ~0007329

fixed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4815

WA9PIE

2019-02-20 00:16

administrator   ~0007448

Validated (though I wonder if this caused a removal of a valid COM port that is now the cause of my "Encountered an improper argument" error when launching Rig Control.

Issue History

Date Modified Username Field Change
2019-02-08 14:14 K7ZCZ New Issue
2019-02-08 14:17 K7ZCZ Assigned To => K7ZCZ
2019-02-08 14:17 K7ZCZ Status new => resolved
2019-02-08 14:17 K7ZCZ Resolution open => fixed
2019-02-08 14:17 K7ZCZ Note Added: 0007329
2019-02-08 14:18 K7ZCZ Relationship added related to 0003076
2019-02-08 14:18 K7ZCZ Relationship added related to 0003070
2019-02-13 07:59 K7ZCZ Fixed in Version => 6.5.0.192
2019-02-20 00:16 WA9PIE Status resolved => closed
2019-02-20 00:16 WA9PIE Description Updated View Revisions
2019-02-20 00:16 WA9PIE Steps to Reproduce Updated View Revisions
2019-02-20 00:16 WA9PIE Testing Not Started => Beta Successful
2019-02-20 00:16 WA9PIE Note Added: 0007448
2019-02-24 14:36 WA9PIE Fixed in Version 6.5.0.192 => 6.5.0.196
2019-02-24 15:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe