View Issue Details

IDProjectCategoryView StatusLast Update
0003172Ham Radio DeluxeBugpublic2019-02-24 15:13
ReporterK7ZCZAssigned ToK7ZCZ 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version6.4.0.907 
Target VersionFixed in Version6.5.0.196 
Summary0003172: Rig Control has an unused "Updates" setting
DescriptionThe Rig Control app has an unused setting which might have previously determined the period at which the application would query a website for updates. The setting is completely unused and should be removed.

Steps To Reproduce1) Start up Rig Control. Don't need a specific radio.
2) In the "Tools" menu, use the "Program Options" command
3) Select the "Updates" tab in the resulting "Options" window

BUG#1) This setting isn't used anywhere in the application. At all.

TagsNo tags attached.
ModuleRig Control
Sub-ModuleAppearance/UI
Testing Beta Successful

Activities

KB3NPH

2019-02-11 11:00

administrator   ~0007352

The "Updates" option was originally a popular feature in the Simon Brown versions of Ham Radio Deluxe. It was used to configure the option to check Simon's website at the configured intervals and inform the user when Simon posted a new update to Ham Radio Deluxe on his website. This was disabled in V6.0. Since it has been disabled, there is hardly a day or week that goes by where someone has requested it be put back in our versions so that users know when a new release has been posted on our website.

PD9FER

2019-02-11 11:07

viewer   ~0007353

Since we only support current versions, it would be great for a weekly check
or just a check upon starting HRD

K7ZCZ

2019-02-14 12:46

manager   ~0007393

removed with this checkin:
https://hrdsoftware.visualstudio.com/HRD/_versionControl/changeset/4824

WA9PIE

2019-02-20 00:10

administrator   ~0007446

Validated

Issue History

Date Modified Username Field Change
2019-02-11 09:29 K7ZCZ New Issue
2019-02-11 11:00 KB3NPH Note Added: 0007352
2019-02-11 11:07 PD9FER Note Added: 0007353
2019-02-14 12:46 K7ZCZ Assigned To => K7ZCZ
2019-02-14 12:46 K7ZCZ Status new => resolved
2019-02-14 12:46 K7ZCZ Resolution open => fixed
2019-02-14 12:46 K7ZCZ Note Added: 0007393
2019-02-19 19:05 K7ZCZ Fixed in Version => 6.5.0.194
2019-02-20 00:10 WA9PIE Status resolved => closed
2019-02-20 00:10 WA9PIE Description Updated View Revisions
2019-02-20 00:10 WA9PIE Steps to Reproduce Updated View Revisions
2019-02-20 00:10 WA9PIE Testing Not Started => Beta Successful
2019-02-20 00:10 WA9PIE Note Added: 0007446
2019-02-24 14:36 WA9PIE Fixed in Version 6.5.0.194 => 6.5.0.196
2019-02-24 15:13 WA9PIE Project 3 - Current Dev List => Ham Radio Deluxe